summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-05-23 11:17:20 +0000
committerAlin Năstac <mrness@gentoo.org>2007-05-23 11:17:20 +0000
commit74b74a52853970e09f3eb8f4fbc9f89016b19558 (patch)
treee6afb2843d4f4d8f8be5e7c48a1f08d2283a0064 /sys-fs
parent Pick up 3.5.6 patch. (diff)
downloadgentoo-2-74b74a52853970e09f3eb8f4fbc9f89016b19558.tar.gz
gentoo-2-74b74a52853970e09f3eb8f4fbc9f89016b19558.tar.bz2
gentoo-2-74b74a52853970e09f3eb8f4fbc9f89016b19558.zip
Fix QA notices.
(Portage version: 2.1.2.7)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/siefs/ChangeLog8
-rw-r--r--sys-fs/siefs/files/digest-siefs-0.5-r1 (renamed from sys-fs/siefs/files/digest-siefs-0.5)0
-rw-r--r--sys-fs/siefs/files/siefs-0.5-qa-fixes.patch40
-rw-r--r--sys-fs/siefs/siefs-0.5-r1.ebuild (renamed from sys-fs/siefs/siefs-0.5.ebuild)9
4 files changed, 54 insertions, 3 deletions
diff --git a/sys-fs/siefs/ChangeLog b/sys-fs/siefs/ChangeLog
index 009ba72d1444..b584ad13d0e2 100644
--- a/sys-fs/siefs/ChangeLog
+++ b/sys-fs/siefs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/siefs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/siefs/ChangeLog,v 1.9 2007/05/12 02:21:54 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/siefs/ChangeLog,v 1.10 2007/05/23 11:17:20 mrness Exp $
+
+*siefs-0.5-r1 (23 May 2007)
+
+ 23 May 2007; Alin Năstac <mrness@gentoo.org>
+ +files/siefs-0.5-qa-fixes.patch, -siefs-0.5.ebuild, +siefs-0.5-r1.ebuild:
+ Fix QA notices.
12 May 2007; Daniel Drake <dsd@gentoo.org> metadata.xml:
Move from kernel to kernel-misc herd
diff --git a/sys-fs/siefs/files/digest-siefs-0.5 b/sys-fs/siefs/files/digest-siefs-0.5-r1
index 26d7aad04a08..26d7aad04a08 100644
--- a/sys-fs/siefs/files/digest-siefs-0.5
+++ b/sys-fs/siefs/files/digest-siefs-0.5-r1
diff --git a/sys-fs/siefs/files/siefs-0.5-qa-fixes.patch b/sys-fs/siefs/files/siefs-0.5-qa-fixes.patch
new file mode 100644
index 000000000000..59feeae61e11
--- /dev/null
+++ b/sys-fs/siefs/files/siefs-0.5-qa-fixes.patch
@@ -0,0 +1,40 @@
+diff -Nru siefs-0.5.orig/siefs/charset.c siefs-0.5/siefs/charset.c
+--- siefs-0.5.orig/siefs/charset.c 2005-04-05 17:15:47.000000000 +0300
++++ siefs-0.5/siefs/charset.c 2007-05-23 14:13:19.000000000 +0300
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <ctype.h>
+
+diff -Nru siefs-0.5.orig/siefs/comm.c siefs-0.5/siefs/comm.c
+--- siefs-0.5.orig/siefs/comm.c 2005-04-05 02:53:38.000000000 +0300
++++ siefs-0.5/siefs/comm.c 2007-05-23 14:12:32.000000000 +0300
+@@ -15,6 +15,7 @@
+ #include <termios.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <stdarg.h>
+ #include <errno.h>
+ #include "comm.h"
+@@ -114,7 +115,7 @@
+ if (fd < 0) return -1;
+ h->fd = fd;
+
+- bzero(&tio, sizeof(tio));
++ memset(&tio, 0, sizeof(tio));
+ f = commflags(h->speed);
+ if (f == -1) return -1;
+ tio.c_cflag = f;
+diff -Nru siefs-0.5.orig/siefs/transport.c siefs-0.5/siefs/transport.c
+--- siefs-0.5.orig/siefs/transport.c 2005-04-05 18:06:44.000000000 +0300
++++ siefs-0.5/siefs/transport.c 2007-05-23 14:13:00.000000000 +0300
+@@ -10,6 +10,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <errno.h>
+ #include "comm.h"
+ #include "crcmodel.h"
diff --git a/sys-fs/siefs/siefs-0.5.ebuild b/sys-fs/siefs/siefs-0.5-r1.ebuild
index e5abb8793ff1..92a4153ad66e 100644
--- a/sys-fs/siefs/siefs-0.5.ebuild
+++ b/sys-fs/siefs/siefs-0.5-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/siefs/siefs-0.5.ebuild,v 1.4 2006/07/05 16:48:45 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/siefs/siefs-0.5-r1.ebuild,v 1.1 2007/05/23 11:17:20 mrness Exp $
+
+inherit eutils
DESCRIPTION="Siemens FS"
HOMEPAGE="http://chaos.allsiemens.com/siefs"
@@ -15,7 +17,10 @@ DEPEND="sys-fs/fuse"
src_unpack() {
unpack ${A}
+
cd "${S}/siefs"
+ epatch "${FILESDIR}"/${P}-qa-fixes.patch
+
sed -i "s:-rm -f /sbin/mount.siefs:-mkdir \$(DESTDIR)/sbin/:" Makefile.in
sed -i "s:-ln -s \$(DESTDIR)\$(bindir)/siefs /sbin/mount.siefs:-ln -s ..\$(bindir)/siefs \$(DESTDIR)/sbin/mount.siefs:" Makefile.in
sed -i "s:LDADD = \$(fuseinst)/lib/libfuse.a:LDADD = -lfuse:" Makefile.in