summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-02-29 12:35:36 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-02-29 12:35:36 +0000
commitbbc1094cb10d78af9ebc53ae9c94534cc41e3f65 (patch)
tree31504b8be961ad53b3ddd28487e9121fab1e271d /sys-kernel/aa-sources
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-bbc1094cb10d78af9ebc53ae9c94534cc41e3f65.tar.gz
gentoo-2-bbc1094cb10d78af9ebc53ae9c94534cc41e3f65.tar.bz2
gentoo-2-bbc1094cb10d78af9ebc53ae9c94534cc41e3f65.zip
Vresion bump; closes bug #43241.
Diffstat (limited to 'sys-kernel/aa-sources')
-rw-r--r--sys-kernel/aa-sources/ChangeLog7
-rw-r--r--sys-kernel/aa-sources/aa-sources-2.4.23-r2.ebuild67
-rw-r--r--sys-kernel/aa-sources/files/digest-aa-sources-2.4.23-r22
3 files changed, 75 insertions, 1 deletions
diff --git a/sys-kernel/aa-sources/ChangeLog b/sys-kernel/aa-sources/ChangeLog
index 855d8fb39122..ed34ca3cb913 100644
--- a/sys-kernel/aa-sources/ChangeLog
+++ b/sys-kernel/aa-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/aa-sources
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aa-sources/ChangeLog,v 1.29 2004/02/27 11:52:12 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aa-sources/ChangeLog,v 1.30 2004/02/29 12:35:36 plasmaroo Exp $
+
+*aa-sources-2.4.23-r2 (29 Feb 2004)
+
+ 29 Feb 2004; <plasmaroo@gentoo.org> aa-sources-2.4.23-r2.ebuild:
+ Version bump; closes bug #43241.
18 Feb 2004; <plasmaroo@gentoo.org> aa-sources-2.4.23-r1.ebuild,
files/aa-sources-2.4.23.munmap.patch:
diff --git a/sys-kernel/aa-sources/aa-sources-2.4.23-r2.ebuild b/sys-kernel/aa-sources/aa-sources-2.4.23-r2.ebuild
new file mode 100644
index 000000000000..3392d6b54f90
--- /dev/null
+++ b/sys-kernel/aa-sources/aa-sources-2.4.23-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aa-sources/aa-sources-2.4.23-r2.ebuild,v 1.1 2004/02/29 12:35:36 plasmaroo Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version.
+
+ETYPE="sources"
+
+inherit kernel
+
+# AAV=andrea arcangeli release version
+AAV=aa${PR/r/}
+# KV=patched kernel version
+KV="${PV/_/-}-${AAV}"
+# OKV=original kernel version as provided by ebuild
+OKV="`echo ${KV} | cut -d- -f1`"
+# OKVLAST=(working) last digit of OKV
+OKVLAST="`echo ${OKV} | cut -d. -f3`"
+# OKVLASTPR=the previous kernel version (for a marcelo pre/rc release)
+OKVLASTPR="`expr ${OKVLAST} - 1`"
+# If _ isn't there, then it's a stable+ac, otherwise last-stable+pre/rc+ac
+PRERC="`echo ${PV}|grep \_`"
+
+# Other working variables
+S=${WORKDIR}/linux-${KV}
+EXTRAVERSION="`echo ${KV}|sed -e 's:[^-]*\(-.*$\):\1:'`"
+BASE="`echo ${KV}|sed -e s:${EXTRAVERSION}::`"
+
+# If it's a last-stable+pre/rc+aa (marcelo), we need to handle it differently
+# ourkernel is the stable kernel we'll be working with (previous or current)
+if [ ${PRERC} ]; then
+ OURKERNEL="2.4.${OKVLASTPR}"
+ SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OURKERNEL}.tar.bz2
+ mirror://kernel/linux/kernel/people/andrea/kernels/v2.4/${KV/-}.bz2
+ mirror://kernel/linux/kernel/v2.4/testing/patch-${PV/_/-}.bz2"
+else
+ OURKERNEL="2.4.${OKVLAST}"
+ SRC_URI="mirror://kernel//linux/kernel/v2.4/linux-${OURKERNEL}.tar.bz2
+ mirror://kernel/linux/kernel/people/andrea/kernels/v2.4/${KV/-}.bz2"
+fi
+
+DESCRIPTION="Full sources for Andrea Arcangeli's Linux kernel"
+KEYWORDS="x86"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack linux-${OURKERNEL}.tar.bz2
+ mv linux-${OURKERNEL} linux-${KV} || die
+ cd linux-${KV}
+
+ # if we need a pre/rc patch, then use it
+ if [ ${PRERC} ]; then
+ bzcat ${DISTDIR}/patch-${PV/_/-}.bz2|patch -p1 || die "-marcelo patch failed"
+ fi
+
+ bzcat ${DISTDIR}/${KV/-}.bz2|patch -p1 || die "-aa patch failed"
+ sed -e '51i \ qsort.o \\' -i fs/xfs/support/Makefile || die "XFS patch failed!"
+
+ epatch ${FILESDIR}/${P}.CAN-2003-0985.patch || die "Failed to apply mremap() patch!"
+ epatch ${FILESDIR}/${P}.CAN-2004-0001.patch || die "Failed to apply AMD64 ptrace patch!"
+ epatch ${FILESDIR}/${P}.rtc_fix.patch || die "Failed to apply RTC patch!"
+ # The munmap() patch is already in aa2...
+
+ kernel_universal_unpack
+}
diff --git a/sys-kernel/aa-sources/files/digest-aa-sources-2.4.23-r2 b/sys-kernel/aa-sources/files/digest-aa-sources-2.4.23-r2
new file mode 100644
index 000000000000..c09c15bfa6cf
--- /dev/null
+++ b/sys-kernel/aa-sources/files/digest-aa-sources-2.4.23-r2
@@ -0,0 +1,2 @@
+MD5 642af5ab5e1fc63685fde85e9ae601e4 linux-2.4.23.tar.bz2 29832609
+MD5 4d3cdc11578f59ecc163815dc7cd867d 2.4.23aa2.bz2 2036817