summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-02-09 20:10:33 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-02-09 20:10:33 +0000
commit9205b340de65f3427e021d09d6db9946d3d54bb9 (patch)
tree3bbb918359450f7c0f565f5f39949813c722bc4a /sys-kernel/ck-sources
parentAdded hppa to keywords. (diff)
downloadgentoo-2-9205b340de65f3427e021d09d6db9946d3d54bb9.tar.gz
gentoo-2-9205b340de65f3427e021d09d6db9946d3d54bb9.tar.bz2
gentoo-2-9205b340de65f3427e021d09d6db9946d3d54bb9.zip
bump
Diffstat (limited to 'sys-kernel/ck-sources')
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.4.20-r3.ebuild36
-rw-r--r--sys-kernel/ck-sources/files/digest-ck-sources-2.4.20-r32
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-kernel/ck-sources/ck-sources-2.4.20-r3.ebuild b/sys-kernel/ck-sources/ck-sources-2.4.20-r3.ebuild
new file mode 100644
index 000000000000..44d5d4a3478f
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-2.4.20-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.4.20-r3.ebuild,v 1.1 2003/02/09 20:10:33 lostlogic Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version.
+
+ETYPE="sources"
+
+inherit kernel || die
+
+OKV="2.4.20"
+KV="2.4.20-ck${PR/r/}"
+S=${WORKDIR}/linux-${KV}
+
+EXTRAVERSION="-ck${PR/r/}"
+DESCRIPTION="Full sources for the Stock Linux kernel Con Kolivas's high performance patchset"
+HOMEPAGE="http://members.optusnet.com.au/ckolivas/kernel/"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://members.optusnet.com.au/ckolivas/kernel/ck${PR/r/}_${OKV}.patch.bz2"
+
+KEYWORDS="x86 -ppc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ bzcat ${DISTDIR}/ck${PR/r/}_${OKV}.patch.bz2 | patch -p0 || die "-patch failed"
+
+ mv linux-${OKV} linux-${KV} || die
+
+ cd linux-${KV}
+
+ kernel_universal_unpack
+}
+
+
diff --git a/sys-kernel/ck-sources/files/digest-ck-sources-2.4.20-r3 b/sys-kernel/ck-sources/files/digest-ck-sources-2.4.20-r3
new file mode 100644
index 000000000000..163e46535321
--- /dev/null
+++ b/sys-kernel/ck-sources/files/digest-ck-sources-2.4.20-r3
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 43a8d339958b7f1906df00644f3263d5 ck3_2.4.20.patch.bz2 1397998