summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2014-08-04 00:00:13 +0000
committerMike Pagano <mpagano@gentoo.org>2014-08-04 00:00:13 +0000
commitc5b4366204454ed37fc0c7071158b8b4fb709513 (patch)
treec2bdfeca75b788ef7f9470ede6816691ec0eabe2 /sys-kernel/gentoo-sources
parentRemove older version (diff)
downloadgentoo-2-c5b4366204454ed37fc0c7071158b8b4fb709513.tar.gz
gentoo-2-c5b4366204454ed37fc0c7071158b8b4fb709513.tar.bz2
gentoo-2-c5b4366204454ed37fc0c7071158b8b4fb709513.zip
Zero copy for infiniband psm userspace driver. ACPI: Disable Windows 8 compatibility for some Lenovo ThinkPads. Ensure that /dev/root doesn't appear in /proc/mounts when bootint without an initramfs. Patch to not lock when UMH is waiting on current thread spawned by linuxrc. (bug #481344). Bootsplash ported by Uladzimir Bely (bug #513334). Support for Pogoplug e02 (bug #460350), adjusted to be opt-in by TomWij. Patch to add Gentoo Linux support config settings and defaults. Kernel patch enables gcc optimizations for additional CPUs.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B576E4E3)
Diffstat (limited to 'sys-kernel/gentoo-sources')
-rw-r--r--sys-kernel/gentoo-sources/ChangeLog14
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-3.16.0.ebuild29
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-kernel/gentoo-sources/ChangeLog b/sys-kernel/gentoo-sources/ChangeLog
index 402b27009b45..150a10bc104d 100644
--- a/sys-kernel/gentoo-sources/ChangeLog
+++ b/sys-kernel/gentoo-sources/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for sys-kernel/gentoo-sources
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.1385 2014/08/02 16:43:11 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.1386 2014/08/04 00:00:13 mpagano Exp $
+
+*gentoo-sources-3.16.0 (03 Aug 2014)
+
+ 03 Aug 2014; Mike Pagano <mpagano@gentoo.org> +gentoo-sources-3.16.0.ebuild:
+ Zero copy for infiniband psm userspace driver. ACPI: Disable Windows 8
+ compatibility for some Lenovo ThinkPads. Ensure that /dev/root doesn't appear
+ in /proc/mounts when bootint without an initramfs. Patch to not lock when UMH
+ is waiting on current thread spawned by linuxrc. (bug #481344). Bootsplash
+ ported by Uladzimir Bely (bug #513334). Support for Pogoplug e02 (bug
+ #460350), adjusted to be opt-in by TomWij. Patch to add Gentoo Linux support
+ config settings and defaults. Kernel patch enables gcc optimizations for
+ additional CPUs.
*gentoo-sources-3.15.8 (02 Aug 2014)
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-3.16.0.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-3.16.0.ebuild
new file mode 100644
index 000000000000..8ac440656f6e
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-3.16.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-3.16.0.ebuild,v 1.1 2014/08/04 00:00:13 mpagano Exp $
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="1"
+K_DEBLOB_AVAILABLE="0"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches"
+IUSE="deblob experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}