summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-01-22 02:25:11 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-01-22 02:25:11 +0000
commit3e1b1b679a249b4184992fdad8e364fe95243c22 (patch)
tree83fcbf046435340e1e462ad8659ec0c52cb20437 /sys-kernel/kurobox-sources/kurobox-sources-2.4.31.ebuild
parentMake modular X friendly, remove media-libs/xpm dependency (diff)
downloadgentoo-2-3e1b1b679a249b4184992fdad8e364fe95243c22.tar.gz
gentoo-2-3e1b1b679a249b4184992fdad8e364fe95243c22.tar.bz2
gentoo-2-3e1b1b679a249b4184992fdad8e364fe95243c22.zip
Adding new kernel sources for kurobox and LinkStation
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-kernel/kurobox-sources/kurobox-sources-2.4.31.ebuild')
-rw-r--r--sys-kernel/kurobox-sources/kurobox-sources-2.4.31.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-kernel/kurobox-sources/kurobox-sources-2.4.31.ebuild b/sys-kernel/kurobox-sources/kurobox-sources-2.4.31.ebuild
new file mode 100644
index 000000000000..9fa117b91445
--- /dev/null
+++ b/sys-kernel/kurobox-sources/kurobox-sources-2.4.31.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/kurobox-sources/kurobox-sources-2.4.31.ebuild,v 1.1 2006/01/22 02:25:11 nerdboy Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+ETYPE="sources"
+inherit kernel-2 eutils
+
+#TIMESTAMP="20050527"
+#[ "${PR}" == "r0" ] && KV=${PV/_/-}-openmosix || KV=${PV/_/-}-openmosix-${PR}
+S=${WORKDIR}/linux-${KV}
+
+DESCRIPTION="Full sources for the Linux kernel, including kurobox hardware patches."
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${PV}.tar.bz2
+ mirror://gentoo/kurobox-${PV}.patch.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/
+ http://www.kurobox.com"
+LICENSE="GPL-2"
+SLOT="${KV}"
+KEYWORDS="-* ~ppc"
+IUSE=""
+
+src_unpack() {
+ unpack linux-${PV}.tar.bz2
+ mv linux-${PV} linux-${KV}
+ cd linux-${KV}
+ epatch ${DISTDIR}/kurobox-${PV}.patch.bz2 || die "kurobox patch failed."
+ unpack_2_4
+}
+
+pkg_postinst() {
+ echo
+ einfo "For documentation about setting up your kurobox - check out"
+ einfo "http://www.kurobox.com/online/tiki-index.php?page=Welcome"
+ einfo "For a more modular and complete kurobox config - check out"
+ einfo "http://dev.gentoo.org/~nerdboy/config-2.4.31-kurobox"
+ echo
+}