summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2015-02-23 02:07:25 +0000
committerAlex Alexander <wired@gentoo.org>2015-02-23 02:07:25 +0000
commit1d624bd23d1a900b6f81dcb751c0b48884cafd95 (patch)
treef27fd3c41ee22756ada8eebcf958df5bf2849ab6 /sys-kernel/pf-sources
parentAdd docs USE flag and add proper dependency, bug 534122. (diff)
downloadgentoo-2-1d624bd23d1a900b6f81dcb751c0b48884cafd95.tar.gz
gentoo-2-1d624bd23d1a900b6f81dcb751c0b48884cafd95.tar.bz2
gentoo-2-1d624bd23d1a900b6f81dcb751c0b48884cafd95.zip
version bump
(Portage version: 2.2.16/cvs/Linux x86_64, signed Manifest commit with key EB9B4AFA)
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/ChangeLog7
-rw-r--r--sys-kernel/pf-sources/pf-sources-3.19_p1.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/sys-kernel/pf-sources/ChangeLog b/sys-kernel/pf-sources/ChangeLog
index 6c797c714037..8dbfe9256b72 100644
--- a/sys-kernel/pf-sources/ChangeLog
+++ b/sys-kernel/pf-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/pf-sources
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.127 2015/02/01 15:43:51 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.128 2015/02/23 02:07:25 wired Exp $
+
+*pf-sources-3.19_p1 (23 Feb 2015)
+
+ 23 Feb 2015; Alex Alexander <wired@gentoo.org> +pf-sources-3.19_p1.ebuild:
+ version bump
01 Feb 2015; Markos Chandras <hwoarang@gentoo.org> -pf-sources-3.15_p4.ebuild,
-pf-sources-3.17_p1.ebuild, -pf-sources-3.17_p2.ebuild:
diff --git a/sys-kernel/pf-sources/pf-sources-3.19_p1.ebuild b/sys-kernel/pf-sources/pf-sources-3.19_p1.ebuild
new file mode 100644
index 000000000000..26092d6bceb7
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-3.19_p1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-3.19_p1.ebuild,v 1.1 2015/02/23 02:07:25 wired Exp $
+
+EAPI="5"
+inherit readme.gentoo versionator
+
+COMPRESSTYPE=".xz"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="$(get_version_component_range 1-2)"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new features, including the -ck patchset (BFS), BFQ, TuxOnIce and UKSM"
+HOMEPAGE="http://pf.natalenko.name/"
+
+PF_VERS="1"
+PF_FILE="patch-${PV/_p*/}-pf${PV/*_p/}${COMPRESSTYPE}"
+PF_URI="http://pf.natalenko.name/sources/$(get_version_component_range 1-2)/${PF_FILE}"
+SRC_URI="${KERNEL_URI} ${PF_URI}" # \${EXPERIMENTAL_URI}
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+KV_FULL="${PVR}-pf"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${P} has the following optional runtime dependencies:
+- sys-apps/tuxonice-userui: provides minimal userspace progress
+information related to suspending and resuming process.
+- sys-power/hibernate-script or sys-power/pm-utils: runtime utilities
+for hibernating and suspending your computer."
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+}
+
+src_install() {
+ kernel-2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ readme.gentoo_print_elog
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+see: ${HOMEPAGE}."