summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-03-19 18:53:38 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-03-19 18:53:38 +0000
commit516545121599c5ea8c6c0196aca4e8cb9e4adb46 (patch)
treed775d4190350ed7998d8fac3315d0bf452b41f26 /sys-kernel
parentBased on vanilla 2.6.37.3 + genpatches-2.6.37.4 + grsecurity-2.2.1-2.6.37.3-2... (diff)
downloadgentoo-2-516545121599c5ea8c6c0196aca4e8cb9e4adb46.tar.gz
gentoo-2-516545121599c5ea8c6c0196aca4e8cb9e4adb46.tar.bz2
gentoo-2-516545121599c5ea8c6c0196aca4e8cb9e4adb46.zip
Based on vanilla 2.6.32.32 + genpatches-2.6.32.34 + grsecurity-2.2.1-2.6.32.32-201103122250
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog9
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.32-r41.ebuild46
2 files changed, 54 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 0386d15d3a1e..eed3f7b6177f 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.397 2011/03/19 18:51:19 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.398 2011/03/19 18:53:38 blueness Exp $
+
+*hardened-sources-2.6.32-r41 (19 Mar 2011)
+
+ 19 Mar 2011; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.32-r41.ebuild:
+ Based on vanilla 2.6.32.32 + genpatches-2.6.32.34 +
+ grsecurity-2.2.1-2.6.32.32-201103122250
*hardened-sources-2.6.37-r6 (19 Mar 2011)
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.32-r41.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r41.ebuild
new file mode 100644
index 000000000000..6b312303c04c
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r41.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.32-r41.ebuild,v 1.1 2011/03/19 18:53:38 blueness Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="34"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-44"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="1032_linux-2.6.32.33.patch 4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.1*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides three different predefined grsecurity level:"
+ ewarn "[server], [workstation], and [virtualization]."
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}