summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-10-29 14:39:00 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-10-29 14:39:00 +0000
commitb4ab7c88815213de3808f52f3b955f9938b15e14 (patch)
tree8e008c0ee08b48671f380c84654be8fa352ab3b4 /sys-kernel
parentVersion bump (diff)
downloadgentoo-2-b4ab7c88815213de3808f52f3b955f9938b15e14.tar.gz
gentoo-2-b4ab7c88815213de3808f52f3b955f9938b15e14.tar.bz2
gentoo-2-b4ab7c88815213de3808f52f3b955f9938b15e14.zip
Version bump
(Portage version: 2.2.0_alpha2/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/pf-sources/ChangeLog8
-rw-r--r--sys-kernel/pf-sources/pf-sources-2.6.36_p1.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/sys-kernel/pf-sources/ChangeLog b/sys-kernel/pf-sources/ChangeLog
index 5ecbbe9c4f03..5ed67d7863aa 100644
--- a/sys-kernel/pf-sources/ChangeLog
+++ b/sys-kernel/pf-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/pf-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.6 2010/10/06 22:00:24 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.7 2010/10/29 14:39:00 hwoarang Exp $
+
+*pf-sources-2.6.36_p1 (29 Oct 2010)
+
+ 29 Oct 2010; Markos Chandras <hwoarang@gentoo.org>
+ +pf-sources-2.6.36_p1.ebuild:
+ Version bump
*pf-sources-2.6.35_p11 (06 Oct 2010)
diff --git a/sys-kernel/pf-sources/pf-sources-2.6.36_p1.ebuild b/sys-kernel/pf-sources/pf-sources-2.6.36_p1.ebuild
new file mode 100644
index 000000000000..dc495c268ca0
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-2.6.36_p1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-2.6.36_p1.ebuild,v 1.1 2010/10/29 14:39:00 hwoarang Exp $
+
+EAPI="2"
+
+COMPRESSTYPE=".bz2"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="${PV/_p[0-9]*}"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new features, including the -ck patchset (BFS), BFQ, TuxOnIce and LinuxIMQ"
+HOMEPAGE="http://pf-kernel.org.ua/"
+
+PF_PATCHSET="${PV/*_p}"
+PF_KERNEL="${PV/_p[0-9]*}"
+PF_KERNEL="${PF_KERNEL/_/-}"
+PF_FILE="patch-${PF_KERNEL}-pf${PF_PATCHSET}${COMPRESSTYPE}"
+PF_URI="http://pf-kernel.org.ua/sources/$(get_version_component_range 1-3)/${PF_FILE}"
+SRC_URI="${KERNEL_URI} ${PF_URI}"
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+KV_FULL="${PVR/_p/-pf}"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ ebeep 8
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems, see: \
+${HOMEPAGE}."