summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2014-08-03 22:03:03 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2014-08-03 22:03:03 +0000
commitfd69c9d1a45f60566f8cae15f8b414b4d8a0a499 (patch)
treeb30c73bbcd9f8baa54bd13a6ddbd837627d5c615 /sys-libs/db
parentBring MySQL-Cluster from the overlay into the tree. Thanks to the great work ... (diff)
downloadgentoo-2-fd69c9d1a45f60566f8cae15f8b414b4d8a0a499.tar.gz
gentoo-2-fd69c9d1a45f60566f8cae15f8b414b4d8a0a499.tar.bz2
gentoo-2-fd69c9d1a45f60566f8cae15f8b414b4d8a0a499.zip
Cleanup ebuilds, some EAPI5 porting.
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/ChangeLog10
-rw-r--r--sys-libs/db/db-4.8.30-r2.ebuild183
-rw-r--r--sys-libs/db/db-5.3.21.ebuild226
-rw-r--r--sys-libs/db/db-5.3.28.ebuild216
-rw-r--r--sys-libs/db/db-6.0.30-r1.ebuild (renamed from sys-libs/db/db-6.0.20-r1.ebuild)106
5 files changed, 253 insertions, 488 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index f28d494e9fe8..a2684aebb786 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.353 2014/07/28 13:49:27 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.354 2014/08/03 22:03:03 robbat2 Exp $
+
+*db-6.0.30-r1 (03 Aug 2014)
+*db-4.8.30-r2 (03 Aug 2014)
+
+ 03 Aug 2014; Robin H. Johnson <robbat2@gentoo.org> +db-4.8.30-r2.ebuild,
+ +db-6.0.30-r1.ebuild, -db-5.3.21.ebuild, -db-5.3.28.ebuild,
+ -db-6.0.20-r1.ebuild:
+ Cleanup ebuilds, some EAPI5 porting.
28 Jul 2014; Agostino Sarubbo <ago@gentoo.org> db-4.8.30-r1.ebuild:
Stable for ppc, wrt bug #512012
diff --git a/sys-libs/db/db-4.8.30-r2.ebuild b/sys-libs/db/db-4.8.30-r2.ebuild
new file mode 100644
index 000000000000..7bd0abec8fe9
--- /dev/null
+++ b/sys-libs/db/db-4.8.30-r2.ebuild
@@ -0,0 +1,183 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.8.30-r2.ebuild,v 1.1 2014/08/03 22:03:03 robbat2 Exp $
+
+EAPI=5
+
+inherit eutils db flag-o-matic java-pkg-opt-2 autotools multilib multilib-minimal
+
+#Number of official patches
+#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
+PATCHNO=${PV/*.*.*_p}
+if [[ ${PATCHNO} == "${PV}" ]] ; then
+ MY_PV=${PV}
+ MY_P=${P}
+ PATCHNO=0
+else
+ MY_PV=${PV/_p${PATCHNO}}
+ MY_P=${PN}-${MY_PV}
+fi
+
+S="${WORKDIR}/${MY_P}/build_unix"
+DESCRIPTION="Oracle Berkeley DB"
+HOMEPAGE="http://www.oracle.com/technology/software/products/berkeley-db/index.html"
+SRC_URI="http://download.oracle.com/berkeley-db/${MY_P}.tar.gz"
+for (( i=1 ; i<=${PATCHNO} ; i++ )) ; do
+ export SRC_URI="${SRC_URI} http://www.oracle.com/technology/products/berkeley-db/db/update/${MY_PV}/patch.${MY_PV}.${i}"
+done
+
+LICENSE="Sleepycat"
+SLOT="4.8"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="doc java cxx tcl test"
+
+REQUIRED_USE="test? ( tcl )"
+
+# the entire testsuite needs the TCL functionality
+DEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1[${MULTILIB_USEDEP}] )
+ test? ( >=dev-lang/tcl-8.5.15-r1[${MULTILIB_USEDEP}] )
+ java? ( >=virtual/jdk-1.5 )
+ >=sys-devel/binutils-2.16.1"
+RDEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1[${MULTILIB_USEDEP}] )
+ java? ( >=virtual/jre-1.5 )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508-r2
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+
+src_prepare() {
+ cd "${WORKDIR}"/"${MY_P}" || die
+ for (( i=1 ; i<=${PATCHNO} ; i++ ))
+ do
+ epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
+ done
+ epatch "${FILESDIR}"/${PN}-4.8-libtool.patch
+ epatch "${FILESDIR}"/${PN}-4.8.24-java-manifest-location.patch
+ epatch "${FILESDIR}"/${PN}-4.8.30-rename-atomic-compare-exchange.patch
+
+ # use the includes from the prefix
+ epatch "${FILESDIR}"/${PN}-4.6-jni-check-prefix-first.patch
+ epatch "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
+
+ sed -e "/^DB_RELEASE_DATE=/s/%B %e, %Y/%Y-%m-%d/" -i dist/RELEASE \
+ || die
+
+ # Include the SLOT for Java JAR files
+ # This supersedes the unused jarlocation patches.
+ sed -r -i \
+ -e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
+ "${S}"/../dist/Makefile.in || die
+
+ cd "${S}"/../dist || die
+ rm -f aclocal/libtool.m4
+ sed -i \
+ -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
+ configure.ac || die
+ sed -i \
+ -e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
+ aclocal/programs.m4 || die
+ AT_M4DIR="aclocal aclocal_java" eautoreconf
+ # Upstream sucks - they do autoconf and THEN replace the version variables.
+ . ./RELEASE
+ sed -i \
+ -e "s/__EDIT_DB_VERSION_MAJOR__/$DB_VERSION_MAJOR/g" \
+ -e "s/__EDIT_DB_VERSION_MINOR__/$DB_VERSION_MINOR/g" \
+ -e "s/__EDIT_DB_VERSION_PATCH__/$DB_VERSION_PATCH/g" \
+ -e "s/__EDIT_DB_VERSION_STRING__/$DB_VERSION_STRING/g" \
+ -e "s/__EDIT_DB_VERSION_UNIQUE_NAME__/$DB_VERSION_UNIQUE_NAME/g" \
+ -e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" configure || die
+}
+
+src_configure() {
+ # Add linker versions to the symbols. Easier to do, and safer than header file
+ # mumbo jumbo.
+ if use userland_GNU ; then
+ append-ldflags -Wl,--default-symver
+ fi
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ local myconf=()
+
+ # compilation with -O0 fails on amd64, see bug #171231
+ if [[ ${ABI} == amd64 ]]; then
+ local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
+ replace-flags -O0 -O2
+ is-flagq -O[s123] || append-flags -O2
+ fi
+
+ # use `set` here since the java opts will contain whitespace
+ if multilib_is_native_abi && use java ; then
+ myconf+=(
+ --with-java-prefix="${JAVA_HOME}"
+ --with-javac-flags="$(java-pkg_javac-args)"
+ )
+ fi
+
+ # Bug #270851: test needs TCL support
+ if use tcl || use test ; then
+ myconf+=(
+ --enable-tcl
+ --with-tcl=/usr/$(get_libdir)
+ )
+ else
+ myconf+=(--disable-tcl )
+ fi
+
+ ECONF_SOURCE="${S}"/../dist \
+ STRIP="true" \
+ econf \
+ --enable-compat185 \
+ --enable-o_direct \
+ --without-uniquename \
+ $([[ ${ABI} == arm ]] && echo --with-mutex=ARM/gcc-assembly) \
+ $([[ ${ABI} == amd64 ]] && echo --with-mutex=x86/gcc-assembly) \
+ $(use_enable cxx) \
+ $(use_enable cxx stl) \
+ $(multilib_native_use_enable java) \
+ "${myconf[@]}" \
+ $(use_enable test)
+}
+
+multilib_src_test() {
+ multilib_is_native_abi || return
+
+ S=${BUILD_DIR} db_src_test
+}
+
+multilib_src_install() {
+ emake install DESTDIR="${D}"
+
+ db_src_install_headerslot
+
+ db_src_install_usrlibcleanup
+
+ if multilib_is_native_abi && use java; then
+ java-pkg_regso "${D}"/usr/"$(get_libdir)"/libdb_java*.so
+ java-pkg_dojar "${D}"/usr/"$(get_libdir)"/*.jar
+ rm -f "${D}"/usr/"$(get_libdir)"/*.jar
+ fi
+}
+
+multilib_src_install_all() {
+ db_src_install_usrbinslot
+
+ db_src_install_doc
+
+ dodir /usr/sbin
+ # This file is not always built, and no longer exists as of db-4.8
+ if [[ -f "${D}"/usr/bin/berkeley_db_svc ]] ; then
+ mv "${D}"/usr/bin/berkeley_db_svc \
+ "${D}"/usr/sbin/berkeley_db"${SLOT/./}"_svc || die
+ fi
+}
+
+pkg_postinst() {
+ multilib_foreach_abi db_fix_so
+}
+
+pkg_postrm() {
+ multilib_foreach_abi db_fix_so
+}
diff --git a/sys-libs/db/db-5.3.21.ebuild b/sys-libs/db/db-5.3.21.ebuild
deleted file mode 100644
index 3479705e28fd..000000000000
--- a/sys-libs/db/db-5.3.21.ebuild
+++ /dev/null
@@ -1,226 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-5.3.21.ebuild,v 1.5 2014/05/20 13:19:07 polynomial-c Exp $
-
-EAPI=2
-inherit eutils db flag-o-matic java-pkg-opt-2 autotools multilib
-
-#Number of official patches
-#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
-PATCHNO=${PV/*.*.*_p}
-if [[ ${PATCHNO} == "${PV}" ]] ; then
- MY_PV=${PV}
- MY_P=${P}
- PATCHNO=0
-else
- MY_PV=${PV/_p${PATCHNO}}
- MY_P=${PN}-${MY_PV}
-fi
-
-S_BASE="${WORKDIR}/${MY_P}"
-S="${S_BASE}/build_unix"
-DESCRIPTION="Oracle Berkeley DB"
-HOMEPAGE="http://www.oracle.com/technology/software/products/berkeley-db/index.html"
-SRC_URI="http://download.oracle.com/berkeley-db/${MY_P}.tar.gz"
-for (( i=1 ; i<=${PATCHNO} ; i++ )) ; do
- export SRC_URI="${SRC_URI} http://www.oracle.com/technology/products/berkeley-db/db/update/${MY_PV}/patch.${MY_PV}.${i}"
-done
-
-LICENSE="Sleepycat"
-SLOT="5.3"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="doc java cxx tcl test"
-
-# the entire testsuite needs the TCL functionality
-DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
- test? ( >=dev-lang/tcl-8.4 )
- java? ( >=virtual/jdk-1.5 )
- >=sys-devel/binutils-2.16.1"
-RDEPEND="tcl? ( dev-lang/tcl )
- java? ( >=virtual/jre-1.5 )"
-
-src_unpack() {
- unpack "${MY_P}".tar.gz
-}
-
-src_prepare() {
- cd "${WORKDIR}"/"${MY_P}"
- for (( i=1 ; i<=${PATCHNO} ; i++ ))
- do
- epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
- done
- #epatch "${FILESDIR}"/${PN}-4.8-libtool.patch
- # upstreamed:5.2.36
- #epatch "${FILESDIR}"/${PN}-4.8.24-java-manifest-location.patch
-
- # bug #510506
- epatch "${FILESDIR}"/${PN}-4.8.24-java-manifest-location.patch
-
- # use the includes from the prefix
- epatch "${FILESDIR}"/${PN}-4.6-jni-check-prefix-first.patch
- epatch "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
-
- # upstream autoconf fails to build DBM when it's supposed to
- # merged upstream in 5.0.26
- #epatch "${FILESDIR}"/${PN}-5.0.21-enable-dbm-autoconf.patch
-
- # sqlite configure call has an extra leading ..
- # upstreamed:5.2.36, missing in 5.3.x
- epatch "${FILESDIR}"/${PN}-5.2.28-sqlite-configure-path.patch
-
- # The upstream testsuite copies .lib and the binaries for each parallel test
- # core, ~300MB each. This patch uses links instead, saves a lot of space.
- epatch "${FILESDIR}"/${PN}-6.0.20-test-link.patch
-
- # Upstream release script grabs the dates when the script was run, so lets
- # end-run them to keep the date the same.
- export REAL_DB_RELEASE_DATE="$(awk \
- '/^DB_VERSION_STRING=/{ gsub(".*\\(|\\).*","",$0); print $0; }' \
- "${S_BASE}"/dist/configure)"
- sed -r -i \
- -e "/^DB_RELEASE_DATE=/s~=.*~='${REAL_DB_RELEASE_DATE}'~g" \
- "${S_BASE}"/dist/RELEASE
-
- # Include the SLOT for Java JAR files
- # This supersedes the unused jarlocation patches.
- sed -r -i \
- -e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
- "${S_BASE}"/dist/Makefile.in
-
- cd "${S_BASE}"/dist
- rm -f aclocal/libtool.m4
- sed -i \
- -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
- configure.ac
- sed -i \
- -e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
- aclocal/programs.m4
- AT_M4DIR="aclocal aclocal_java" eautoreconf
- # Upstream sucks - they do autoconf and THEN replace the version variables.
- . ./RELEASE
- for v in \
- DB_VERSION_{FAMILY,LETTER,RELEASE,MAJOR,MINOR} \
- DB_VERSION_{PATCH,FULL,UNIQUE_NAME,STRING,FULL_STRING} \
- DB_VERSION \
- DB_RELEASE_DATE ; do
- local ev="__EDIT_${v}__"
- sed -i -e "s/${ev}/${!v}/g" configure
- done
-}
-
-src_configure() {
- local myconf=''
-
- # compilation with -O0 fails on amd64, see bug #171231
- if use amd64; then
- replace-flags -O0 -O2
- is-flagq -O[s123] || append-flags -O2
- fi
-
- # use `set` here since the java opts will contain whitespace
- set --
- if use java ; then
- set -- "$@" \
- --with-java-prefix="${JAVA_HOME}" \
- --with-javac-flags="$(java-pkg_javac-args)"
- fi
-
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU ; then
- append-ldflags -Wl,--default-symver
- fi
-
- # Bug #270851: test needs TCL support
- if use tcl || use test ; then
- myconf="${myconf} --enable-tcl"
- myconf="${myconf} --with-tcl=/usr/$(get_libdir)"
- else
- myconf="${myconf} --disable-tcl"
- fi
-
- # sql_compat will cause a collision with sqlite3
- # --enable-sql_compat
- cd "${S}"
- ECONF_SOURCE="${S_BASE}"/dist \
- STRIP="true" \
- econf \
- --enable-compat185 \
- --enable-dbm \
- --enable-o_direct \
- --without-uniquename \
- --enable-sql \
- --enable-sql_codegen \
- --disable-sql_compat \
- $(use arm && echo --with-mutex=ARM/gcc-assembly) \
- $(use amd64 && echo --with-mutex=x86/gcc-assembly) \
- $(use_enable cxx) \
- $(use_enable cxx stl) \
- $(use_enable java) \
- ${myconf} \
- $(use_enable test) \
- "$@"
-}
-
-src_compile() {
- emake || die "make failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
-
- db_src_install_usrbinslot
-
- db_src_install_headerslot
-
- db_src_install_doc
-
- db_src_install_usrlibcleanup
-
- dodir /usr/sbin
- # This file is not always built, and no longer exists as of db-4.8
- [[ -f "${D}"/usr/bin/berkeley_db_svc ]] && \
- mv "${D}"/usr/bin/berkeley_db_svc "${D}"/usr/sbin/berkeley_db"${SLOT/./}"_svc
-
- if use java; then
- java-pkg_regso "${D}"/usr/"$(get_libdir)"/libdb_java*.so
- java-pkg_dojar "${D}"/usr/"$(get_libdir)"/*.jar
- rm -f "${D}"/usr/"$(get_libdir)"/*.jar
- fi
-}
-
-pkg_postinst() {
- db_fix_so
-}
-
-pkg_postrm() {
- db_fix_so
-}
-
-src_test() {
- # db_repsite is impossible to build, as upstream strips those sources.
- # db_repsite is used directly in the setup_site_prog,
- # setup_site_prog is called from open_site_prog
- # which is called only from tests in the multi_repmgr group.
- #sed -ri \
- # -e '/set subs/s,multi_repmgr,,g' \
- # "${S_BASE}/test/testparams.tcl"
- sed -ri \
- -e '/multi_repmgr/d' \
- "${S_BASE}/test/tcl/test.tcl"
-
- # This is the only failure in 5.2.28 so far, and looks like a false positive.
- # Repmgr018 (btree): Test of repmgr stats.
- # Repmgr018.a: Start a master.
- # Repmgr018.b: Start a client.
- # Repmgr018.c: Run some transactions at master.
- # Rep_test: btree 20 key/data pairs starting at 0
- # Rep_test.a: put/get loop
- # FAIL:07:05:59 (00:00:00) perm_no_failed_stat: expected 0, got 1
- sed -ri \
- -e '/set parms.*repmgr018/d' \
- -e 's/repmgr018//g' \
- "${S_BASE}/test/tcl/test.tcl"
-
- db_src_test
-}
diff --git a/sys-libs/db/db-5.3.28.ebuild b/sys-libs/db/db-5.3.28.ebuild
deleted file mode 100644
index 1f8ee8d574b8..000000000000
--- a/sys-libs/db/db-5.3.28.ebuild
+++ /dev/null
@@ -1,216 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-5.3.28.ebuild,v 1.3 2014/05/20 13:19:07 polynomial-c Exp $
-
-EAPI=4
-inherit eutils db flag-o-matic java-pkg-opt-2 autotools multilib
-
-#Number of official patches
-#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
-PATCHNO=${PV/*.*.*_p}
-if [[ ${PATCHNO} == "${PV}" ]] ; then
- MY_PV=${PV}
- MY_P=${P}
- PATCHNO=0
-else
- MY_PV=${PV/_p${PATCHNO}}
- MY_P=${PN}-${MY_PV}
-fi
-
-S_BASE="${WORKDIR}/${MY_P}"
-S="${S_BASE}/build_unix"
-DESCRIPTION="Oracle Berkeley DB"
-HOMEPAGE="http://www.oracle.com/technology/software/products/berkeley-db/index.html"
-SRC_URI="http://download.oracle.com/berkeley-db/${MY_P}.tar.gz"
-for (( i=1 ; i<=${PATCHNO} ; i++ )) ; do
- export SRC_URI="${SRC_URI} http://www.oracle.com/technology/products/berkeley-db/db/update/${MY_PV}/patch.${MY_PV}.${i}"
-done
-
-LICENSE="Sleepycat"
-SLOT="5.3"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="doc java cxx tcl test"
-
-# the entire testsuite needs the TCL functionality
-DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
- test? ( >=dev-lang/tcl-8.4 )
- java? ( >=virtual/jdk-1.5 )
- >=sys-devel/binutils-2.16.1"
-RDEPEND="tcl? ( dev-lang/tcl )
- java? ( >=virtual/jre-1.5 )"
-
-src_unpack() {
- unpack "${MY_P}".tar.gz
-}
-
-src_prepare() {
- cd "${WORKDIR}"/"${MY_P}"
- for (( i=1 ; i<=${PATCHNO} ; i++ ))
- do
- epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
- done
-
- # bug #510506
- epatch "${FILESDIR}"/${PN}-4.8.24-java-manifest-location.patch
-
- # use the includes from the prefix
- epatch "${FILESDIR}"/${PN}-4.6-jni-check-prefix-first.patch
- epatch "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
-
- # sqlite configure call has an extra leading ..
- # upstreamed:5.2.36, missing in 5.3.x
- epatch "${FILESDIR}"/${PN}-5.2.28-sqlite-configure-path.patch
-
- # The upstream testsuite copies .lib and the binaries for each parallel test
- # core, ~300MB each. This patch uses links instead, saves a lot of space.
- epatch "${FILESDIR}"/${PN}-6.0.20-test-link.patch
-
- # Upstream release script grabs the dates when the script was run, so lets
- # end-run them to keep the date the same.
- export REAL_DB_RELEASE_DATE="$(awk \
- '/^DB_VERSION_STRING=/{ gsub(".*\\(|\\).*","",$0); print $0; }' \
- "${S_BASE}"/dist/configure)"
- sed -r -i \
- -e "/^DB_RELEASE_DATE=/s~=.*~='${REAL_DB_RELEASE_DATE}'~g" \
- "${S_BASE}"/dist/RELEASE || die
-
- # Include the SLOT for Java JAR files
- # This supersedes the unused jarlocation patches.
- sed -r -i \
- -e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
- "${S_BASE}"/dist/Makefile.in || die
-
- cd "${S_BASE}"/dist || die
- rm -f aclocal/libtool.m4
- sed -i \
- -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
- configure.ac || die
- sed -i \
- -e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
- aclocal/programs.m4 || die
- AT_M4DIR="aclocal aclocal_java" eautoreconf
- # Upstream sucks - they do autoconf and THEN replace the version variables.
- . ./RELEASE
- for v in \
- DB_VERSION_{FAMILY,LETTER,RELEASE,MAJOR,MINOR} \
- DB_VERSION_{PATCH,FULL,UNIQUE_NAME,STRING,FULL_STRING} \
- DB_VERSION \
- DB_RELEASE_DATE ; do
- local ev="__EDIT_${v}__"
- sed -i -e "s/${ev}/${!v}/g" configure || die
- done
-}
-
-src_configure() {
- local myconf=''
-
- # compilation with -O0 fails on amd64, see bug #171231
- if use amd64; then
- replace-flags -O0 -O2
- is-flagq -O[s123] || append-flags -O2
- fi
-
- # use `set` here since the java opts will contain whitespace
- set --
- if use java ; then
- set -- "$@" \
- --with-java-prefix="${JAVA_HOME}" \
- --with-javac-flags="$(java-pkg_javac-args)"
- fi
-
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU ; then
- append-ldflags -Wl,--default-symver
- fi
-
- # Bug #270851: test needs TCL support
- if use tcl || use test ; then
- myconf="${myconf} --enable-tcl"
- myconf="${myconf} --with-tcl=/usr/$(get_libdir)"
- else
- myconf="${myconf} --disable-tcl"
- fi
-
- # sql_compat will cause a collision with sqlite3
- # --enable-sql_compat
- ECONF_SOURCE="${S_BASE}"/dist \
- STRIP="true" \
- econf \
- --enable-compat185 \
- --enable-dbm \
- --enable-o_direct \
- --without-uniquename \
- --enable-sql \
- --enable-sql_codegen \
- --disable-sql_compat \
- $(use arm && echo --with-mutex=ARM/gcc-assembly) \
- $(use amd64 && echo --with-mutex=x86/gcc-assembly) \
- $(use_enable cxx) \
- $(use_enable cxx stl) \
- $(use_enable java) \
- ${myconf} \
- $(use_enable test) \
- "$@"
-}
-
-src_install() {
- emake install DESTDIR="${D}"
-
- db_src_install_usrbinslot
-
- db_src_install_headerslot
-
- db_src_install_doc
-
- db_src_install_usrlibcleanup
-
- dodir /usr/sbin
- # This file is not always built, and no longer exists as of db-4.8
- if [[ -f "${D}"/usr/bin/berkeley_db_svc ]] ; then
- mv "${D}"/usr/bin/berkeley_db_svc \
- "${D}"/usr/sbin/berkeley_db"${SLOT/./}"_svc || die
- fi
-
- if use java; then
- java-pkg_regso "${D}"/usr/"$(get_libdir)"/libdb_java*.so
- java-pkg_dojar "${D}"/usr/"$(get_libdir)"/*.jar
- rm -f "${D}"/usr/"$(get_libdir)"/*.jar
- fi
-}
-
-pkg_postinst() {
- db_fix_so
-}
-
-pkg_postrm() {
- db_fix_so
-}
-
-src_test() {
- # db_repsite is impossible to build, as upstream strips those sources.
- # db_repsite is used directly in the setup_site_prog,
- # setup_site_prog is called from open_site_prog
- # which is called only from tests in the multi_repmgr group.
- #sed -ri \
- # -e '/set subs/s,multi_repmgr,,g' \
- # "${S_BASE}/test/testparams.tcl"
- sed -ri \
- -e '/multi_repmgr/d' \
- "${S_BASE}/test/tcl/test.tcl" || die
-
- # This is the only failure in 5.2.28 so far, and looks like a false positive.
- # Repmgr018 (btree): Test of repmgr stats.
- # Repmgr018.a: Start a master.
- # Repmgr018.b: Start a client.
- # Repmgr018.c: Run some transactions at master.
- # Rep_test: btree 20 key/data pairs starting at 0
- # Rep_test.a: put/get loop
- # FAIL:07:05:59 (00:00:00) perm_no_failed_stat: expected 0, got 1
- sed -ri \
- -e '/set parms.*repmgr018/d' \
- -e 's/repmgr018//g' \
- "${S_BASE}/test/tcl/test.tcl" || die
-
- db_src_test
-}
diff --git a/sys-libs/db/db-6.0.20-r1.ebuild b/sys-libs/db/db-6.0.30-r1.ebuild
index 230c743f8b8e..6525bbf7d3dc 100644
--- a/sys-libs/db/db-6.0.20-r1.ebuild
+++ b/sys-libs/db/db-6.0.30-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-6.0.20-r1.ebuild,v 1.4 2014/05/20 13:19:07 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-6.0.30-r1.ebuild,v 1.1 2014/08/03 22:03:03 robbat2 Exp $
-EAPI=4
-inherit eutils db flag-o-matic java-pkg-opt-2 autotools multilib
+EAPI=5
+inherit eutils db flag-o-matic java-pkg-opt-2 autotools multilib multilib-minimal versionator
#Number of official patches
#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
@@ -27,21 +27,23 @@ for (( i=1 ; i<=${PATCHNO} ; i++ )) ; do
done
LICENSE="AGPL-3"
-SLOT="6.0"
+SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
IUSE="doc java cxx tcl test"
+REQUIRED_USE="test? ( tcl )"
+
# the entire testsuite needs the TCL functionality
-DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
- test? ( >=dev-lang/tcl-8.4 )
+DEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1[${MULTILIB_USEDEP}] )
+ test? ( >=dev-lang/tcl-8.5.15-r1[${MULTILIB_USEDEP}] )
java? ( >=virtual/jdk-1.5 )
>=sys-devel/binutils-2.16.1"
-RDEPEND="tcl? ( dev-lang/tcl )
+RDEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1[${MULTILIB_USEDEP}] )
java? ( >=virtual/jre-1.5 )"
-src_unpack() {
- unpack "${MY_P}".tar.gz
-}
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/db$(get_version_component_range 1-2)/db.h
+)
src_prepare() {
cd "${WORKDIR}"/"${MY_P}"
@@ -103,34 +105,41 @@ src_prepare() {
}
src_configure() {
- local myconf=''
+ # Add linker versions to the symbols. Easier to do, and safer than header file
+ # mumbo jumbo.
+ if use userland_GNU ; then
+ append-ldflags -Wl,--default-symver
+ fi
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ local myconf=()
# compilation with -O0 fails on amd64, see bug #171231
- if use amd64; then
+ if [[ ${ABI} == amd64 ]]; then
+ local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
replace-flags -O0 -O2
is-flagq -O[s123] || append-flags -O2
fi
# use `set` here since the java opts will contain whitespace
- set --
- if use java ; then
- set -- "$@" \
- --with-java-prefix="${JAVA_HOME}" \
+ if multilib_is_native_abi && use java ; then
+ myconf+=(
+ --with-java-prefix="${JAVA_HOME}"
--with-javac-flags="$(java-pkg_javac-args)"
- fi
-
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU ; then
- append-ldflags -Wl,--default-symver
+ )
fi
# Bug #270851: test needs TCL support
if use tcl || use test ; then
- myconf="${myconf} --enable-tcl"
- myconf="${myconf} --with-tcl=/usr/$(get_libdir)"
+ myconf+=(
+ --enable-tcl
+ --with-tcl=/usr/$(get_libdir)
+ )
else
- myconf="${myconf} --disable-tcl"
+ myconf+=(--disable-tcl )
fi
# sql_compat will cause a collision with sqlite3
@@ -145,47 +154,48 @@ src_configure() {
--enable-sql \
--enable-sql_codegen \
--disable-sql_compat \
- $(use arm && echo --with-mutex=ARM/gcc-assembly) \
- $(use amd64 && echo --with-mutex=x86/gcc-assembly) \
+ $([[ ${ABI} == arm ]] && echo --with-mutex=ARM/gcc-assembly) \
+ $([[ ${ABI} == amd64 ]] && echo --with-mutex=x86/gcc-assembly) \
$(use_enable cxx) \
$(use_enable cxx stl) \
- $(use_enable java) \
- ${myconf} \
- $(use_enable test) \
- "$@"
+ $(multilib_native_use_enable java) \
+ "${myconf[@]}" \
+ $(use_enable test)
}
-src_install() {
+multilib_src_install() {
emake install DESTDIR="${D}"
- db_src_install_usrbinslot
-
db_src_install_headerslot
- db_src_install_doc
-
db_src_install_usrlibcleanup
+ if multilib_is_native_abi && use java; then
+ java-pkg_regso "${D}"/usr/"$(get_libdir)"/libdb_java*.so
+ java-pkg_dojar "${D}"/usr/"$(get_libdir)"/*.jar
+ rm -f "${D}"/usr/"$(get_libdir)"/*.jar
+ fi
+}
+
+multilib_src_install_all() {
+ db_src_install_usrbinslot
+
+ db_src_install_doc
+
dodir /usr/sbin
# This file is not always built, and no longer exists as of db-4.8
if [[ -f "${D}"/usr/bin/berkeley_db_svc ]] ; then
mv "${D}"/usr/bin/berkeley_db_svc \
"${D}"/usr/sbin/berkeley_db"${SLOT/./}"_svc || die
fi
-
- if use java; then
- java-pkg_regso "${D}"/usr/"$(get_libdir)"/libdb_java*.so
- java-pkg_dojar "${D}"/usr/"$(get_libdir)"/*.jar
- rm -f "${D}"/usr/"$(get_libdir)"/*.jar
- fi
}
pkg_postinst() {
- db_fix_so
+ multilib_foreach_abi db_fix_so
}
pkg_postrm() {
- db_fix_so
+ multilib_foreach_abi db_fix_so
}
src_test() {
@@ -213,5 +223,11 @@ src_test() {
-e 's/repmgr018//g' \
"${S_BASE}/test/tcl/test.tcl" || die
- db_src_test
+ multilib-minimal_src_test
+}
+
+multilib_src_test() {
+ multilib_is_native_abi || return
+
+ S=${BUILD_DIR} db_src_test
}