summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-04-05 16:05:07 +0000
committerMike Frysinger <vapier@gentoo.org>2014-04-05 16:05:07 +0000
commit9259cee2706c4c20a8143a43e1e191e82d6ffe5a (patch)
tree39b5b3d039594d4d04b4fef325584b5c94596402 /sys-libs/glibc
parentRemove ree18 and ruby18 target. (diff)
downloadgentoo-2-9259cee2706c4c20a8143a43e1e191e82d6ffe5a.tar.gz
gentoo-2-9259cee2706c4c20a8143a43e1e191e82d6ffe5a.tar.bz2
gentoo-2-9259cee2706c4c20a8143a43e1e191e82d6ffe5a.zip
Add multilib bootstraps for mips/ppc/s390 too.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/ChangeLog6
-rw-r--r--sys-libs/glibc/glibc-2.17.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.18-r1.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.19.ebuild6
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild6
5 files changed, 17 insertions, 13 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 30026b3b94b2..90eea870829e 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.991 2014/03/29 17:02:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.992 2014/04/05 16:05:07 vapier Exp $
+
+ 05 Apr 2014; Mike Frysinger <vapier@gentoo.org> glibc-2.17.ebuild,
+ glibc-2.18-r1.ebuild, glibc-2.19.ebuild, glibc-9999.ebuild:
+ Add multilib bootstraps for mips/ppc/s390 too.
29 Mar 2014; Mike Frysinger <vapier@gentoo.org> glibc-2.19.ebuild:
Move into unstable.
diff --git a/sys-libs/glibc/glibc-2.17.ebuild b/sys-libs/glibc/glibc-2.17.ebuild
index 35ddf4239492..a03418c3f311 100644
--- a/sys-libs/glibc/glibc-2.17.ebuild
+++ b/sys-libs/glibc/glibc-2.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.17.ebuild,v 1.33 2014/03/29 05:31:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.17.ebuild,v 1.34 2014/04/05 16:05:07 vapier Exp $
inherit eutils versionator toolchain-funcs flag-o-matic gnuconfig multilib systemd unpacker multiprocessing
@@ -24,7 +24,7 @@ case ${PV} in
RELEASE_VER=${PV}
;;
esac
-GCC_BOOTSTRAP_VER="4.7.3"
+GCC_BOOTSTRAP_VER="4.7.3-r1"
PATCH_VER="8" # Gentoo patchset
NPTL_KERN_VER=${NPTL_KERN_VER:-"2.6.16"} # min kernel version nptl requires
@@ -154,7 +154,7 @@ done
eblit-src_unpack-pre() {
GLIBC_PATCH_EXCLUDE+=" 6600_mips_librt-mips.patch" #456912
- [[ -n ${GCC_BOOTSTRAP_VER} ]] && use multilib && unpack gcc-4.7.3-multilib-bootstrap.tar.bz2
+ [[ -n ${GCC_BOOTSTRAP_VER} ]] && use multilib && unpack gcc-${GCC_BOOTSTRAP_VER}-multilib-bootstrap.tar.bz2
}
eblit-src_unpack-post() {
diff --git a/sys-libs/glibc/glibc-2.18-r1.ebuild b/sys-libs/glibc/glibc-2.18-r1.ebuild
index 30a9c74f6126..83f2f03324ac 100644
--- a/sys-libs/glibc/glibc-2.18-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.18-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.18-r1.ebuild,v 1.3 2014/03/29 05:31:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.18-r1.ebuild,v 1.4 2014/04/05 16:05:07 vapier Exp $
inherit eutils versionator toolchain-funcs flag-o-matic gnuconfig multilib systemd unpacker multiprocessing
@@ -24,7 +24,7 @@ case ${PV} in
RELEASE_VER=${PV}
;;
esac
-GCC_BOOTSTRAP_VER="4.7.3"
+GCC_BOOTSTRAP_VER="4.7.3-r1"
PATCH_VER="4" # Gentoo patchset
NPTL_KERN_VER=${NPTL_KERN_VER:-"2.6.16"} # min kernel version nptl requires
@@ -154,7 +154,7 @@ done
eblit-src_unpack-pre() {
GLIBC_PATCH_EXCLUDE+=" 00_all_0012-mips-add-clock_-g-s-ettime-symbol-compat-hacks.patch" #456912 #481438
- [[ -n ${GCC_BOOTSTRAP_VER} ]] && use multilib && unpack gcc-4.7.3-multilib-bootstrap.tar.bz2
+ [[ -n ${GCC_BOOTSTRAP_VER} ]] && use multilib && unpack gcc-${GCC_BOOTSTRAP_VER}-multilib-bootstrap.tar.bz2
}
eblit-src_unpack-post() {
diff --git a/sys-libs/glibc/glibc-2.19.ebuild b/sys-libs/glibc/glibc-2.19.ebuild
index a705919ae25d..5b5722489894 100644
--- a/sys-libs/glibc/glibc-2.19.ebuild
+++ b/sys-libs/glibc/glibc-2.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.19.ebuild,v 1.5 2014/03/29 17:02:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.19.ebuild,v 1.6 2014/04/05 16:05:07 vapier Exp $
inherit eutils versionator toolchain-funcs flag-o-matic gnuconfig multilib systemd unpacker multiprocessing
@@ -24,7 +24,7 @@ case ${PV} in
RELEASE_VER=${PV}
;;
esac
-GCC_BOOTSTRAP_VER="4.7.3"
+GCC_BOOTSTRAP_VER="4.7.3-r1"
PATCH_VER="1" # Gentoo patchset
NPTL_KERN_VER=${NPTL_KERN_VER:-"2.6.16"} # min kernel version nptl requires
@@ -153,7 +153,7 @@ for x in setup {pre,post}inst ; do
done
eblit-src_unpack-pre() {
- [[ -n ${GCC_BOOTSTRAP_VER} ]] && use multilib && unpack gcc-4.7.3-multilib-bootstrap.tar.bz2
+ [[ -n ${GCC_BOOTSTRAP_VER} ]] && use multilib && unpack gcc-${GCC_BOOTSTRAP_VER}-multilib-bootstrap.tar.bz2
}
eblit-src_unpack-post() {
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index f2bdf97bf862..146c49e1e667 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-9999.ebuild,v 1.23 2014/03/29 06:11:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-9999.ebuild,v 1.24 2014/04/05 16:05:07 vapier Exp $
inherit eutils versionator toolchain-funcs flag-o-matic gnuconfig multilib systemd unpacker multiprocessing
@@ -24,7 +24,7 @@ case ${PV} in
RELEASE_VER=${PV}
;;
esac
-GCC_BOOTSTRAP_VER="4.7.3"
+GCC_BOOTSTRAP_VER="4.7.3-r1"
PATCH_VER="" # Gentoo patchset
NPTL_KERN_VER=${NPTL_KERN_VER:-"2.6.16"} # min kernel version nptl requires
@@ -153,7 +153,7 @@ for x in setup {pre,post}inst ; do
done
eblit-src_unpack-pre() {
- [[ -n ${GCC_BOOTSTRAP_VER} ]] && use multilib && unpack gcc-4.7.3-multilib-bootstrap.tar.bz2
+ [[ -n ${GCC_BOOTSTRAP_VER} ]] && use multilib && unpack gcc-${GCC_BOOTSTRAP_VER}-multilib-bootstrap.tar.bz2
}
eblit-src_unpack-post() {