summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-12-22 17:51:28 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-12-22 17:51:28 +0000
commit34ce9151946f1d280340803112252bc63719e8fc (patch)
treea9fb9988496da492f7567e9987a7eade4c8ee6d5 /sys-libs/libcxx
parentVersion bump (diff)
downloadgentoo-2-34ce9151946f1d280340803112252bc63719e8fc.tar.gz
gentoo-2-34ce9151946f1d280340803112252bc63719e8fc.tar.bz2
gentoo-2-34ce9151946f1d280340803112252bc63719e8fc.zip
link tests against libcxxrt if needed since we dont have the linker script in place at that point
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-libs/libcxx')
-rw-r--r--sys-libs/libcxx/ChangeLog6
-rw-r--r--sys-libs/libcxx/libcxx-9999.ebuild5
2 files changed, 8 insertions, 3 deletions
diff --git a/sys-libs/libcxx/ChangeLog b/sys-libs/libcxx/ChangeLog
index 6a21a626cd4e..ec54ddd2f608 100644
--- a/sys-libs/libcxx/ChangeLog
+++ b/sys-libs/libcxx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/libcxx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.35 2013/10/14 18:21:00 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.36 2013/12/22 17:51:28 aballier Exp $
+
+ 22 Dec 2013; Alexis Ballier <aballier@gentoo.org> libcxx-9999.ebuild:
+ link tests against libcxxrt if needed since we dont have the linker script in
+ place at that point
14 Oct 2013; Michał Górny <mgorny@gentoo.org> libcxx-0.0_p20130725.ebuild,
libcxx-9999.ebuild:
diff --git a/sys-libs/libcxx/libcxx-9999.ebuild b/sys-libs/libcxx/libcxx-9999.ebuild
index 3ecd98d9fdd6..17e4723fe039 100644
--- a/sys-libs/libcxx/libcxx-9999.ebuild
+++ b/sys-libs/libcxx/libcxx-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-9999.ebuild,v 1.25 2013/10/14 18:21:00 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-9999.ebuild,v 1.26 2013/12/22 17:51:28 aballier Exp $
EAPI=5
@@ -98,8 +98,9 @@ multilib_src_test() {
CC="clang++ $(get_abi_CFLAGS) ${CXXFLAGS}" \
HEADER_INCLUDE="-I${BUILD_DIR}/include" \
SOURCE_LIB="-L${BUILD_DIR}/lib" \
- LIBS="-lm" \
+ LIBS="-lm $(usex libcxxrt -lcxxrt "")" \
./testit || die
+ # TODO: fix link against libsupc++
}
# Usage: deps