summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-11-04 04:08:49 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-11-04 04:08:49 +0000
commit7e95cbce562e05e795c24ca3d0ea393cac93899d (patch)
treeb551bd03728162358f7f9c36eb04afb6c97306d5 /sys-libs/libhugetlbfs/libhugetlbfs-2.6.ebuild
parentUpdate the libusb dep to point to virtual/libusb:0 as this should work fine w... (diff)
downloadgentoo-2-7e95cbce562e05e795c24ca3d0ea393cac93899d.tar.gz
gentoo-2-7e95cbce562e05e795c24ca3d0ea393cac93899d.tar.bz2
gentoo-2-7e95cbce562e05e795c24ca3d0ea393cac93899d.zip
Fully wire up the upstream testsuite.
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/libhugetlbfs/libhugetlbfs-2.6.ebuild')
-rw-r--r--sys-libs/libhugetlbfs/libhugetlbfs-2.6.ebuild127
1 files changed, 97 insertions, 30 deletions
diff --git a/sys-libs/libhugetlbfs/libhugetlbfs-2.6.ebuild b/sys-libs/libhugetlbfs/libhugetlbfs-2.6.ebuild
index c2e93af3b2de..f2bbe6ca177d 100644
--- a/sys-libs/libhugetlbfs/libhugetlbfs-2.6.ebuild
+++ b/sys-libs/libhugetlbfs/libhugetlbfs-2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libhugetlbfs/libhugetlbfs-2.6.ebuild,v 1.2 2009/11/01 01:24:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libhugetlbfs/libhugetlbfs-2.6.ebuild,v 1.3 2009/11/04 04:08:48 robbat2 Exp $
EAPI=2
inherit eutils multilib toolchain-funcs
@@ -16,12 +16,9 @@ IUSE=""
DEPEND=""
-# testsuite requires specific kernel options, and LOTS of free memory.
-# with 16GiB of RAM available, I hit swap :-) - robbat2
-RESTRICT=test
-
src_prepare() {
epatch "${FILESDIR}"/${PN}-2.6-noexec-stack.patch
+ epatch "${FILESDIR}"/${PN}-2.6-fixup-testsuite.patch
sed -i \
-e '/^PREFIX/s:/local::' \
-e '1iBUILDTYPE = NATIVEONLY' \
@@ -51,34 +48,104 @@ src_install() {
rm "${D}"/usr/bin/oprofile*
}
+src_test_alloc_one() {
+ hugeadm="$1"
+ sign="$2"
+ pagesize="$3"
+ pagecount="$4"
+ ${hugeadm} \
+ --pool-pages-max ${pagesize}:${sign}${pagecount} \
+ && \
+ ${hugeadm} \
+ --pool-pages-min ${pagesize}:${sign}${pagecount}
+ return $?
+}
+
+# die is NOT allowed in this src_test block after the marked point, so that we
+# can clean up memory allocation. You'll leak at LEAST 64MiB per run otherwise.
src_test() {
- emake tests || die "Failed to build tests"
+ [[ $UID -eq 0 ]] || die "Need FEATURES=-userpriv to run this testsuite"
+ einfo "Building testsuite"
+ emake -j1 tests || die "Failed to build tests"
+
hugeadm='obj/hugeadm'
- ${hugeadm} --create-mounts
- PAGESIZES="$(${hugeadm} --page-sizes-all)"
+ allocated=''
+ rc=0
+ # the testcases need 64MiB per pagesize.
MIN_HUGEPAGE_RAM=$((64*1024*1024))
- ALLOCATED=''
- for p in ${PAGESIZES} ; do
- pagecount=$((${MIN_HUGEPAGE_RAM}/${p}))
- ${hugeadm} \
- --pool-pages-min ${p}:+${pagecount} \
- --pool-pages-max ${p}:+${pagecount} \
- && ALLOCATED="${ALLOCATED} ${p}:${pagecount}" \
- || die "Failed to set pages"
+
+ einfo "Planning allocation"
+ PAGESIZES="$(${hugeadm} --page-sizes-all)"
+
+ # Need to do this before we can create the mountpoints.
+ for pagesize in ${PAGESIZES} ; do
+ # The kernel depends on the location :-(
+ mkdir -p /var/lib/hugetlbfs/pagesize-${pagesize}
+ addwrite /var/lib/hugetlbfs/pagesize-${pagesize}
+ done
+ addwrite /proc/sys/vm/
+ addwrite /proc/sys/kernel/shmall
+ addwrite /proc/sys/kernel/shmmax
+ addwrite /proc/sys/kernel/shmmni
+
+ einfo "Checking HugeTLB mountpoints"
+ ${hugeadm} --create-mounts || die "Failed to set up hugetlb mountpoints."
+
+ # -----------------------------------------------------
+ # --------- die is unsafe after this point. -----------
+ # -----------------------------------------------------
+
+ einfo "Starting allocation"
+ for pagesize in ${PAGESIZES} ; do
+ pagecount=$((${MIN_HUGEPAGE_RAM}/${pagesize}))
+ einfo " ${pagecount} @ ${pagesize}"
+ addwrite /var/lib/hugetlbfs/pagesize-${pagesize}
+ src_test_alloc_one "$hugeadm" "+" "${pagesize}" "${pagecount}"
+ rc=$?
+ if [[ $rc -eq 0 ]]; then
+ allocated="${allocated} ${pagesize}:${pagecount}"
+ else
+ eerror "Failed to add ${pagecount} pages of size ${pagesize}"
+ fi
done
- cd "${S}"/tests
- TESTOPTS="-t func"
- case $ARCH in
- amd64|ppc64)
- TESTOPTS="${TESTOPTS} -b 64"
- ;;
- x86)
- TESTOPTS="${TESTOPTS} -b 32"
- ;;
- esac
- ./run_tests.py ${TESTOPTS}
- # TODO: undo the allocation here.
- for p in ${ALLOCATED} ; do
- :
+
+ einfo "Allocation status"
+ ${hugeadm} --pool-list
+
+ if [[ -n "${allocated}" ]]; then
+ # All our allocations worked, so time to run.
+ einfo "Starting tests"
+ cd "${S}"/tests
+ TESTOPTS="-t func"
+ case $ARCH in
+ amd64|ppc64)
+ TESTOPTS="${TESTOPTS} -b 64"
+ ;;
+ x86)
+ TESTOPTS="${TESTOPTS} -b 32"
+ ;;
+ esac
+ # This needs a bit of work to give a nice exit code still.
+ ./run_tests.py ${TESTOPTS}
+ rc=$?
+ else
+ eerror "Failed to make HugeTLB allocations."
+ rc=1
+ fi
+
+ einfo "Cleaning up memory"
+ cd "${S}"
+ # Cleanup memory allocation
+ for alloc in ${allocated} ; do
+ pagesize="${alloc/:*}"
+ pagecount="${alloc/*:}"
+ einfo " ${pagecount} @ ${pagesize}"
+ src_test_alloc_one "$hugeadm" "-" "${pagesize}" "${pagecount}"
done
+
+ # ---------------------------------------------------------
+ # --------- die is safe again after this point. -----------
+ # ---------------------------------------------------------
+
+ return $rc
}