summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-07-15 21:03:08 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-07-15 21:03:08 +0000
commit8824deaba5fb5e5aa1de18b0103bf53b8c3a5152 (patch)
tree04797a546939673b1f2d43767633a01e3cfeebd9 /sys-libs/libsepol/libsepol-2.0.42.ebuild
parentBump to 2.0.46 - proxy for SwifT (diff)
downloadgentoo-2-8824deaba5fb5e5aa1de18b0103bf53b8c3a5152.tar.gz
gentoo-2-8824deaba5fb5e5aa1de18b0103bf53b8c3a5152.tar.bz2
gentoo-2-8824deaba5fb5e5aa1de18b0103bf53b8c3a5152.zip
Bump to 2.0.42 - proxy for SwifT
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/libsepol/libsepol-2.0.42.ebuild')
-rw-r--r--sys-libs/libsepol/libsepol-2.0.42.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-libs/libsepol/libsepol-2.0.42.ebuild b/sys-libs/libsepol/libsepol-2.0.42.ebuild
new file mode 100644
index 000000000000..594ec5d5aa7b
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.0.42.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/libsepol-2.0.42.ebuild,v 1.1 2011/07/15 21:03:08 blueness Exp $
+
+EAPI="2"
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20101221/devel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib SHLIBDIR failed."
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}