summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-05-02 04:13:33 +0000
committerMike Frysinger <vapier@gentoo.org>2008-05-02 04:13:33 +0000
commit803ba3298b173ef42962d8b94205ddce338eecbf (patch)
treed54b594102b9ef01000314424fcbd2180a78449d /sys-libs/zlib/zlib-1.2.3-r1.ebuild
parentVersion bump. Added dep for dev-python/coverage, removed broken pudge build i... (diff)
downloadgentoo-2-803ba3298b173ef42962d8b94205ddce338eecbf.tar.gz
gentoo-2-803ba3298b173ef42962d8b94205ddce338eecbf.tar.bz2
gentoo-2-803ba3298b173ef42962d8b94205ddce338eecbf.zip
Fixes from kerzol for mingw targets #182903.
(Portage version: 2.2_pre5)
Diffstat (limited to 'sys-libs/zlib/zlib-1.2.3-r1.ebuild')
-rw-r--r--sys-libs/zlib/zlib-1.2.3-r1.ebuild49
1 files changed, 30 insertions, 19 deletions
diff --git a/sys-libs/zlib/zlib-1.2.3-r1.ebuild b/sys-libs/zlib/zlib-1.2.3-r1.ebuild
index db80e4947d3a..e40adea053dc 100644
--- a/sys-libs/zlib/zlib-1.2.3-r1.ebuild
+++ b/sys-libs/zlib/zlib-1.2.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.3-r1.ebuild,v 1.12 2007/05/14 23:51:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.3-r1.ebuild,v 1.13 2008/05/02 04:13:33 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -19,24 +19,30 @@ RDEPEND=""
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
epatch "${FILESDIR}"/${P}-visibility-support.patch #149929
- # Make sure we link with glibc at all times
epatch "${FILESDIR}"/${PN}-1.2.1-glibc.patch
- # Needed for Alpha and prelink
epatch "${FILESDIR}"/${PN}-1.2.1-build-fPIC.patch
epatch "${FILESDIR}"/${PN}-1.2.1-configure.patch #55434
- # fix shared library test on -fPIC dependant archs
epatch "${FILESDIR}"/${PN}-1.2.1-fPIC.patch
epatch "${FILESDIR}"/${PN}-1.2.3-r1-bsd-soname.patch #123571
epatch "${FILESDIR}"/${PN}-1.2.3-LDFLAGS.patch #126718
- sed -i -e '/ldconfig/d' Makefile.in
+ sed -i -e '/ldconfig/d' Makefile*
}
src_compile() {
- tc-export CC RANLIB
- export AR="$(tc-getAR) rc"
- ./configure --shared --prefix=/usr --libdir=/$(get_libdir) || die
- emake || die
+ tc-export AR CC RANLIB
+ case ${CHOST} in
+ *-mingw*|mingw*)
+ export RC=${CHOST}-windres DLLWRAP=${CHOST}-dllwrap
+ emake -f win32/Makefile.gcc prefix=/usr || die
+ ;;
+ *)
+ # not an autoconf script, so cant use econf
+ ./configure --shared --prefix=/usr --libdir=/$(get_libdir) || die
+ emake || die
+ ;;
+ esac
}
src_install() {
@@ -46,9 +52,7 @@ src_install() {
doins zconf.h zlib.h
doman zlib.3
- dodoc FAQ README ChangeLog
- docinto txt
- dodoc algorithm.txt
+ dodoc FAQ README ChangeLog algorithm.txt
# we don't need the static lib in /lib
# as it's only for compiling against
@@ -56,10 +60,17 @@ src_install() {
# all the shared libs go into /lib
# for NFS based /usr
- into /
- dolib libz.so.${PV}
- ( cd "${D}"/$(get_libdir) ; chmod 755 libz.so.* )
- dosym libz.so.${PV} /$(get_libdir)/libz.so
- dosym libz.so.${PV} /$(get_libdir)/libz.so.1
- gen_usr_ldscript libz.so
+ case ${CHOST} in
+ *-mingw*|mingw*)
+ dolib zlib1.dll libzdll.a || die
+ ;;
+ *)
+ into /
+ dolib libz.so.${PV}
+ ( cd "${D}"/$(get_libdir) ; chmod 755 libz.so.* )
+ dosym libz.so.${PV} /$(get_libdir)/libz.so
+ dosym libz.so.${PV} /$(get_libdir)/libz.so.1
+ gen_usr_ldscript libz.so
+ ;;
+ esac
}