summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-16 17:49:12 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-16 17:49:12 +0000
commit0555d3d44984bd2727dea738d027bd64fb794a77 (patch)
tree8a06a8ef76c21523fc77c23adc6ae6610bb95afb /sys-libs
parentold (diff)
downloadgentoo-2-0555d3d44984bd2727dea738d027bd64fb794a77.tar.gz
gentoo-2-0555d3d44984bd2727dea738d027bd64fb794a77.tar.bz2
gentoo-2-0555d3d44984bd2727dea738d027bd64fb794a77.zip
Version bump #332995 by Rodrigo Severo.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/timezone-data/ChangeLog7
-rw-r--r--sys-libs/timezone-data/timezone-data-2010l.ebuild106
2 files changed, 112 insertions, 1 deletions
diff --git a/sys-libs/timezone-data/ChangeLog b/sys-libs/timezone-data/ChangeLog
index adf842647e45..599bf0f0e2bd 100644
--- a/sys-libs/timezone-data/ChangeLog
+++ b/sys-libs/timezone-data/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/timezone-data
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/ChangeLog,v 1.235 2010/07/26 22:12:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/ChangeLog,v 1.236 2010/08/16 17:49:12 vapier Exp $
+
+*timezone-data-2010l (16 Aug 2010)
+
+ 16 Aug 2010; Mike Frysinger <vapier@gentoo.org> +timezone-data-2010l.ebuild:
+ Version bump #332995 by Rodrigo Severo.
*timezone-data-2010k (26 Jul 2010)
diff --git a/sys-libs/timezone-data/timezone-data-2010l.ebuild b/sys-libs/timezone-data/timezone-data-2010l.ebuild
new file mode 100644
index 000000000000..f1a876c0f2e8
--- /dev/null
+++ b/sys-libs/timezone-data/timezone-data-2010l.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2010l.ebuild,v 1.1 2010/08/16 17:49:12 vapier Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+code_ver=${PV}
+data_ver=${PV}
+DESCRIPTION="Timezone data (/usr/share/zoneinfo) and utilities (tzselect/zic/zdump)"
+HOMEPAGE="ftp://elsie.nci.nih.gov/pub/"
+SRC_URI="ftp://elsie.nci.nih.gov/pub/tzdata${data_ver}.tar.gz
+ ftp://elsie.nci.nih.gov/pub/tzcode${code_ver}.tar.gz
+ mirror://gentoo/tzdata${data_ver}.tar.gz
+ mirror://gentoo/tzcode${code_ver}.tar.gz"
+
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="nls elibc_FreeBSD elibc_glibc"
+
+RDEPEND="!<sys-libs/glibc-2.3.5"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PN}-2008h-makefile.patch
+ tc-is-cross-compiler && cp -pR "${S}" "${S}"-native
+}
+
+src_compile() {
+ local LDLIBS
+ tc-export CC
+ use elibc_FreeBSD && append-flags -DSTD_INSPIRED #138251
+ if use nls ; then
+ use elibc_glibc || LDLIBS="${LDLIBS} -lintl" #154181
+ export NLS=1
+ else
+ export NLS=0
+ fi
+ # Makefile uses LBLIBS for the libs (which defaults to LDFLAGS)
+ # But it also uses LFLAGS where it expects the real LDFLAGS
+ emake \
+ LDLIBS="${LDLIBS}" \
+ || die "emake failed"
+ if tc-is-cross-compiler ; then
+ emake -C "${S}"-native \
+ CC=$(tc-getBUILD_CC) \
+ CFLAGS="${BUILD_CFLAGS}" \
+ LDFLAGS="${BUILD_LDFLAGS}" \
+ LDLIBS="${LDLIBS}" \
+ zic || die
+ fi
+}
+
+src_install() {
+ local zic=""
+ tc-is-cross-compiler && zic="zic=${S}-native/zic"
+ emake install ${zic} DESTDIR="${D}" || die
+ rm -rf "${D}"/usr/share/zoneinfo-leaps
+ dodoc README Theory
+ dohtml *.htm *.jpg
+}
+
+pkg_config() {
+ # make sure the /etc/localtime file does not get stale #127899
+ local tz src
+
+ if has_version '<sys-apps/baselayout-2' ; then
+ src="${ROOT}etc/conf.d/clock"
+ tz=$(unset TIMEZONE ; source "${src}" ; echo ${TIMEZONE-FOOKABLOIE})
+ else
+ src="${ROOT}etc/timezone"
+ if [[ -e ${src} ]] ; then
+ tz=$(sed -e 's:#.*::' -e 's:[[:space:]]*::g' -e '/^$/d' "${src}")
+ else
+ tz="FOOKABLOIE"
+ fi
+ fi
+ [[ -z ${tz} ]] && return 0
+
+ if [[ ${tz} == "FOOKABLOIE" ]] ; then
+ elog "You do not have TIMEZONE set in ${src}."
+
+ if [[ ! -e ${ROOT}/etc/localtime ]] ; then
+ cp -f "${ROOT}"/usr/share/zoneinfo/Factory "${ROOT}"/etc/localtime
+ elog "Setting ${ROOT}etc/localtime to Factory."
+ else
+ elog "Skipping auto-update of ${ROOT}etc/localtime."
+ fi
+ return 0
+ fi
+
+ if [[ ! -e ${ROOT}/usr/share/zoneinfo/${tz} ]] ; then
+ elog "You have an invalid TIMEZONE setting in ${src}"
+ elog "Your ${ROOT}etc/localtime has been reset to Factory; enjoy!"
+ tz="Factory"
+ fi
+ einfo "Updating ${ROOT}etc/localtime with ${ROOT}usr/share/zoneinfo/${tz}"
+ [[ -L ${ROOT}/etc/localtime ]] && rm -f "${ROOT}"/etc/localtime
+ cp -f "${ROOT}"/usr/share/zoneinfo/"${tz}" "${ROOT}"/etc/localtime
+}
+
+pkg_postinst() {
+ pkg_config
+}