summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-31 13:19:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-31 13:19:35 +0000
commit10183e46b9ce4ccc7c25df618a4962c606b572d8 (patch)
tree5948483245d15b4787d37908612972cf7d1f3d70 /sys-libs
parenthandle openbsd CHOSTs as well (diff)
downloadgentoo-2-10183e46b9ce4ccc7c25df618a4962c606b572d8.tar.gz
gentoo-2-10183e46b9ce4ccc7c25df618a4962c606b572d8.tar.bz2
gentoo-2-10183e46b9ce4ccc7c25df618a4962c606b572d8.zip
Use $CHOST checks instead of $USERLAND checks for moving libraries around.
(Portage version: 2.1_pre3)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/ncurses/ChangeLog5
-rw-r--r--sys-libs/ncurses/ncurses-5.5-r1.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/sys-libs/ncurses/ChangeLog b/sys-libs/ncurses/ChangeLog
index 2ee15a0f7220..854fdaf5ea50 100644
--- a/sys-libs/ncurses/ChangeLog
+++ b/sys-libs/ncurses/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/ncurses
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.105 2005/12/14 12:04:54 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.106 2005/12/31 13:19:35 flameeyes Exp $
+
+ 31 Dec 2005; Diego Pettenò <flameeyes@gentoo.org> ncurses-5.5-r1.ebuild:
+ Use $CHOST checks instead of $USERLAND checks for moving libraries around.
14 Dec 2005; Diego Pettenò <flameeyes@gentoo.org>
files/ncurses-5.5-gfbsd.patch:
diff --git a/sys-libs/ncurses/ncurses-5.5-r1.ebuild b/sys-libs/ncurses/ncurses-5.5-r1.ebuild
index 4e3ad7be296b..505181d3ea5c 100644
--- a/sys-libs/ncurses/ncurses-5.5-r1.ebuild
+++ b/sys-libs/ncurses/ncurses-5.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.5-r1.ebuild,v 1.3 2005/12/10 02:02:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.5-r1.ebuild,v 1.4 2005/12/31 13:19:35 flameeyes Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -58,7 +58,7 @@ do_compile() {
ECONF_SOURCE=${S}
local mylibprefix=""
- [[ ${USERLAND} == "Darwin" ]] && mylibprefix="/usr"
+ [[ ${CHOST} == *-darwin* ]] && mylibprefix="/usr"
# We need the basic terminfo files in /etc, bug #37026. We will
# add '--with-terminfo-dirs' and then populate /etc/terminfo in
@@ -101,7 +101,7 @@ src_install() {
cd "${WORKDIR}"/narrowc
make DESTDIR="${D}" install || die "make narrowc install failed"
- if [[ ${USERLAND} != "Darwin" ]] ; then
+ if [[ ${CHOST} != *-darwin* ]] ; then
# Move static and extraneous ncurses libraries out of /lib
dodir /usr/$(get_libdir)
cd "${D}"/$(get_libdir)