summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-23 00:56:39 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-23 00:56:39 +0000
commit146fc45879e0bc1ddf9a5809b4afe1b0005396f1 (patch)
tree21e2aaf0ea74e44cdb5e3aeec6dba65be0b5d02a /sys-libs
parentblah typo fix (diff)
downloadgentoo-2-146fc45879e0bc1ddf9a5809b4afe1b0005396f1.tar.gz
gentoo-2-146fc45879e0bc1ddf9a5809b4afe1b0005396f1.tar.bz2
gentoo-2-146fc45879e0bc1ddf9a5809b4afe1b0005396f1.zip
Add a readline-4.x ebuild for the ABI lib only.
(Portage version: 2.2_rc23/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/readline/ChangeLog7
-rw-r--r--sys-libs/readline/readline-4.3_p5.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index 90b3c6eeb674..8d5b14d2765b 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/readline
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.125 2009/02/21 21:38:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.126 2009/02/23 00:56:39 vapier Exp $
+
+*readline-4.3_p5 (23 Feb 2009)
+
+ 23 Feb 2009; Mike Frysinger <vapier@gentoo.org> +readline-4.3_p5.ebuild:
+ Add a readline-4.x ebuild for the ABI lib only.
*readline-6.0 (21 Feb 2009)
diff --git a/sys-libs/readline/readline-4.3_p5.ebuild b/sys-libs/readline/readline-4.3_p5.ebuild
new file mode 100644
index 000000000000..aa00e0c33e2f
--- /dev/null
+++ b/sys-libs/readline/readline-4.3_p5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3_p5.ebuild,v 1.1 2009/02/23 00:56:39 vapier Exp $
+
+# This version is just for the ABI .4 library
+
+inherit eutils flag-o-matic
+
+# Official patches
+# See ftp://ftp.cwru.edu/pub/bash/readline-4.3-patches/
+PLEVEL=${PV##*_p}
+MY_PV=${PV/_p*}
+MY_P=${PN}-${MY_PV}
+[[ ${PV} != *_p* ]] && PLEVEL=0
+patches() {
+ [[ ${PLEVEL} -eq 0 ]] && return 1
+ local opt=$1
+ eval set -- {1..${PLEVEL}}
+ set -- $(printf "${PN}${MY_PV/\.}-%03d " "$@")
+ if [[ ${opt} == -s ]] ; then
+ echo "${@/#/${DISTDIR}/}"
+ else
+ local u
+ for u in ftp://ftp.cwru.edu/pub/bash mirror://gnu/${PN} ; do
+ printf "${u}/${PN}-${MY_PV}-patches/%s " "$@"
+ done
+ fi
+}
+
+DESCRIPTION="Another cute console display library"
+HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz $(patches)"
+
+LICENSE="GPL-2"
+SLOT="${PV:0:1}"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+# We must be certain that we have a bash that is linked
+# to its internal readline, else we may get problems.
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-2.05b-r2"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd "${S}"
+ [[ ${PLEVEL} -gt 0 ]] && epatch $(patches -s)
+ # force ncurses linking #71420
+ sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
+}
+
+src_compile() {
+ append-cppflags -D_GNU_SOURCE
+ econf --with-curses --disable-static || die
+ emake -C shlib || die
+}
+
+src_install() {
+ emake -C shlib DESTDIR="${D}" install || die
+ rm -f "${D}"/usr/lib*/*.so
+}