summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-12 20:49:40 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-12 20:49:40 +0000
commit1a582409022d7c8a5eb6cb52414d41ee28aaf4ce (patch)
tree7a2c104afab8545dbac3b9e4f96d783199765af6 /sys-libs
parentVersion bump (diff)
downloadgentoo-2-1a582409022d7c8a5eb6cb52414d41ee28aaf4ce.tar.gz
gentoo-2-1a582409022d7c8a5eb6cb52414d41ee28aaf4ce.tar.bz2
gentoo-2-1a582409022d7c8a5eb6cb52414d41ee28aaf4ce.zip
Enable multilib support, required by samba-4.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/ntdb/ChangeLog8
-rw-r--r--sys-libs/ntdb/ntdb-1.0-r1.ebuild51
2 files changed, 57 insertions, 2 deletions
diff --git a/sys-libs/ntdb/ChangeLog b/sys-libs/ntdb/ChangeLog
index dbe6f5a97f32..bfeeb5a2f3e1 100644
--- a/sys-libs/ntdb/ChangeLog
+++ b/sys-libs/ntdb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/ntdb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ntdb/ChangeLog,v 1.4 2014/04/18 21:04:15 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ntdb/ChangeLog,v 1.5 2014/06/12 20:49:40 mgorny Exp $
+
+*ntdb-1.0-r1 (12 Jun 2014)
+
+ 12 Jun 2014; Michał Górny <mgorny@gentoo.org> +ntdb-1.0-r1.ebuild:
+ Enable multilib support, required by samba-4.
18 Apr 2014; Lars Wendler <polynomial-c@gentoo.org> ntdb-1.0.ebuild:
Hard block older samba versions again.
@@ -16,4 +21,3 @@
17 Apr 2014; Lars Wendler <polynomial-c@gentoo.org> +ntdb-1.0.ebuild,
+metadata.xml:
Initital commit.
-
diff --git a/sys-libs/ntdb/ntdb-1.0-r1.ebuild b/sys-libs/ntdb/ntdb-1.0-r1.ebuild
new file mode 100644
index 000000000000..768b365d16f7
--- /dev/null
+++ b/sys-libs/ntdb/ntdb-1.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ntdb/ntdb-1.0-r1.ebuild,v 1.1 2014/06/12 20:49:40 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="A not-so trivial keyword/data database system"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="!!<net-fs/samba-4.1.7
+ ${RDEPEND}
+ app-text/docbook-xml-dtd:4.2"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+src_prepare() {
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local extra_opts=()
+ if ! multilib_is_native_abi || ! use python; then
+ extra_opts+=( --disable-python )
+ fi
+
+ waf-utils_src_configure \
+ "${extra_opts[@]}"
+}
+
+multilib_src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+}