summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-10-27 03:44:37 +0000
committerDaniel Goller <morfic@gentoo.org>2004-10-27 03:44:37 +0000
commit2523f718b1784647928425a631871621610cf5b9 (patch)
tree09213e3a4e5c28a913ca0ee0766a707bd1c3e24c /sys-libs
parentupdated to the fedora-branch snap in fedora's 2.3.3-73 src rpm and removed th... (diff)
downloadgentoo-2-2523f718b1784647928425a631871621610cf5b9.tar.gz
gentoo-2-2523f718b1784647928425a631871621610cf5b9.tar.bz2
gentoo-2-2523f718b1784647928425a631871621610cf5b9.zip
Doing required flag magic for gcc3.3 closing bug 64252
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libstdc++-v3/ChangeLog6
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild10
2 files changed, 14 insertions, 2 deletions
diff --git a/sys-libs/libstdc++-v3/ChangeLog b/sys-libs/libstdc++-v3/ChangeLog
index 70b380e25972..564688916e11 100644
--- a/sys-libs/libstdc++-v3/ChangeLog
+++ b/sys-libs/libstdc++-v3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/libstdc++-v3
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.25 2004/09/11 22:13:07 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.26 2004/10/27 03:44:37 morfic Exp $
+
+ 26 Oct 2004; Daniel Goller <morfic@gentoo.org> libstdc++-v3-3.3.4.ebuild:
+ Do the required magic to deal with G3, G4, G5 archs on gcc3.3
+ Closing bug 64252
11 Sep 2004; Travis Tilley <lv@gentoo.org> -libstdc++-v3-3.3.4-r1.ebuild:
temporarily removing ebuild pending a redesign of the toolchain eclass.
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild
index d66b06de5b10..14a70d2bcf23 100644
--- a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild,v 1.4 2004/10/06 22:27:08 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild,v 1.5 2004/10/27 03:44:37 morfic Exp $
inherit eutils flag-o-matic libtool gnuconfig versionator
@@ -28,6 +28,14 @@ do_filter_flags() {
# gcc 3.3 doesn't support -march=pentium-m
replace-flags -march=pentium-m -march=pentium3
+ #GCC 3.3 does not understand G3, G4, G5 on ppc
+ replace-flags -mcpu=G3 -mcpu=750
+ replace-flags -mcpu=G4 -mcpu=7400
+ replace-flags -mtune=G3 -mtune=750
+ replace-flags -mtune=G4 -mtune=7400
+ filter-flags -mcpu=G5
+ filter-flags -mtune=G5
+
# gcc 3.3 doesn't support -mtune on numerous archs, so xgcc will fail
if use x86 || use amd64 ; then
setting="`get-flag mtune`"