summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-12-28 00:14:44 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-12-28 00:14:44 +0000
commit3cac17f9ff234945302fdf8817ad7a5d211cfa0d (patch)
treee1d6e9632dd04bc22be75088fa83db9452a2da89 /sys-libs
parentVersion bump. (diff)
downloadgentoo-2-3cac17f9ff234945302fdf8817ad7a5d211cfa0d.tar.gz
gentoo-2-3cac17f9ff234945302fdf8817ad7a5d211cfa0d.tar.bz2
gentoo-2-3cac17f9ff234945302fdf8817ad7a5d211cfa0d.zip
Version bump. Fix QA issues per bug #219595. Python swig install per bug #290763.
(Portage version: 2.2_rc58/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/openipmi/ChangeLog9
-rw-r--r--sys-libs/openipmi/openipmi-2.0.16.ebuild93
2 files changed, 101 insertions, 1 deletions
diff --git a/sys-libs/openipmi/ChangeLog b/sys-libs/openipmi/ChangeLog
index 80bbfdb0820a..55594831bb6e 100644
--- a/sys-libs/openipmi/ChangeLog
+++ b/sys-libs/openipmi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/openipmi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/openipmi/ChangeLog,v 1.16 2009/12/24 19:40:15 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/openipmi/ChangeLog,v 1.17 2009/12/28 00:14:44 robbat2 Exp $
+
+*openipmi-2.0.16 (28 Dec 2009)
+
+ 28 Dec 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +openipmi-2.0.16.ebuild:
+ Version bump. Fix QA issues per bug #219595. Python swig install per bug
+ #290763.
24 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
openipmi-2.0.11.ebuild:
diff --git a/sys-libs/openipmi/openipmi-2.0.16.ebuild b/sys-libs/openipmi/openipmi-2.0.16.ebuild
new file mode 100644
index 000000000000..cfd4ffd2a483
--- /dev/null
+++ b/sys-libs/openipmi/openipmi-2.0.16.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/openipmi/openipmi-2.0.16.ebuild,v 1.1 2009/12/28 00:14:44 robbat2 Exp $
+
+inherit autotools python
+
+DESCRIPTION="Library interface to IPMI"
+HOMEPAGE="http://sourceforge.net/projects/openipmi/"
+MY_PN="OpenIPMI"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="crypt snmp perl tcl python"
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="dev-libs/glib
+ sys-libs/gdbm
+ crypt? ( dev-libs/openssl )
+ snmp? ( net-analyzer/net-snmp )
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )
+ tcl? ( dev-lang/tcl )"
+DEPEND="${RDEPEND}
+ >=dev-lang/swig-1.3.21
+ dev-util/pkgconfig"
+# Gui is broken!
+# python? ( tcl? ( tk? ( dev-lang/tk dev-tcltk/tix ) ) )"
+
+# Upstream doesn't use --without properly
+use_yesno() {
+ yesmsg="yes"
+ [ -n "$3" ] && yesmsg="$3"
+ if use $1; then
+ echo "--with-$2=${yesmsg}"
+ else
+ echo "--without-$2"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ # Bug #290763: The buildsys tries to compile+optimize the py file during
+ # install, when the .so might not be been added yet. We just skip the files
+ # and use python_mod_optimize ourselves later instead.
+ sed -r -i \
+ -e '/INSTALL.*\.py[oc] /d' \
+ -e '/install-exec-local/s,OpenIPMI.pyc OpenIPMI.pyo,,g' \
+ "${S}"/swig/python/Makefile.am \
+ "${S}"/swig/python/Makefile.in
+ # We touch the .in and .am above because if we use the below, the Perl stuff
+ # is very fragile, and often fails to link.
+ #cd "${S}"
+ #elibtoolize
+ #eautoreconf
+}
+
+src_compile() {
+ local myconf=""
+ myconf="${myconf} `use_with snmp ucdsnmp yes`"
+ myconf="${myconf} `use_with crypt openssl yes`"
+ myconf="${myconf} `use_with perl perl yes`"
+ myconf="${myconf} `use_with tcl tcl yes`"
+ myconf="${myconf} `use_with python python yes`"
+
+ # GUI is broken
+ #use tk && use python && use !tcl && \
+ # ewarn "Not building Tk GUI because it needs both Python AND Tcl"
+ #if use python && use tcl; then
+ # myconf="${myconf} `use_yesno tk tkinter yes`"
+ #else
+ # myconf="${myconf} `use_yesno tk tkinter no`"
+ #fi
+
+ myconf="${myconf} --without-tkinter"
+ myconf="${myconf} --with-glib --with-swig"
+ # these binaries are for root!
+ econf ${myconf} --bindir=/usr/sbin || die "econf failed"
+ emake || die "emake $i failed"
+}
+
+src_install() {
+ # bug #298250
+ emake -j1 DESTDIR="${D}" install || die
+ dodoc README* FAQ ChangeLog TODO doc/IPMI.pdf lanserv/README.emulator
+ newdoc cmdlang/README README.cmdlang
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize
+}