summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-26 02:17:30 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-26 02:17:30 +0000
commit51dca9f26befcd14b8878e8bf2cbde859dabbe65 (patch)
tree0844585a759a07b01735aadcef59bafce1319042 /sys-libs
parentOnly install the NeXT icon set if neXt is in USE; New upstream version; Port ... (diff)
downloadgentoo-2-51dca9f26befcd14b8878e8bf2cbde859dabbe65.tar.gz
gentoo-2-51dca9f26befcd14b8878e8bf2cbde859dabbe65.tar.bz2
gentoo-2-51dca9f26befcd14b8878e8bf2cbde859dabbe65.zip
Define alt_build_headers for the --with-headers option and for checking for nptl support #114923.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild15
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild16
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild15
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild15
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r1.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r2.ebuild6
6 files changed, 44 insertions, 29 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
index a8c3f98d98ff..f47d806c8b8c 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.52 2006/01/11 01:04:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.53 2006/01/26 02:17:30 vapier Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -87,6 +87,13 @@ alt_headers() {
fi
echo "${ALT_HEADERS}"
}
+alt_build_headers() {
+ if [[ -z ${ALT_BUILD_HEADERS} ]] ; then
+ ALT_BUILD_HEADERS=$(alt_headers)
+ tc-is-cross-compiler && ALT_BUILD_HEADERS=${ROOT}$(alt_headers)
+ fi
+ echo "${ALT_BUILD_HEADERS}"
+}
alt_prefix() {
if [[ ${CTARGET} = ${CHOST} ]] ; then
echo /usr
@@ -201,7 +208,7 @@ setup_flags() {
check_kheader_version() {
- local header="$(alt_headers)/linux/version.h"
+ local header="$(alt_build_headers)/linux/version.h"
[ -z "$1" ] && return 1
@@ -672,15 +679,13 @@ src_compile() {
mkdir -p ${WORKDIR}/build
cd ${WORKDIR}/build
# Pick out the correct location for build headers
- local headersloc=$(alt_headers)
- tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
${S}/configure \
--build=${CHOST} \
--host=${CTARGET} \
--disable-profile \
--without-gd \
--without-cvs \
- --with-headers=${headersloc} \
+ --with-headers=$(alt_build_headers) \
--prefix=$(alt_prefix) \
--mandir=$(alt_prefix)/share/man \
--infodir=$(alt_prefix)/share/info \
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
index 3deae88ac555..305c14a35623 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.23 2006/01/11 01:04:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.24 2006/01/26 02:17:30 vapier Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -87,6 +87,13 @@ alt_headers() {
fi
echo "${ALT_HEADERS}"
}
+alt_build_headers() {
+ if [[ -z ${ALT_BUILD_HEADERS} ]] ; then
+ ALT_BUILD_HEADERS=$(alt_headers)
+ tc-is-cross-compiler && ALT_BUILD_HEADERS=${ROOT}$(alt_headers)
+ fi
+ echo "${ALT_BUILD_HEADERS}"
+}
alt_prefix() {
if [[ ${CTARGET} = ${CHOST} ]] ; then
echo /usr
@@ -201,7 +208,7 @@ setup_flags() {
check_kheader_version() {
- local header="$(alt_headers)/linux/version.h"
+ local header="$(alt_build_headers)/linux/version.h"
[ -z "$1" ] && return 1
@@ -695,9 +702,6 @@ glibc_do_configure() {
myconf="${myconf} --without-selinux"
fi
- # Pick out the correct location for build headers
- local headersloc=$(alt_headers)
- tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
# Who knows if this works :)
[[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
myconf="${myconf} --without-cvs
@@ -706,7 +710,7 @@ glibc_do_configure() {
--host=${CTARGET}
--disable-profile
--without-gd
- --with-headers=${headersloc}
+ --with-headers=$(alt_build_headers)
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild
index 3a71b5af2775..831441cd05fb 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild,v 1.10 2006/01/25 03:22:17 dostrow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild,v 1.11 2006/01/26 02:17:30 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -612,6 +612,13 @@ alt_headers() {
fi
echo "${ALT_HEADERS}"
}
+alt_build_headers() {
+ if [[ -z ${ALT_BUILD_HEADERS} ]] ; then
+ ALT_BUILD_HEADERS=$(alt_headers)
+ tc-is-cross-compiler && ALT_BUILD_HEADERS=${ROOT}$(alt_headers)
+ fi
+ echo "${ALT_BUILD_HEADERS}"
+}
alt_prefix() {
if is_crosscompile ; then
@@ -711,7 +718,7 @@ setup_flags() {
}
check_kheader_version() {
- local header="${ROOT}$(alt_headers)/linux/version.h"
+ local header="$(alt_build_headers)/linux/version.h"
[[ -z $1 ]] && return 1
@@ -940,8 +947,6 @@ glibc_do_configure() {
fi
# Pick out the correct location for build headers
- local headersloc=$(alt_headers)
- tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -949,7 +954,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
--disable-profile
--without-gd
- --with-headers=${headersloc}
+ --with-headers=$(alt_build_headers)
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index 71efd3dafbc0..95c57a17d1fe 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.65 2005/12/18 02:10:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.66 2006/01/26 02:17:30 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -601,6 +601,13 @@ alt_headers() {
fi
echo "${ALT_HEADERS}"
}
+alt_build_headers() {
+ if [[ -z ${ALT_BUILD_HEADERS} ]] ; then
+ ALT_BUILD_HEADERS=$(alt_headers)
+ tc-is-cross-compiler && ALT_BUILD_HEADERS=${ROOT}$(alt_headers)
+ fi
+ echo "${ALT_BUILD_HEADERS}"
+}
alt_prefix() {
if is_crosscompile ; then
@@ -704,7 +711,7 @@ setup_flags() {
}
check_kheader_version() {
- local header="${ROOT}$(alt_headers)/linux/version.h"
+ local header="$(alt_build_headers)/linux/version.h"
[[ -z $1 ]] && return 1
@@ -885,8 +892,6 @@ glibc_do_configure() {
fi
# Pick out the correct location for build headers
- local headersloc=$(alt_headers)
- tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -894,7 +899,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
--disable-profile
--without-gd
- --with-headers=${headersloc}
+ --with-headers=$(alt_build_headers)
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
diff --git a/sys-libs/glibc/glibc-2.3.6-r1.ebuild b/sys-libs/glibc/glibc-2.3.6-r1.ebuild
index c1a1a5b44bec..38d0c31ffd1b 100644
--- a/sys-libs/glibc/glibc-2.3.6-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r1.ebuild,v 1.15 2006/01/25 04:39:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r1.ebuild,v 1.16 2006/01/26 02:17:30 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -950,8 +950,6 @@ glibc_do_configure() {
fi
# Pick out the correct location for build headers
- local headersloc=$(alt_headers)
- tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -959,7 +957,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
--without-gd
- --with-headers=${headersloc}
+ --with-headers=$(alt_build_headers)
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
diff --git a/sys-libs/glibc/glibc-2.3.6-r2.ebuild b/sys-libs/glibc/glibc-2.3.6-r2.ebuild
index 3db306506f3e..922126e33c67 100644
--- a/sys-libs/glibc/glibc-2.3.6-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r2.ebuild,v 1.12 2006/01/25 04:39:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r2.ebuild,v 1.13 2006/01/26 02:17:30 vapier Exp $
# TODO:
# - fix warning from glibc build system:
@@ -266,8 +266,6 @@ toolchain-glibc_headers_compile() {
cd "${GBUILDDIR}"
# Pick out the correct location for build headers
- local headersloc=$(alt_headers)
- tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
local myconf="--disable-sanity-checks --enable-hacker-mode"
myconf="${myconf}
--enable-add-ons=linuxthreads
@@ -275,7 +273,7 @@ toolchain-glibc_headers_compile() {
--enable-bind-now
--build=${CBUILD_OPT:-${CBUILD}}
--host=${CTARGET_OPT:-${CTARGET}}
- --with-headers=${headersloc}
+ --with-headers=$(alt_build_headers)
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info