summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-21 09:59:37 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-21 09:59:37 +0000
commit890ef043eb626101f3a5095b7d030c98961ac965 (patch)
treefeaf1ad5dff27ab4d001f563d07b800a2a4ca825 /sys-libs
parentInitial package release. (diff)
downloadgentoo-2-890ef043eb626101f3a5095b7d030c98961ac965.tar.gz
gentoo-2-890ef043eb626101f3a5095b7d030c98961ac965.tar.bz2
gentoo-2-890ef043eb626101f3a5095b7d030c98961ac965.zip
No more gzipped html documentation
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/ncurses/ChangeLog10
-rw-r--r--sys-libs/ncurses/files/digest-ncurses-5.2-r52
-rw-r--r--sys-libs/ncurses/ncurses-5.2-r5.ebuild75
3 files changed, 86 insertions, 1 deletions
diff --git a/sys-libs/ncurses/ChangeLog b/sys-libs/ncurses/ChangeLog
index 068096a5e5a1..53f0c337df10 100644
--- a/sys-libs/ncurses/ChangeLog
+++ b/sys-libs/ncurses/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-libs/ncurses
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.1 2002/02/01 21:53:38 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.2 2002/03/21 09:59:37 seemant Exp $
+
+*ncurses-5.2-r5 (21 Mar 2002)
+
+ 12 Mar 2002; Seemant Kulleen <seemant@gentoo.org> ncurses-5.2-r5.ebuild :
+
+ stefan@mdy.univie.ac.at pointed out html documentation getting gzipped
+ unnecessarily. This is now fixed in r5. I noticed a prior r4 which does
+ not work anyway, so this is based off r3.
*ncurses-5.2-r3 (1 Feb 2002)
diff --git a/sys-libs/ncurses/files/digest-ncurses-5.2-r5 b/sys-libs/ncurses/files/digest-ncurses-5.2-r5
new file mode 100644
index 000000000000..0bad2de85996
--- /dev/null
+++ b/sys-libs/ncurses/files/digest-ncurses-5.2-r5
@@ -0,0 +1,2 @@
+MD5 199133b047319f962e462be24995f68a ncurses-5.2.tar.gz 139790
+MD5 7a67970c140c53671db2a9f4d1e81aa5 ncurses-5.2-20010908.patch.gz 538750
diff --git a/sys-libs/ncurses/ncurses-5.2-r5.ebuild b/sys-libs/ncurses/ncurses-5.2-r5.ebuild
new file mode 100644
index 000000000000..6ed9496d7875
--- /dev/null
+++ b/sys-libs/ncurses/ncurses-5.2-r5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Achim Gottinger <achim@gentoo.org>, Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.2-r5.ebuild,v 1.1 2002/03/21 09:59:37 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Linux console display libarary"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/ncurses/ncurses.html"
+DEPEND="virtual/glibc"
+
+src_compile() {
+ if [ -z "$DEBUG" ]
+ then
+ myconf="${myconf} --without-debug"
+ fi
+ rm -rf test
+ ./configure --prefix=/usr --libdir=/lib --mandir=/usr/share/man --enable-symlinks --enable-termcap --with-shared --with-rcs-ids --host=${CHOST} ${myconf} || die
+ echo "all:" > test/Makefile
+ # Parallel make fails sometimes so I removed MAKEOPTS
+ make || die
+}
+
+src_install() {
+ dodir /usr/lib
+ echo "install:" >> ${S}/test/Makefile
+ make DESTDIR=${D} install || die
+
+ cd ${D}/lib
+ ln -s libncurses.a libcurses.a
+ chmod 755 ${D}/lib/*.${PV}
+ dodir /usr/lib
+ mv libform* libmenu* libpanel* ../usr/lib
+ mv *.a ../usr/lib
+
+ #with this fix, the default xterm has color as it should
+ cd ${D}/usr/share/terminfo/x
+ mv xterm xterm.orig
+ ln -s xterm-color xterm
+
+ if [ "`use build`" ]
+ then
+ cd ${D}
+ rm -rf usr/share/man
+ cd usr/share/terminfo
+ cp -a l/linux n/nxterm v/vt100 ${T}
+ rm -rf *
+ mkdir l x v
+ cp -a ${T}/linux l
+ cp -a ${T}/nxterm x/xterm
+ cp -a ${T}/vt100 v
+ cd ${D}/usr/lib
+ #bash compilation requires static libncurses libraries, so
+ #this breaks the "build a new build image" system. We now
+ #need to remove libncurses.a from the build image manually.
+ #rm *.a
+ else
+ cd ${S}
+ dodoc ANNOUNCE MANIFEST NEWS README* TO-DO
+ dodoc doc/*.doc
+ dohtml -r doc/html/
+# docinto html/ada
+# dodoc doc/html/ada/*.htm
+# docinto html/ada/files
+# dodoc doc/html/ada/files/*.htm
+# docinto html/ada/funcs
+# dodoc doc/html/ada/funcs/*.htm
+# docinto html/man
+# dodoc doc/html/man/*.html
+ fi
+}
+
+
+