summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-14 20:22:59 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-14 20:22:59 +0000
commit93f7c332985324adbd68aed54a165e00b4872abf (patch)
tree2284525374f661c8cff9b45b8b3c9bacb6e30a03 /sys-libs
parentDrop myconf entirely. Add || die to sed. Fix LICENSE variable to list both li... (diff)
downloadgentoo-2-93f7c332985324adbd68aed54a165e00b4872abf.tar.gz
gentoo-2-93f7c332985324adbd68aed54a165e00b4872abf.tar.bz2
gentoo-2-93f7c332985324adbd68aed54a165e00b4872abf.zip
Revbump to respect LDFLAGS. Thanks to Dane Smith <smithdanea@gmail.com> for the patch
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/tdb/ChangeLog8
-rw-r--r--sys-libs/tdb/tdb-1.2.1-r1.ebuild75
2 files changed, 82 insertions, 1 deletions
diff --git a/sys-libs/tdb/ChangeLog b/sys-libs/tdb/ChangeLog
index eed20bc6892e..cc8cd3124715 100644
--- a/sys-libs/tdb/ChangeLog
+++ b/sys-libs/tdb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/tdb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/ChangeLog,v 1.20 2010/08/12 01:14:43 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/ChangeLog,v 1.21 2010/08/14 20:22:59 hwoarang Exp $
+
+*tdb-1.2.1-r1 (14 Aug 2010)
+
+ 14 Aug 2010; Markos Chandras <hwoarang@gentoo.org> +tdb-1.2.1-r1.ebuild:
+ Revbump to respect LDFLAGS. Thanks to Dane Smith <smithdanea@gmail.com>
+ for the patch
12 Aug 2010; Joseph Jezak <josejx@gentoo.org> tdb-1.2.1.ebuild:
Marked ppc stable for bug #300158.
diff --git a/sys-libs/tdb/tdb-1.2.1-r1.ebuild b/sys-libs/tdb/tdb-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..5e4fb0092db7
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.2.1-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.1-r1.ebuild,v 1.1 2010/08/14 20:22:59 hwoarang Exp $
+
+EAPI="2"
+
+inherit autotools python
+
+DESCRIPTION="Samba tdb"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="python static-libs tools tdbtest"
+
+RDEPEND=""
+DEPEND="python? ( dev-lang/python )
+ !<net-fs/samba-libs-3.4
+ !<net-fs/samba-3.3
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt"
+
+src_prepare() {
+ eautoconf -Ilibreplace
+ sed -i \
+ -e 's:$(SHLD_FLAGS) :$(SHLD_FLAGS) $(LDFLAGS) :' \
+ {Makefile.in,tdb.mk} || die "sed failed"
+
+ # xsltproc will display a warning but we can assume the xml files are valid
+ sed -i \
+ -e 's|$(XSLTPROC) -o|$(XSLTPROC) --nonet -o|' \
+ tdb.mk || die "sed failed"
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/samba \
+ --localstatedir=/var \
+ $(use_enable python)
+}
+
+src_compile() {
+ # TODO:
+ # - don't build static-libs in case of USE=-static-libs
+
+ # we create the directories first to avoid workaround parallel build problem
+ emake dirs || die "emake dirs failed"
+
+ emake shared-build || die "emake shared-build failed"
+
+ if use tdbtest ; then
+ emake bin/tdbtest || die "emake tdbtest failed"
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ # installs a necessary symlink
+ dolib.so sharedbuild/lib/libtdb.so
+
+ dodoc docs/README
+
+ use static-libs || rm -f "${D}"/usr/lib*/*.a
+ use tools || rm -rf "${D}/usr/bin"
+ use tdbtest && dobin bin/tdbtest
+ use python && python_need_rebuild
+}
+
+src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check || die "emake check failed"
+}