summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2010-08-20 17:34:13 +0000
committerHanno Böck <hanno@gentoo.org>2010-08-20 17:34:13 +0000
commitc8d92e5c32a76a837a1b8e56ca3a0696cdceae79 (patch)
tree7937f0ca117aa5507714ec9f5913e30b14f12fcd /sys-libs
parentPatch to fix page table unmap for stack guard page (diff)
downloadgentoo-2-c8d92e5c32a76a837a1b8e56ca3a0696cdceae79.tar.gz
gentoo-2-c8d92e5c32a76a837a1b8e56ca3a0696cdceae79.tar.bz2
gentoo-2-c8d92e5c32a76a837a1b8e56ca3a0696cdceae79.zip
libhx bump and security fix
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libhx/ChangeLog9
-rw-r--r--sys-libs/libhx/files/libhx-3.5-buffer-overflow.patch43
-rw-r--r--sys-libs/libhx/libhx-3.5.ebuild34
3 files changed, 85 insertions, 1 deletions
diff --git a/sys-libs/libhx/ChangeLog b/sys-libs/libhx/ChangeLog
index 2522d7be4f54..6bb689c5c355 100644
--- a/sys-libs/libhx/ChangeLog
+++ b/sys-libs/libhx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/libhx
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libhx/ChangeLog,v 1.23 2010/08/13 13:31:54 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libhx/ChangeLog,v 1.24 2010/08/20 17:34:13 hanno Exp $
+
+*libhx-3.5 (20 Aug 2010)
+
+ 20 Aug 2010; Hanno Boeck <hanno@gentoo.org> +libhx-3.5.ebuild,
+ +files/libhx-3.5-buffer-overflow.patch:
+ Version bump and fix for security bug #333635, thanks to Tim Sammut for
+ notice.
13 Aug 2010; Joseph Jezak <josejx@gentoo.org> libhx-3.4.ebuild:
Marked ppc stable for bug #328501.
diff --git a/sys-libs/libhx/files/libhx-3.5-buffer-overflow.patch b/sys-libs/libhx/files/libhx-3.5-buffer-overflow.patch
new file mode 100644
index 000000000000..ae6ff91bb9bf
--- /dev/null
+++ b/sys-libs/libhx/files/libhx-3.5-buffer-overflow.patch
@@ -0,0 +1,43 @@
+diff --git a/src/string.c b/src/string.c
+index 1acfab2..bea6e71 100644
+--- a/src/string.c
++++ b/src/string.c
+@@ -153,7 +153,7 @@ EXPORT_SYMBOL char **HX_split(const char *str, const char *delim,
+ }
+ }
+
+- if (max == 0)
++ if (max == 0 || *cp < max)
+ max = *cp;
+ else if (*cp > max)
+ *cp = max;
+diff --git a/src/tx-string.cpp b/src/tx-string.cpp
+index 4e9a534..cc2cbf8 100644
+--- a/src/tx-string.cpp
++++ b/src/tx-string.cpp
+@@ -142,6 +142,17 @@ static void t_split(void)
+ free(a1);
+ }
+
++static void t_split2(void)
++{
++ static const char tmp[] = "";
++ int c = 0;
++ char **a;
++
++ a = HX_split(tmp, " ", &c, 6);
++ printf("Got %d fields\n", c);
++ HX_zvecfree(a);
++}
++
+ static void t_quote(void)
+ {
+ char *fm = NULL;
+@@ -178,6 +189,7 @@ int main(int argc, const char **argv)
+ t_strncat();
+ t_strsep();
+ t_split();
++ t_split2();
+ t_quote();
+ HXmc_free(tx);
+ HX_exit();
diff --git a/sys-libs/libhx/libhx-3.5.ebuild b/sys-libs/libhx/libhx-3.5.ebuild
new file mode 100644
index 000000000000..d3c5e9a2c0c0
--- /dev/null
+++ b/sys-libs/libhx/libhx-3.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libhx/libhx-3.5.ebuild,v 1.1 2010/08/20 17:34:13 hanno Exp $
+
+EAPI=3
+
+inherit eutils
+
+DESCRIPTION="Platform independent library providing basic system functions."
+HOMEPAGE="http://libhx.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/libHX-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+RDEPEND=""
+
+S="${WORKDIR}/libHX-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-buffer-overflow.patch"
+}
+
+src_configure() {
+ econf --docdir="/usr/share/doc/${PF}" || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc doc/*.txt || die
+}