summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Gabert <pappy@gentoo.org>2003-11-16 15:05:58 +0000
committerAlexander Gabert <pappy@gentoo.org>2003-11-16 15:05:58 +0000
commitd56401bc8248f12f2e0e10541ca3623c9b3d60c5 (patch)
tree42d506f3c099b48963d888b5de929459a10faedc /sys-libs
parentremoved text relocations out of the libcap library for hardened-gcc via sysca... (diff)
downloadgentoo-2-d56401bc8248f12f2e0e10541ca3623c9b3d60c5.tar.gz
gentoo-2-d56401bc8248f12f2e0e10541ca3623c9b3d60c5.tar.bz2
gentoo-2-d56401bc8248f12f2e0e10541ca3623c9b3d60c5.zip
removed text relocations out of the libcap library for hardened-gcc via syscall removal patch
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcap/ChangeLog6
-rw-r--r--sys-libs/libcap/Manifest4
-rw-r--r--sys-libs/libcap/libcap-1.10.ebuild13
3 files changed, 18 insertions, 5 deletions
diff --git a/sys-libs/libcap/ChangeLog b/sys-libs/libcap/ChangeLog
index 3a74dfbd7122..b26b927922cd 100644
--- a/sys-libs/libcap/ChangeLog
+++ b/sys-libs/libcap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/libcap
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/ChangeLog,v 1.14 2003/11/05 01:22:31 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/ChangeLog,v 1.15 2003/11/16 15:05:53 pappy Exp $
+
+ 16 Nov 2003; Alexander Gabert <pappy@gentoo.org> libcap-1.10.ebuild:
+ removed text relocations out of the libcap library for hardened-gcc via
+ syscall removal patch
04 Nov 2003; Brad House <brad_mssw@gentoo.org> libcap-1.10-r3.ebuild:
add amd64 flag
diff --git a/sys-libs/libcap/Manifest b/sys-libs/libcap/Manifest
index dcc86d9efee5..ddbb6eaa2038 100644
--- a/sys-libs/libcap/Manifest
+++ b/sys-libs/libcap/Manifest
@@ -1,7 +1,7 @@
MD5 f69f94768d91879ce67e7b61d10927d5 libcap-1.10-r3.ebuild 1887
-MD5 47f3babdcee5c70fcf716a2e49d70e05 libcap-1.10.ebuild 2088
+MD5 35a3d9b593765695ecbd82ce77798e21 libcap-1.10.ebuild 2084
MD5 510725e722e6c593968f928c994b0d9d libcap-1.10-r2.ebuild 1610
-MD5 3a41941f07785efa04195b061d9ecbeb ChangeLog 2290
+MD5 8d814cd2451c8392a639bb262e8110b2 ChangeLog 2286
MD5 3aa7335821ba75c0994083995b0331f2 files/libcap-1.10-syscall.patch 1051
MD5 8f279ebf325d1b8efb6ad3c3a0d8cb5d files/libcap-1.10-python.patch 3353
MD5 f55c8f8c068940da50e21f4d4b840422 files/digest-libcap-1.10-r2 63
diff --git a/sys-libs/libcap/libcap-1.10.ebuild b/sys-libs/libcap/libcap-1.10.ebuild
index d6b8645c8729..16de3d44954c 100644
--- a/sys-libs/libcap/libcap-1.10.ebuild
+++ b/sys-libs/libcap/libcap-1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/libcap-1.10.ebuild,v 1.14 2003/10/18 08:32:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/libcap-1.10.ebuild,v 1.15 2003/11/16 15:05:53 pappy Exp $
inherit base flag-o-matic
@@ -22,12 +22,21 @@ RDEPEND="python? ( >=virtual/python-2.2.1 )"
src_unpack() {
unpack ${A}
cd ${S}
+ # hardened-gcc needs this PIC patch to remove .TEXT relocations from the libcap library
+ has_version "sys-devel/hardened-gcc" && epatch ${FILESDIR}/${PF}-syscall.patch
epatch ${FILESDIR}/${PF}-python.patch
}
src_compile() {
PYTHONVER="`python -V 2>&1 | sed 's/^Python //'|sed 's/\([0-9]*\.[0-9]*\).*/\1/'`"
- filter-flags -fPIC
+
+ # filter-flags the PIC option only if hcc is not found active
+ # and thats way the syscall removal patch will not be applied
+ if ! has_version sys-devel/hardened-gcc
+ then
+ filter-flags -fPIC
+ fi
+
local myflags=""
if [ `use python` ]; then
myflags="${myflags} PYTHON=1 PYTHONMODDIR=/usr/lib/python${PYTHONVER}/site-packages"