summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-06 16:15:28 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-06 16:15:28 +0000
commitf1a553fdd97d78f2a989d3b5d2023adae6650271 (patch)
tree5e79285acaa54f28cef100112c1952458b6a5a26 /sys-libs
parentrevert locale-gen job updates as this one still has the old version and tweak... (diff)
downloadgentoo-2-f1a553fdd97d78f2a989d3b5d2023adae6650271.tar.gz
gentoo-2-f1a553fdd97d78f2a989d3b5d2023adae6650271.tar.bz2
gentoo-2-f1a553fdd97d78f2a989d3b5d2023adae6650271.zip
fix simple sanity checks #149690 by Christian Schmidt
(Portage version: 2.1.2_pre2-r5)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.4-r4.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.5.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/glibc/glibc-2.4-r4.ebuild b/sys-libs/glibc/glibc-2.4-r4.ebuild
index 8ea58420882a..cb615cedb6f9 100644
--- a/sys-libs/glibc/glibc-2.4-r4.ebuild
+++ b/sys-libs/glibc/glibc-2.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4-r4.ebuild,v 1.2 2006/10/04 14:12:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4-r4.ebuild,v 1.3 2006/10/06 16:15:28 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -498,7 +498,7 @@ toolchain-glibc_src_install() {
[[ -z ${x} ]] && continue
striptest=$(LC_ALL="C" file -L ${x} 2>/dev/null)
[[ -z ${striptest} ]] && continue
- [[ ${striptest} != *"statically linked"* ]] && continue
+ [[ ${striptest} == *"statically linked"* ]] && continue
"${D}"/$(get_libdir)/ld-*.so \
--library-path "${D}"/$(get_libdir) \
${x} > /dev/null \
diff --git a/sys-libs/glibc/glibc-2.5.ebuild b/sys-libs/glibc/glibc-2.5.ebuild
index ce91173a2827..241adabaaf21 100644
--- a/sys-libs/glibc/glibc-2.5.ebuild
+++ b/sys-libs/glibc/glibc-2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.5.ebuild,v 1.1 2006/09/30 18:21:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.5.ebuild,v 1.2 2006/10/06 16:15:28 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -398,7 +398,7 @@ toolchain-glibc_src_install() {
[[ -z ${x} ]] && continue
striptest=$(LC_ALL="C" file -L ${x} 2>/dev/null)
[[ -z ${striptest} ]] && continue
- [[ ${striptest} != *"statically linked"* ]] && continue
+ [[ ${striptest} == *"statically linked"* ]] && continue
"${D}"/$(get_libdir)/ld-*.so \
--library-path "${D}"/$(get_libdir) \
${x} > /dev/null \