summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-07-18 14:14:47 +0000
committerChristoph Junghans <ottxor@gentoo.org>2013-07-18 14:14:47 +0000
commitdd115037b8e5bc2ce6b9d70de8a9c9553fb8f431 (patch)
treeeee3fdc17d438aac768ccf225b47dd64bc10ad18 /sys-power/acpi_call/acpi_call-1.1.0.ebuild
parentsci-chemistry/molequeue: New addition written by me (diff)
downloadgentoo-2-dd115037b8e5bc2ce6b9d70de8a9c9553fb8f431.tar.gz
gentoo-2-dd115037b8e5bc2ce6b9d70de8a9c9553fb8f431.tar.bz2
gentoo-2-dd115037b8e5bc2ce6b9d70de8a9c9553fb8f431.zip
version bump (bug #475392)
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sys-power/acpi_call/acpi_call-1.1.0.ebuild')
-rw-r--r--sys-power/acpi_call/acpi_call-1.1.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-power/acpi_call/acpi_call-1.1.0.ebuild b/sys-power/acpi_call/acpi_call-1.1.0.ebuild
new file mode 100644
index 000000000000..d1501423cda4
--- /dev/null
+++ b/sys-power/acpi_call/acpi_call-1.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpi_call/acpi_call-1.1.0.ebuild,v 1.1 2013/07/18 14:14:47 ottxor Exp $
+
+EAPI=5
+
+inherit linux-info linux-mod
+
+if [ "${PV}" = "9999" ]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/mkottman/acpi_call.git"
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/mkottman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A kernel module that enables you to call ACPI methods"
+HOMEPAGE="http://github.com/mkottman/acpi_call"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+CONFIG_CHECK="ACPI"
+MODULE_NAMES="acpi_call(misc:${S})"
+BUILD_TARGETS="default"
+
+src_compile(){
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+ linux-mod_src_compile
+}