summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-09-25 08:09:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-09-25 08:09:29 +0000
commit145ef25863b3d2298709f47c94785f32250183ad (patch)
tree79592fc9428c29f2028fa5b04f3941ce94d8e4a9 /sys-power/acpid
parentForce <sys-fs/samba-4 for <media-libs/xine-lib-1.2.4 wrt #453532 by Rafał Mu... (diff)
downloadgentoo-2-145ef25863b3d2298709f47c94785f32250183ad.tar.gz
gentoo-2-145ef25863b3d2298709f47c94785f32250183ad.tar.bz2
gentoo-2-145ef25863b3d2298709f47c94785f32250183ad.zip
Version bump.
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-power/acpid')
-rw-r--r--sys-power/acpid/ChangeLog7
-rw-r--r--sys-power/acpid/acpid-2.0.20.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/sys-power/acpid/ChangeLog b/sys-power/acpid/ChangeLog
index 58063309228e..1dbea7bf4e42 100644
--- a/sys-power/acpid/ChangeLog
+++ b/sys-power/acpid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/acpid
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.106 2013/07/26 18:39:51 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.107 2013/09/25 08:09:29 ssuominen Exp $
+
+*acpid-2.0.20 (25 Sep 2013)
+
+ 25 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +acpid-2.0.20.ebuild:
+ Version bump.
*acpid-2.0.19 (26 Jul 2013)
diff --git a/sys-power/acpid/acpid-2.0.20.ebuild b/sys-power/acpid/acpid-2.0.20.ebuild
new file mode 100644
index 000000000000..531462072443
--- /dev/null
+++ b/sys-power/acpid/acpid-2.0.20.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-2.0.20.ebuild,v 1.1 2013/09/25 08:09:29 ssuominen Exp $
+
+EAPI=5
+inherit systemd
+
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
+HOMEPAGE="http://sourceforge.net/projects/acpid2"
+SRC_URI="mirror://sourceforge/${PN}2/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 -ppc ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-apm )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newdoc kacpimon/README README.kacpimon
+ dodoc -r samples
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING || die
+
+ exeinto /etc/acpi
+ newexe "${FILESDIR}"/${PN}-1.0.6-default.sh default.sh
+ exeinto /etc/acpi/actions
+ newexe samples/powerbtn/powerbtn.sh powerbtn.sh
+ insinto /etc/acpi/events
+ newins "${FILESDIR}"/${PN}-1.0.4-default default
+
+ newinitd "${FILESDIR}"/${PN}-2.0.16-init.d ${PN}
+ newconfd "${FILESDIR}"/${PN}-2.0.16-conf.d ${PN}
+
+ systemd_dounit "${FILESDIR}"/systemd/${PN}.{service,socket}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "You may wish to read the Gentoo Linux Power Management Guide,"
+ elog "which can be found online at:"
+ elog "http://www.gentoo.org/doc/en/power-management-guide.xml"
+ elog
+ fi
+
+ # files/systemd/acpid.socket -> ListenStream=/run/acpid.socket
+ mkdir -p "${ROOT}"/run
+
+ if ! grep -qs "^tmpfs.*/run " "${ROOT}"/proc/mounts ; then
+ echo
+ ewarn "You should reboot the system now to get /run mounted with tmpfs!"
+ fi
+}