summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-05-18 06:05:29 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-05-18 06:05:29 +0000
commit1e8142fc50d2d23a15618efb634e99278fc056ea (patch)
treea4735e89cad7ed7e45983076953d4a0ccc5b42cb /sys-power/nut
parentFix bug #133523. (diff)
downloadgentoo-2-1e8142fc50d2d23a15618efb634e99278fc056ea.tar.gz
gentoo-2-1e8142fc50d2d23a15618efb634e99278fc056ea.tar.bz2
gentoo-2-1e8142fc50d2d23a15618efb634e99278fc056ea.zip
Version bump and clean up of Nut (bug #85296), resolving bugs for SSL, GD (bug #62745), USB (bug #73074), and moving portions to /sbin and /lib/nut to allow for poweroff where /usr is a seperate partition (bug #88832). Also add udev rules for new USB devices.
(Portage version: 2.1_rc1-r2)
Diffstat (limited to 'sys-power/nut')
-rw-r--r--sys-power/nut/ChangeLog10
-rw-r--r--sys-power/nut/files/digest-nut-2.0.33
-rw-r--r--sys-power/nut/nut-2.0.3.ebuild157
3 files changed, 169 insertions, 1 deletions
diff --git a/sys-power/nut/ChangeLog b/sys-power/nut/ChangeLog
index 8f70ed97d577..3be760e58ef6 100644
--- a/sys-power/nut/ChangeLog
+++ b/sys-power/nut/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-apps/nut
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/ChangeLog,v 1.1 2006/05/15 23:43:08 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/ChangeLog,v 1.2 2006/05/18 06:05:29 robbat2 Exp $
+
+*nut-2.0.3 (18 May 2006)
+
+ 18 May 2006; Robin H. Johnson <robbat2@gentoo.org> +nut-2.0.3.ebuild:
+ Version bump and clean up of Nut (bug #85296), resolving bugs for SSL, GD
+ (bug #62745), USB (bug #73074), and moving portions to /sbin and /lib/nut to
+ allow for poweroff where /usr is a seperate partition (bug #88832). Also add
+ udev rules for new USB devices.
15 May 2006; Robin H. Johnson <robbat2@gentoo.org> +files/upsd.rc6,
+files/upsdrv.rc6, +files/upsdrv.rc6-r1, +files/upsmon.rc6, +metadata.xml,
diff --git a/sys-power/nut/files/digest-nut-2.0.3 b/sys-power/nut/files/digest-nut-2.0.3
new file mode 100644
index 000000000000..55c8a6e59877
--- /dev/null
+++ b/sys-power/nut/files/digest-nut-2.0.3
@@ -0,0 +1,3 @@
+MD5 ed2d3104d021a6ddb864f23d8cbd1cf6 nut-2.0.3.tar.gz 656376
+RMD160 890c52b1ab538101c30e5be33e785817a773cdb9 nut-2.0.3.tar.gz 656376
+SHA256 e4ded1fd1f119a71ee500d043bfa08d912d84793738d81b2bd08871e34ed8f95 nut-2.0.3.tar.gz 656376
diff --git a/sys-power/nut/nut-2.0.3.ebuild b/sys-power/nut/nut-2.0.3.ebuild
new file mode 100644
index 000000000000..c9fd44b803ee
--- /dev/null
+++ b/sys-power/nut/nut-2.0.3.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.3.ebuild,v 1.1 2006/05/18 06:05:29 robbat2 Exp $
+
+inherit eutils fixheadtails
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="Network-UPS Tools"
+HOMEPAGE="http://www.networkupstools.org/"
+# Nut mirrors are presently broken
+#SRC_URI="mirror://nut/source/${PV%.*}/${MY_P}.tar.gz"
+SRC_URI="http://www.networkupstools.org/source/${PV%.*}/${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~ppc64 ~alpha ~amd64"
+IUSE="cgi snmp usb ssl"
+
+RDEPEND="cgi? ( >=media-libs/gd-2 )
+ snmp? ( net-analyzer/net-snmp )
+ usb? ( dev-libs/libusb )
+ ssl? ( dev-libs/openssl )"
+DEPEND="$RDEPEND
+ >=sys-apps/sed-4
+ >=sys-devel/autoconf-2.58"
+
+pkg_setup() {
+ enewgroup nut 84
+ enewuser nut 84 -1 /var/state/nut nut
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ sed -e "s/install: install-dirs/install: install-dirs install-conf/" \
+ -i Makefile.in || die "sed failed"
+
+ ht_fix_file configure.in
+
+ sed -e "s:GD_LIBS.*=.*-L/usr/X11R6/lib \(.*\) -lXpm -lX11:GD_LIBS=\"\1:" \
+ -i configure.in || die "sed failed"
+
+ ebegin "Recreating configure"
+ WANT_AUTOCONF=2.5 autoconf || die "autoconf failed"
+ eend $?
+}
+
+src_compile() {
+ local myconf
+
+ if [ -n "${NUT_DRIVERS}" ]; then
+ myconf="${myconf} --with-drivers=${NUT_DRIVERS// /,}"
+ fi
+
+ econf \
+ --with-user=nut \
+ --with-group=nut \
+ --with-drvpath=/lib/nut \
+ --sysconfdir=/etc/nut \
+ --with-logfacility=LOG_DAEMON \
+ --with-statepath=/var/lib/nut \
+ $(use_with ssl) \
+ $(use_with cgi) \
+ $(use_with cgi cgipath /usr/share/nut) \
+ ${myconf} || die "econf failed"
+
+ emake || die "compile problem"
+
+ if use snmp; then
+ emake snmp || die "snmp compile problem"
+ fi
+
+ if use usb; then
+ emake usb || die "usb compile problem"
+ fi
+
+ if use cgi; then
+ emake cgi || die "cgi compile problem"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install install-lib || die "make install failed"
+
+ dodir /sbin
+ dosym /lib/nut/upsdrvctl /sbin/upsdrvctl
+ # This needs to exist for the scripts
+ dosym /lib/nut/upsdrvctl /usr/sbin/upsdrvctl
+
+ if use snmp; then
+ make DESTDIR="${D}" install-snmp || die "make install-snmp failed"
+ fi
+
+ if use usb; then
+ make DESTDIR="${D}" install-usb || die "make install-usb failed"
+ fi
+
+ if use cgi; then
+ make DESTDIR="${D}" install-cgi || die "make install-cgi failed"
+ make DESTDIR="${D}" install-cgi-conf || die "make install-cgi-conf failed"
+ einfo "CGI monitoring scripts are installed in /usr/share/nut,"
+ einfo "copy them to your web server's ScriptPath to activate."
+ fi
+
+ # this must be done after all of the install phases
+ for i in "${D}"/etc/nut/*.sample ; do
+ mv "${i}" "${i/.sample/}"
+ done
+
+
+ dodoc CHANGES CREDITS INSTALL MAINTAINERS NEWS README UPGRADING \
+ docs/{FAQ,*.txt}
+
+ newdoc lib/README README.lib
+
+ docinto cables
+ dodoc docs/cables/*
+
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/upsd.rc6" upsd
+ newexe "${FILESDIR}/upsdrv.rc6-r1" upsdrv
+ newexe "${FILESDIR}/upsmon.rc6" upsmon
+
+ # This sets up permissions for nut to access a UPS
+ insinto /etc/udev/rules.d/
+ newins scripts/hotplug-ng/nut-usbups.rules 70-nut-usbups.rules
+
+ keepdir /var/lib/nut
+
+ fperms 0700 /var/lib/nut
+ fowners nut:nut /var/lib/nut
+
+ fperms 0640 /etc/nut/{upsd.conf,upsd.users,upsmon.conf}
+ fowners root:nut /etc/nut/{upsd.conf,upsd.users,upsmon.conf}
+
+ fperms 0640 /etc/nut/{hosts.conf,upsset.conf,upsstats{,-single}.html}
+ fowners root:nut /etc/nut/{hosts.conf,upsset.conf,upsstats{,-single}.html}
+}
+
+pkg_postinst() {
+ # this is to ensure that everybody that installed old versions still has
+ # correct permissions
+ chown nut:nut ${ROOT}/var/lib/nut 2>/dev/null
+ chmod 0700 ${ROOT}/var/lib/nut 2>/dev/null
+
+ chown root:nut ${ROOT}/etc/nut/{upsd.conf,upsd.users,upsmon.conf} 2>/dev/null
+ chmod 0640 ${ROOT}/etc/nut/{upsd.conf,upsd.users,upsmon.conf} 2>/dev/null
+
+ chown root:nut ${ROOT}/etc/nut/{hosts.conf,upsset.conf,upsstats{,-single}.html} 2>/dev/null
+ chmod 0640 ${ROOT}/etc/nut/{hosts.conf,upsset.conf,upsstats{,-single}.html} 2>/dev/null
+}