summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2008-03-30 21:43:29 +0000
committerWolfram Schlich <wschlich@gentoo.org>2008-03-30 21:43:29 +0000
commit32ba324e8f75440122a30e4d512e08e57ca99f03 (patch)
tree79fe240b372abb4f81ef4070679c08e8b294f0ce /sys-power/sispmctl/sispmctl-2.7.ebuild
parentVersion bump (diff)
downloadgentoo-2-32ba324e8f75440122a30e4d512e08e57ca99f03.tar.gz
gentoo-2-32ba324e8f75440122a30e4d512e08e57ca99f03.tar.bz2
gentoo-2-32ba324e8f75440122a30e4d512e08e57ca99f03.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-power/sispmctl/sispmctl-2.7.ebuild')
-rw-r--r--sys-power/sispmctl/sispmctl-2.7.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sys-power/sispmctl/sispmctl-2.7.ebuild b/sys-power/sispmctl/sispmctl-2.7.ebuild
new file mode 100644
index 000000000000..a6b1442a6c14
--- /dev/null
+++ b/sys-power/sispmctl/sispmctl-2.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/sispmctl/sispmctl-2.7.ebuild,v 1.1 2008/03/30 21:43:29 wschlich Exp $
+
+DESCRIPTION="GEMBIRD SiS-PM control utility"
+HOMEPAGE="http://sispmctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sispmctl/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+DEPEND=">=dev-libs/libusb-0.1.8"
+
+src_compile() {
+ local myconf="--enable-webless"
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog NEWS
+}