summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-09-05 15:30:56 +0000
committerRick Farina <zerochaos@gentoo.org>2012-09-05 15:30:56 +0000
commit9cc7e0e5f715ddfd18d68c2b1699827073f2cb31 (patch)
tree6c04f35e95aa0f90e4c6dd75242c80a8d4f78265 /sys-power
parentrevbump since the last patch was for a runtime issue instead of build-time (t... (diff)
downloadgentoo-2-9cc7e0e5f715ddfd18d68c2b1699827073f2cb31.tar.gz
gentoo-2-9cc7e0e5f715ddfd18d68c2b1699827073f2cb31.tar.bz2
gentoo-2-9cc7e0e5f715ddfd18d68c2b1699827073f2cb31.zip
version bump to 2.1
(Portage version: 2.1.11.13/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/powertop/ChangeLog8
-rw-r--r--sys-power/powertop/powertop-2.1.ebuild59
2 files changed, 65 insertions, 2 deletions
diff --git a/sys-power/powertop/ChangeLog b/sys-power/powertop/ChangeLog
index 61c92a780629..78376d5f40c0 100644
--- a/sys-power/powertop/ChangeLog
+++ b/sys-power/powertop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/powertop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.54 2012/06/01 18:36:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.55 2012/09/05 15:30:56 zerochaos Exp $
+
+*powertop-2.1 (05 Sep 2012)
+
+ 05 Sep 2012; Rick Farina <zerochaos@gentoo.org> +powertop-2.1.ebuild:
+ version bump to 2.1
01 Jun 2012; Mike Frysinger <vapier@gentoo.org> powertop-2.0.ebuild:
Drop hardcoded CXXFLAGS that break things.
@@ -229,4 +234,3 @@
+powertop-1.0.ebuild:
New ebuild thanks to Christian Merkle <gentoo-bugzilla@luemmel.org> in bug
178130
-
diff --git a/sys-power/powertop/powertop-2.1.ebuild b/sys-power/powertop/powertop-2.1.ebuild
new file mode 100644
index 000000000000..2df73632a3e3
--- /dev/null
+++ b/sys-power/powertop/powertop-2.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.1.ebuild,v 1.1 2012/09/05 15:30:56 zerochaos Exp $
+
+EAPI="4"
+
+inherit eutils
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/fenrus75/powertop.git"
+ inherit git-2
+ SRC_URI=""
+else
+ SRC_URI="https://01.org/powertop/sites/default/files/downloads/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="tool that helps you find what software is using the most power"
+HOMEPAGE="https://01.org/powertop/ http://www.lesswatts.org/projects/powertop/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="unicode"
+
+DEPEND="
+ dev-libs/libnl
+ sys-apps/pciutils
+ sys-devel/gettext
+ sys-libs/ncurses[unicode?]
+ sys-libs/zlib
+"
+RDEPEND="
+ ${DEPEND}
+ x11-apps/xset
+"
+
+DOCS=( TODO README )
+
+src_configure() {
+ export ac_cv_search_delwin=$(usex unicode -lncursesw no)
+ default
+}
+
+src_compile() {
+ #the clean is needed because the 2.1 tarball had object files in src/tuning/
+ emake clean
+ emake
+}
+
+src_install() {
+ default
+ keepdir /var/cache/powertop
+}
+
+pkg_postinst() {
+ echo
+ einfo "For PowerTOP to work best, use a Linux kernel with the"
+ einfo "tickless idle (NO_HZ) feature enabled (version 2.6.21 or later)"
+ echo
+}