summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-02-17 22:09:35 +0000
committerThilo Bangert <bangert@gentoo.org>2009-02-17 22:09:35 +0000
commit5511be8ce961eef87deaba31e733b07ebe7f5f6b (patch)
treeaf59545fd861b604988b4c219a13a64717de3267 /sys-process/cronie
parentr1 version that should fix a few currently open bugs (diff)
downloadgentoo-2-5511be8ce961eef87deaba31e733b07ebe7f5f6b.tar.gz
gentoo-2-5511be8ce961eef87deaba31e733b07ebe7f5f6b.tar.bz2
gentoo-2-5511be8ce961eef87deaba31e733b07ebe7f5f6b.zip
cronie - a vixie-cron fork by the fedora people
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-gentoo i686)
Diffstat (limited to 'sys-process/cronie')
-rw-r--r--sys-process/cronie/ChangeLog13
-rw-r--r--sys-process/cronie/cronie-1.2.ebuild55
-rw-r--r--sys-process/cronie/files/cronie-1.2-cron.deny5
-rw-r--r--sys-process/cronie/files/cronie-1.2-crontab18
-rwxr-xr-xsys-process/cronie/files/cronie-1.2-initd22
-rw-r--r--sys-process/cronie/files/cronie-1.2-pathnames.h-fix-SPOOL_DIR.patch11
-rw-r--r--sys-process/cronie/metadata.xml19
7 files changed, 143 insertions, 0 deletions
diff --git a/sys-process/cronie/ChangeLog b/sys-process/cronie/ChangeLog
new file mode 100644
index 000000000000..cfd0221334fc
--- /dev/null
+++ b/sys-process/cronie/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for sys-process/cronie
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/ChangeLog,v 1.1 2009/02/17 22:09:35 bangert Exp $
+
+*cronie-1.2 (17 Feb 2009)
+
+ 17 Feb 2009; Thilo Bangert <bangert@gentoo.org>
+ +files/cronie-1.2-cron.deny, +files/cronie-1.2-crontab,
+ +files/cronie-1.2-initd,
+ +files/cronie-1.2-pathnames.h-fix-SPOOL_DIR.patch, +metadata.xml,
+ +cronie-1.2.ebuild:
+ cronie - a vixie-cron fork by the fedora people
+
diff --git a/sys-process/cronie/cronie-1.2.ebuild b/sys-process/cronie/cronie-1.2.ebuild
new file mode 100644
index 000000000000..d99a22ddffa8
--- /dev/null
+++ b/sys-process/cronie/cronie-1.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.2.ebuild,v 1.1 2009/02/17 22:09:35 bangert Exp $
+
+inherit cron eutils
+
+DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron."
+SRC_URI="https://fedorahosted.org/releases/c/r/cronie/${P}.tar.gz"
+HOMEPAGE="https://fedorahosted.org/cronie/wiki"
+
+LICENSE="as-is BSD BSD-2"
+KEYWORDS="~x86"
+IUSE="inotify pam"
+
+DEPEND="pam? ( virtual/pam )"
+
+#cronie supports /etc/crontab
+CRON_SYSTEM_CRONTAB="yes"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-pathnames.h-fix-SPOOL_DIR.patch"
+}
+
+src_compile() {
+ econf \
+ $(use_with inotify ) \
+ $(use_with pam ) \
+ --with-daemon_username=cron \
+ --with-daemon_groupname=cron \
+ --with-crontabdir=/var/spool/cron/crontabs \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "install failed"
+
+ docrondir
+ fowners root:cron /usr/bin/crontab
+ fperms 2750 /usr/bin/crontab
+
+ insinto /etc
+ newins "${FILESDIR}/${P}-crontab" crontab
+ newins "${FILESDIR}/${P}-cron.deny" cron.deny
+
+ keepdir /etc/cron.d
+ newinitd "${FILESDIR}/${P}-initd" cronie
+ dodoc NEWS AUTHORS README
+}
+
+pkg_postinst() {
+ cron_pkg_postinst
+}
diff --git a/sys-process/cronie/files/cronie-1.2-cron.deny b/sys-process/cronie/files/cronie-1.2-cron.deny
new file mode 100644
index 000000000000..f909922dea25
--- /dev/null
+++ b/sys-process/cronie/files/cronie-1.2-cron.deny
@@ -0,0 +1,5 @@
+# $Id: cronie-1.2-cron.deny,v 1.1 2009/02/17 22:09:35 bangert Exp $
+# If for any reason you have users in the 'cron' group who should not
+# be allowed to run crontab, add them to this file (one username per
+# line)
+
diff --git a/sys-process/cronie/files/cronie-1.2-crontab b/sys-process/cronie/files/cronie-1.2-crontab
new file mode 100644
index 000000000000..8e18f4aed700
--- /dev/null
+++ b/sys-process/cronie/files/cronie-1.2-crontab
@@ -0,0 +1,18 @@
+# for vixie cron
+#
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/files/cronie-1.2-crontab,v 1.1 2009/02/17 22:09:35 bangert Exp $
+#
+#
+
+# Global variables
+SHELL=/bin/bash
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+MAILTO=root
+HOME=/
+
+# check scripts in cron.hourly, cron.daily, cron.weekly and cron.monthly
+0 * * * * root rm -f /var/spool/cron/lastrun/cron.hourly
+1 3 * * * root rm -f /var/spool/cron/lastrun/cron.daily
+15 4 * * 6 root rm -f /var/spool/cron/lastrun/cron.weekly
+30 5 1 * * root rm -f /var/spool/cron/lastrun/cron.monthly
+*/10 * * * * root test -x /usr/sbin/run-crons && /usr/sbin/run-crons
diff --git a/sys-process/cronie/files/cronie-1.2-initd b/sys-process/cronie/files/cronie-1.2-initd
new file mode 100755
index 000000000000..7590a7d85ffb
--- /dev/null
+++ b/sys-process/cronie/files/cronie-1.2-initd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/files/cronie-1.2-initd,v 1.1 2009/02/17 22:09:35 bangert Exp $
+
+depend() {
+ use clock logger
+ need localmount
+ provide cron
+}
+
+start() {
+ ebegin "Starting cronie"
+ start-stop-daemon --start --quiet --exec /usr/sbin/crond
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping cronie"
+ start-stop-daemon --stop --quiet --pidfile /var/run/crond.pid
+ eend $?
+}
diff --git a/sys-process/cronie/files/cronie-1.2-pathnames.h-fix-SPOOL_DIR.patch b/sys-process/cronie/files/cronie-1.2-pathnames.h-fix-SPOOL_DIR.patch
new file mode 100644
index 000000000000..9ea70c14f3b2
--- /dev/null
+++ b/sys-process/cronie/files/cronie-1.2-pathnames.h-fix-SPOOL_DIR.patch
@@ -0,0 +1,11 @@
+--- src/pathnames.h.orig 2009-02-17 22:43:14.000000000 +0100
++++ src/pathnames.h 2009-02-17 22:43:31.000000000 +0100
+@@ -46,7 +46,7 @@
+ * newer than they were last time around (or which
+ * didn't exist last time around...)
+ */
+-#define SPOOL_DIR "cron"
++#define SPOOL_DIR "cron/crontabs"
+
+ /* cron allow/deny file. At least cron.deny must
+ * exist for ordinary users to run crontab.
diff --git a/sys-process/cronie/metadata.xml b/sys-process/cronie/metadata.xml
new file mode 100644
index 000000000000..10169d7ce5a1
--- /dev/null
+++ b/sys-process/cronie/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cron</herd>
+<maintainer>
+ <email>bangert@gentoo.org</email>
+ <name>Thilo Bangert</name>
+</maintainer>
+ <longdescription lang="en">
+ Cronie contains the standard UNIX daemon crond that runs specified programs at
+ scheduled times and related tools. It is based on the original cron and
+ has security and configuration enhancements like the ability to use pam and
+ SELinux.
+ And why cronie? See http://www.urbandictionary.com/define.php?term=cronie
+ </longdescription>
+ <use>
+ <flag name='inotify'>Enable inotify filesystem monitoring support.</flag>
+ </use>
+</pkgmetadata>