summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-10-10 17:10:51 +0000
committerPacho Ramos <pacho@gentoo.org>2013-10-10 17:10:51 +0000
commit217c26fde467deaa516cd1379d2dde6c4ca7b309 (patch)
tree8affe870a361411884c254aadfdc3227f8cf29f0 /sys-process/incron
parentConvert to distutils-r1. Thanks for Dennis Lan for the initial patch, bug #48... (diff)
downloadgentoo-2-217c26fde467deaa516cd1379d2dde6c4ca7b309.tar.gz
gentoo-2-217c26fde467deaa516cd1379d2dde6c4ca7b309.tar.bz2
gentoo-2-217c26fde467deaa516cd1379d2dde6c4ca7b309.zip
Add unit file (#487498 by Rafal Rzepecki)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'sys-process/incron')
-rw-r--r--sys-process/incron/ChangeLog10
-rw-r--r--sys-process/incron/files/incrond.service9
-rw-r--r--sys-process/incron/incron-0.5.10-r1.ebuild40
3 files changed, 57 insertions, 2 deletions
diff --git a/sys-process/incron/ChangeLog b/sys-process/incron/ChangeLog
index d3d3286de39e..c59a4b819067 100644
--- a/sys-process/incron/ChangeLog
+++ b/sys-process/incron/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/incron
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/ChangeLog,v 1.23 2012/11/20 01:11:48 flameeyes Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/ChangeLog,v 1.24 2013/10/10 17:10:51 pacho Exp $
+
+*incron-0.5.10-r1 (10 Oct 2013)
+
+ 10 Oct 2013; Pacho Ramos <pacho@gentoo.org> +files/incrond.service,
+ +incron-0.5.10-r1.ebuild:
+ Add unit file (#487498 by Rafal Rzepecki)
20 Nov 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+files/incron-0.5.10+gcc-4.7.patch, incron-0.5.10.ebuild:
diff --git a/sys-process/incron/files/incrond.service b/sys-process/incron/files/incrond.service
new file mode 100644
index 000000000000..a3d2a9b0b3bb
--- /dev/null
+++ b/sys-process/incron/files/incrond.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Inotify System Scheduler
+
+[Service]
+ExecStart=/usr/sbin/incrond --foreground -f /etc/incron.conf
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/sys-process/incron/incron-0.5.10-r1.ebuild b/sys-process/incron/incron-0.5.10-r1.ebuild
new file mode 100644
index 000000000000..b41a493350f1
--- /dev/null
+++ b/sys-process/incron/incron-0.5.10-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/incron-0.5.10-r1.ebuild,v 1.1 2013/10/10 17:10:51 pacho Exp $
+
+EAPI="4"
+
+inherit eutils linux-info systemd toolchain-funcs
+
+DESCRIPTION="inotify based cron daemon"
+HOMEPAGE="http://incron.aiken.cz/"
+SRC_URI="http://inotify.aiken.cz/download/incron/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# < 2.6.18 => INOTIFY, >= 2.6.18 => INOTIFY_USER
+# It should be ok to expect at least 2.6.18
+CONFIG_CHECK="~INOTIFY_USER"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}+gcc-4.7.patch
+}
+
+src_compile() {
+ emake CXX=$(tc-getCXX)
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr DOCDIR=/usr/share/doc/${PF} install
+
+ newinitd "${FILESDIR}/incrond.init" incrond
+ systemd_dounit "${FILESDIR}/incrond.service"
+
+ dodoc CHANGELOG README TODO
+}