summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-16 02:30:36 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-16 02:30:36 +0000
commit93a0c5d5dcfb36a1fb96e9a0daa938216b9771f4 (patch)
tree74bbe5c94c70ad4ba2678b6cea7624213f05a47f /sys-process/runit
parentuse toolchain-funcs eclass not gcc (diff)
downloadgentoo-2-93a0c5d5dcfb36a1fb96e9a0daa938216b9771f4.tar.gz
gentoo-2-93a0c5d5dcfb36a1fb96e9a0daa938216b9771f4.tar.bz2
gentoo-2-93a0c5d5dcfb36a1fb96e9a0daa938216b9771f4.zip
dont use gcc eclass
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'sys-process/runit')
-rw-r--r--sys-process/runit/runit-1.0.5.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-process/runit/runit-1.0.5.ebuild b/sys-process/runit/runit-1.0.5.ebuild
index e02684da7cd7..00e9b6c642a3 100644
--- a/sys-process/runit/runit-1.0.5.ebuild
+++ b/sys-process/runit/runit-1.0.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/runit-1.0.5.ebuild,v 1.1 2005/03/03 16:08:25 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/runit-1.0.5.ebuild,v 1.2 2005/05/16 02:28:25 vapier Exp $
-inherit gcc flag-o-matic
+inherit toolchain-funcs flag-o-matic
DESCRIPTION="A UNIX init scheme with service supervision"
HOMEPAGE="http://smarden.org/runit/"
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="static"
-DEPEND="virtual/libc"
+DEPEND=""
S=${WORKDIR}/admin/${P}
@@ -25,8 +25,8 @@ src_unpack() {
sed -i -e 's:-static: :' src/Makefile
use static && append-ldflags -static
- echo "$(gcc-getCC) ${CFLAGS}" > src/conf-cc
- echo "$(gcc-getCC) ${LDFLAGS}" > src/conf-ld
+ echo "$(tc-getCC) ${CFLAGS}" > src/conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > src/conf-ld
}
src_compile() {