summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-29 17:38:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-29 17:38:40 +0000
commitde78e1392b46f5e5af939fecde21d6d26c70474b (patch)
tree3bfcbc60467d82548a613870dba6056850a94dff /sys-process
parentRecognize hardfp on arm, bug #429298 by Till Crueger. (diff)
downloadgentoo-2-de78e1392b46f5e5af939fecde21d6d26c70474b.tar.gz
gentoo-2-de78e1392b46f5e5af939fecde21d6d26c70474b.tar.bz2
gentoo-2-de78e1392b46f5e5af939fecde21d6d26c70474b.zip
Remove old. Add new ebuild that avoid spitting pages-long documentation and instead relies on users knowing what they are doing and use pkg_config to set up the package with its systab. Do not change files' permissions at postinst time as that's bad practice.
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/fcron/ChangeLog11
-rw-r--r--sys-process/fcron/fcron-3.0.5-r2.ebuild274
-rw-r--r--sys-process/fcron/fcron-3.0.6-r3.ebuild202
-rw-r--r--sys-process/fcron/files/fcron.init.358
-rw-r--r--sys-process/fcron/files/fcrontab.25
-rw-r--r--sys-process/fcron/metadata.xml15
6 files changed, 283 insertions, 282 deletions
diff --git a/sys-process/fcron/ChangeLog b/sys-process/fcron/ChangeLog
index 3e15e1d9cccd..fb973e7a1198 100644
--- a/sys-process/fcron/ChangeLog
+++ b/sys-process/fcron/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-process/fcron
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/ChangeLog,v 1.92 2012/05/24 05:51:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/ChangeLog,v 1.93 2012/08/29 17:38:40 flameeyes Exp $
+
+*fcron-3.0.6-r3 (29 Aug 2012)
+
+ 29 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> +fcron-3.0.6-r3.ebuild,
+ +files/fcron.init.3, +files/fcrontab.2, -fcron-3.0.5-r2.ebuild, metadata.xml:
+ Remove old. Add new ebuild that avoid spitting pages-long documentation and
+ instead relies on users knowing what they are doing and use pkg_config to set
+ up the package with its systab. Do not change files' permissions at postinst
+ time as that's bad practice.
24 May 2012; Mike Frysinger <vapier@gentoo.org> fcron-3.0.5-r2.ebuild,
fcron-3.0.6-r1.ebuild, fcron-3.0.6-r2.ebuild:
diff --git a/sys-process/fcron/fcron-3.0.5-r2.ebuild b/sys-process/fcron/fcron-3.0.5-r2.ebuild
deleted file mode 100644
index 0b63961bc24c..000000000000
--- a/sys-process/fcron/fcron-3.0.5-r2.ebuild
+++ /dev/null
@@ -1,274 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/fcron-3.0.5-r2.ebuild,v 1.10 2012/05/24 05:51:09 vapier Exp $
-
-inherit cron pam eutils flag-o-matic user
-
-MY_P=${P/_/-}
-DESCRIPTION="A command scheduler with extended capabilities over cron and anacron"
-HOMEPAGE="http://fcron.free.fr/"
-SRC_URI="http://fcron.free.fr/archives/${MY_P}.src.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~arm hppa ia64 ~mips ppc sparc x86 ~x86-fbsd"
-IUSE="debug pam selinux linguas_fr"
-
-DEPEND="selinux? ( sys-libs/libselinux )
- pam? ( virtual/pam )"
-
-# see bug 282214 for the reason to depend on bash
-RDEPEND="${DEPEND}
- app-shells/bash
- >=app-misc/editor-wrapper-3
- pam? ( >=sys-auth/pambase-20100310 )"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- enewgroup fcron
- enewuser fcron -1 -1 -1 fcron
- rootuser=$(egetent passwd 0 | cut -d ':' -f 1)
- rootgroup=$(egetent group 0 | cut -d ':' -f 1)
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # respect LDFLAGS
- sed -i "s:\(@LIBS@\):\$(LDFLAGS) \1:" Makefile.in || die "sed failed"
-
- # patch check_system_crontabs to support "-c /path/to/fcron.conf"
- epatch "${FILESDIR}"/check_system_crontabs.fcron-config-file.patch
-
- # bug #308799
- epatch "${FILESDIR}"/${P}-gentoo.patch
-
- # the script contains bashism, so until upstream fixes it we're
- # going to simply require bash for this to work, sorry!
- # see also bug #282214
- sed -i -e '1s:/bin/sh:/bin/bash:' script/check_system_crontabs \
- || die "Unable to fix check_system_crontabs shebang."
-}
-
-src_compile() {
- local myconf
-
- # Don't try to pass --with-debug as it'll play with cflags as
- # well, and run foreground which is a _very_ nasty idea for
- # Gentoo.
- use debug && append-flags -DDEBUG
-
- [[ -n "${rootuser}" ]] && myconf="${myconf} --with-rootname=${rootuser}"
- [[ -n "${rootgroup}" ]] && myconf="${myconf} --with-rootgroup=${rootgroup}"
-
- econf \
- --with-cflags="${CFLAGS}" \
- $(use_with pam) \
- $(use_with selinux) \
- --sysconfdir=/etc/fcron \
- --with-username=fcron \
- --with-groupname=fcron \
- --with-piddir=/var/run \
- --with-spooldir=/var/spool/fcron \
- --with-fifodir=/var/run \
- --with-fcrondyn=yes \
- --disable-checks \
- --with-editor=/usr/libexec/editor \
- --with-sendmail=/usr/sbin/sendmail \
- --with-shell=/bin/sh \
- --without-db2man --without-dsssl-dir \
- ${myconf} \
- || die "configure failed"
-
- emake || die "make failed"
-
- # bug #216460
- sed -i \
- -e 's:/usr/local/etc/fcron:/etc/fcron/fcron:g' \
- -e 's:/usr/local/etc:/etc:g' \
- -e 's:/usr/local/:/usr/:g' \
- doc/*/*/*.{txt,1,5,8,html} \
- || die "unable to fix documentation references"
-}
-
-src_install() {
- # create directories that don't have special permissions first so
- # that we can play with the permissions later
- dodir /usr/bin /etc /var/spool
-
- diropts -m6770 -o fcron -g fcron
- keepdir /var/spool/fcron
-
- # install fcron tools
- insinto /usr/bin
- dosbin fcron || die
-
- # fcronsighup needs to be suid root, because it sends a HUP
- # to the running fcron daemon
- insopts -m6755 -o ${rootuser:-root} -g fcron
- doins fcronsighup || die
- insopts -m6755 -o fcron -g fcron
- doins fcrondyn fcrontab || die
-
- # /etc stuff
- diropts -m0750 -o ${rootuser:-root} -g fcron
- dodir /etc/fcron
- insinto /etc/fcron
- insopts -m0640 -o ${rootuser:-root} -g fcron
- doins files/fcron.{allow,deny,conf} || die
-
- diropts -m0755
- insopts -m0644
-
- # install /etc/crontab and /etc/fcrontab
- insopts -m0640 -o ${rootuser:-root} -g ${rootgroup:-root}
- doins "${FILESDIR}"/crontab "${FILESDIR}"/fcrontab || die
-
- # install PAM files
- pamd_mimic system-services fcron auth account session
- cat - > "${T}"/fcrontab.pam <<EOF
-# Don't ask for the user's password; fcrontab will only allow to
-# change user if running as root.
-auth sufficient pam_permit.so
-
-# Still use the system-auth stack for account and session as the
-# sysadmin might have set up stuff properly, and also avoids
-# sidestepping limits (since fcrontab will run $EDITOR).
-account include system-auth
-session include system-auth
-EOF
- newpamd "${T}"/fcrontab.pam fcrontab
-
- # install init script
- newinitd "${FILESDIR}"/fcron.init.2 fcron || die
-
- # install the very handy check_system_crontabs script
- dosbin script/check_system_crontabs || die
-
- # doc stuff
- dodoc MANIFEST VERSION "${FILESDIR}"/crontab \
- doc/en/txt/{readme,thanks,faq,todo,relnotes,changes}.txt \
- || die
- newdoc files/fcron.conf fcron.conf.sample || die
- dohtml doc/en/HTML/*.html || die
- doman doc/en/man/*.{1,5,8} || die
-
- # localized docs
- for lang in fr; do
- use linguas_${lang} || continue
-
- doman -i18n=${lang} doc/${lang}/man/*.{1,5,8} || die
- docinto html/${lang}
- dohtml doc/${lang}/HTML/*.html || die
- done
-}
-
-pkg_postinst() {
- elog
- elog "fcron has some important differences compared to vixie-cron:"
- elog
- elog "1. fcron stores the crontabs in ${ROOT}var/spool/fcron"
- elog " instead of ${ROOT}var/spool/cron/crontabs"
- elog
- elog "2. fcron uses a special binary file format for storing the"
- elog " crontabs in ${ROOT}var/spool/fcron/USERNAME,"
- elog " but the original plain text version is saved as"
- elog " ${ROOT}var/spool/fcron/USERNAME.orig for your"
- elog " reference (and for being edited with fcrontab)."
- elog
- elog "3. fcron does not feature a system crontab in exactly the"
- elog " same way as vixie-cron does. This version of fcron"
- elog " features a crontab for a pseudo-user 'systab' for use"
- elog " as the system crontab. Running a command like"
- elog
- elog " fcrontab -u systab ${ROOT}etc/crontab"
- elog
- elog " will write ${ROOT}etc/crontab to the fcron crontabs directory as"
- elog
- elog " ${ROOT}var/spool/fcron/systab"
- elog
- elog " Please note that changes to ${ROOT}etc/crontab will not become"
- elog " active automatically! fcron also does not use the directory"
- elog " ${ROOT}etc/cron.d by default like vixie-cron does."
- elog " Fortunately, it's possible to emulate vixie-cron's behavior"
- elog " with regards to ${ROOT}etc/crontab and ${ROOT}etc/cron.d by using a"
- elog " little helper script called 'check_system_crontabs'."
- elog " The file ${ROOT}etc/fcrontab (not ${ROOT}etc/crontab!) has been set up"
- elog " to run the script once a while to check whether"
- elog " ${ROOT}etc/fcrontab, ${ROOT}etc/crontab or files in ${ROOT}etc/cron.d/ have"
- elog " changed since the last generation of the systab and"
- elog " regenerate it from those three locations as necessary."
- elog " You should now run 'check_system_crontabs' once to properly"
- elog " generate an initial systab:"
- elog
- elog " check_system_crontabs -v -i -f"
- elog
- elog " The file ${ROOT}etc/fcrontab should only be used to run that"
- elog " script in order to ensure independence from the standard"
- elog " system crontab file ${ROOT}etc/crontab."
- elog " You may of course adjust the schedule for the script"
- elog " 'check_system_crontabs' or any other setting in"
- elog " ${ROOT}etc/fcrontab as you desire."
- elog
- elog "If you do NOT want to use 'check_system_crontabs', you"
- elog "might still want to activate the use of the well known"
- elog "directories ${ROOT}etc/cron.{hourly|daily|weekly|monthly} by"
- elog "just generating a systab once from ${ROOT}etc/crontab:"
- elog
- elog " fcrontab -u systab ${ROOT}etc/crontab"
- elog
- elog "Happy fcron'ing!"
- elog
-
- ewarn
- ewarn "Fixing permissions and ownership of ${ROOT}usr/bin/fcron{tab,dyn,sighup}"
- chown fcron:fcron "${ROOT}"usr/bin/fcron{tab,dyn} >&/dev/null
- chown ${rootuser:-root}:fcron "${ROOT}"usr/bin/fcronsighup >&/dev/null
- chmod 6755 "${ROOT}"usr/bin/fcron{tab,dyn,sighup} >&/dev/null
- ewarn "Fixing permissions and ownership of ${ROOT}etc/{fcron,fcrontab,crontab}"
- chown -R ${rootuser:-root}:fcron "${ROOT}"etc/{fcron,fcrontab,crontab} >&/dev/null
- chmod -R g+rX,o= "${ROOT}"etc/fcron "${ROOT}"etc/{fcron,fcrontab,crontab} >&/dev/null
- ewarn
-
- ewarn
- ewarn "WARNING: fcron now uses a dedicated user and group"
- ewarn "'fcron' for the suid/sgid programs/files instead of"
- ewarn "the user and group 'cron' that were previously used."
- ewarn
- ewarn "fcron usage can now only be restricted by adding users"
- ewarn "to the following files instead of to the group 'cron':"
- ewarn
- ewarn " ${ROOT}etc/fcron/fcron.allow"
- ewarn " ${ROOT}etc/fcron/fcron.deny"
- ewarn
-
- if ls -1 "${ROOT}"var/spool/cron/fcrontabs/* >&/dev/null; then
- ewarn
- ewarn "WARNING: fcron now uses a dedicated fcron-specific"
- ewarn "spooldir ${ROOT}var/spool/fcron instead of the commonly"
- ewarn "used ${ROOT}var/spool/cron for several reasons."
- ewarn
- ewarn "Copying over existing crontabs from ${ROOT}var/spool/cron/fcrontabs"
- cp "${ROOT}"var/spool/cron/fcrontabs/* "${ROOT}"var/spool/fcron/ >&/dev/null \
- || die "failed to migrate existing crontabs"
- ewarn "You should now remove ${ROOT}var/spool/cron/fcrontabs!"
- ewarn
- ewarn "Fixing permissions and ownership of ${ROOT}var/spool/fcron"
- chown root:root "${ROOT}"var/spool/fcron/* >&/dev/null
- chmod 0600 "${ROOT}"var/spool/fcron/* >&/dev/null
- chown fcron:fcron "${ROOT}"var/spool/fcron/*.orig >&/dev/null
- chmod 0640 "${ROOT}"var/spool/fcron/*.orig >&/dev/null
- ewarn
- ewarn "*** YOU SHOULD IMMEDIATELY UPDATE THE"
- ewarn "*** fcrontabs ENTRY IN ${ROOT}etc/fcron/fcron.conf"
- ewarn "*** AND RESTART YOUR FCRON DAEMON!"
- fi
-
- elog ""
- elog "Since version 3.0.5 the fcron init script will no longer wait for LDAP, MySQL"
- elog "or PostgreSQL before starting. If you need any of these for authentication or"
- elog "for jobs that are executed by fcron, please create a /etc/conf.d/fcron file to"
- elog "set the rc_need variable to the list of services you should be waiting for."
- elog ""
-}
diff --git a/sys-process/fcron/fcron-3.0.6-r3.ebuild b/sys-process/fcron/fcron-3.0.6-r3.ebuild
new file mode 100644
index 000000000000..ee704b59b1fb
--- /dev/null
+++ b/sys-process/fcron/fcron-3.0.6-r3.ebuild
@@ -0,0 +1,202 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/fcron-3.0.6-r3.ebuild,v 1.1 2012/08/29 17:38:40 flameeyes Exp $
+
+EAPI=4
+
+inherit cron pam eutils flag-o-matic user
+
+MY_P=${P/_/-}
+DESCRIPTION="A command scheduler with extended capabilities over cron and anacron"
+HOMEPAGE="http://fcron.free.fr/"
+SRC_URI="http://fcron.free.fr/archives/${MY_P}.src.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="debug pam selinux linguas_fr +system-crontab"
+
+DEPEND="selinux? ( sys-libs/libselinux )
+ pam? ( virtual/pam )"
+
+# see bug 282214 for the reason to depend on bash
+RDEPEND="${DEPEND}
+ app-shells/bash
+ >=app-misc/editor-wrapper-3
+ pam? ( >=sys-auth/pambase-20100310 )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup fcron
+ enewuser fcron -1 -1 -1 fcron
+ rootuser=$(egetent passwd 0 | cut -d ':' -f 1)
+ [[ ${rootuser} ]] || rootuser=root
+ rootgroup=$(egetent group 0 | cut -d ':' -f 1)
+ [[ ${rootgroup} ]] || rootgroup=root
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # respect LDFLAGS
+ sed -i "s:\(@LIBS@\):\$(LDFLAGS) \1:" Makefile.in || die "sed failed"
+
+ sed -i -e 's:/etc/fcrontab:/etc/fcron/fcrontab:' script/check_system_crontabs.sh || die
+}
+
+src_configure() {
+ local myconf
+
+ # Don't try to pass --with-debug as it'll play with cflags as
+ # well, and run foreground which is a _very_ nasty idea for
+ # Gentoo.
+ use debug && append-flags -DDEBUG
+
+ # bindir is used just for calling fcronsighup
+ econf \
+ --with-cflags="${CFLAGS}" \
+ --bindir=/usr/libexec \
+ $(use_with pam) \
+ $(use_with selinux) \
+ --sysconfdir=/etc/fcron \
+ --with-username=fcron \
+ --with-groupname=fcron \
+ --with-piddir=/var/run \
+ --with-spooldir=/var/spool/fcron \
+ --with-fifodir=/var/run \
+ --with-fcrondyn=yes \
+ --disable-checks \
+ --with-editor=/usr/libexec/editor \
+ --with-sendmail=/usr/sbin/sendmail \
+ --with-shell=/bin/sh \
+ --without-db2man --without-dsssl-dir \
+ --with-rootname=${rootuser} \
+ --with-rootgroup=${rootgroup}
+}
+
+src_compile() {
+ emake || die "make failed"
+
+ # bug #216460
+ sed -i \
+ -e 's:/usr/local/etc/fcron:/etc/fcron/fcron:g' \
+ -e 's:/usr/local/etc:/etc:g' \
+ -e 's:/usr/local/:/usr/:g' \
+ doc/*/*/*.{txt,1,5,8,html} \
+ || die "unable to fix documentation references"
+}
+
+src_install() {
+ keepdir /var/spool/fcron
+
+ exeinto /usr/libexec
+ doexe fcron fcronsighup
+
+ dobin fcrondyn fcrontab
+
+ insinto /etc/fcron
+ doins files/fcron.{allow,deny,conf}
+
+ if use system-crontab; then
+ dosym /usr/bin/fcrontab crontab
+
+ exeinto /usr/libexec
+ newexe script/check_system_crontabs.sh check_system_crontabs
+
+ insinto /etc/fcron
+ newins "${FILESDIR}"/fcrontab.2 fcrontab
+
+ fowners ${rootuser}:fcron /etc/fcron/fcrontab
+ fperms 0640 /etc/fcron/fcrontab
+
+ insinto /etc
+ doins "${FILESDIR}"/crontab
+ fi
+
+ fowners fcron:fcron \
+ /var/spool/fcron \
+ /usr/bin/fcron{dyn,tab}
+
+ # fcronsighup needs to be suid root, because it sends a HUP to the
+ # running fcron daemon, but only has to be called by the fcron group
+ # anyway
+ fowners ${rootuser}:fcron \
+ /usr/libexec/fcronsighup \
+ /etc/fcron \
+ /etc/fcron/fcron.{allow,deny,conf} \
+
+ fperms 6770 /var/spool/fcron
+ fperms 2775 /usr/bin/fcron{dyn,tab}
+
+ fperms 4710 /usr/libexec/fcronsighup
+
+ fperms 0750 /etc/fcron
+ fperms 0640 /etc/fcron/fcron.{allow,deny,conf}
+
+ pamd_mimic system-services fcron auth account session
+ cat - > "${T}"/fcrontab.pam <<EOF
+# Don't ask for the user's password; fcrontab will only allow to
+# change user if running as root.
+auth sufficient pam_permit.so
+
+# Still use the system-auth stack for account and session as the
+# sysadmin might have set up stuff properly, and also avoids
+# sidestepping limits (since fcrontab will run $EDITOR).
+account include system-auth
+session include system-auth
+EOF
+ newpamd "${T}"/fcrontab.pam fcrontab
+
+ newinitd "${FILESDIR}"/fcron.init.3 fcron
+
+ dodoc MANIFEST VERSION "${FILESDIR}"/crontab \
+ doc/en/txt/{readme,thanks,faq,todo,relnotes,changes}.txt
+ newdoc files/fcron.conf fcron.conf.sample
+ dohtml doc/en/HTML/*.html
+ doman doc/en/man/*.{1,5,8}
+
+ for lang in fr; do
+ use linguas_${lang} || continue
+
+ doman -i18n=${lang} doc/${lang}/man/*.{1,5,8} || die
+ docinto html/${lang}
+ dohtml doc/${lang}/HTML/*.html || die
+ done
+}
+
+pkg_postinst() {
+ elog "If it's the first time you install fcron make sure to execute"
+ elog " emerge --config ${CATEGORY}/${PN}"
+ elog "to configure the proper settings."
+ if ! use system-crontab; then
+ ewarn ""
+ ewarn "Remember that fcron will *not* use /etc/cron.d in this configuration"
+ ewarn ""
+ fi
+}
+
+pkg_config() {
+ if [[ $(fcrontab -l -u systab 2>/dev/null) ]]; then
+ eerror "We're not going to make any change to your systab as long as"
+ eerror "it contains data; please clear it before proceeding."
+ return 1
+ fi
+
+ if use system-crontab; then
+ elog "This is going to set up fcron to execute check_system_crontabs."
+ elog "In this configuration, you're no longer free to edit the systab"
+ elog "at your leisure, at it'll be rewritten the moment the crontabs"
+ elog "are modified."
+ /usr/libexec/check_system_crontabs -v -i -f
+ else
+ elog "This is going to set up fcron to set up a default systab that"
+ elog "executes /etc/cron.{hourly,daily,weekly,monthly}."
+ fcrontab -u systab - <<EOF
+0 * * * * rm -f /var/spool/cron/lastrun/cron.hourly
+1 3 * * * rm -f /var/spool/cron/lastrun/cron.daily
+15 4 * * 6 rm -f /var/spool/cron/lastrun/cron.weekly
+30 5 1 * * rm -f /var/spool/cron/lastrun/cron.monthly
+EOF
+ fi
+}
diff --git a/sys-process/fcron/files/fcron.init.3 b/sys-process/fcron/files/fcron.init.3
new file mode 100644
index 000000000000..09c05c6d0361
--- /dev/null
+++ b/sys-process/fcron/files/fcron.init.3
@@ -0,0 +1,58 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/files/fcron.init.3,v 1.1 2012/08/29 17:38:40 flameeyes Exp $
+
+FCRON_INSTANCE=${SVCNAME##*.}
+
+configfile() {
+ if [ -n "${FCRON_INSTANCE}" -a "${SVCNAME}" != "fcron" ]; then
+ echo /etc/fcron/fcron.${FCRON_INSTANCE}.conf
+ else
+ echo /etc/fcron/fcron.conf
+ fi
+}
+
+getconfig() {
+ # if there is no configuration file return the default value
+ if ! [ -f $(configfile) ]; then
+ echo $2
+ return 0
+ fi
+
+ sed -n -e 's:^$1[ \t]*=[ \t]*::p' $(configfile)
+}
+
+depend() {
+ config $(configfile)
+
+ use logger
+ need clock hostname
+ # provide the cron service if we are the main instance
+ [ "${SVCNAME}" = "fcron" ] && provide cron
+}
+
+command="/usr/libexec/fcron"
+command_args="-c $(configfile)"
+pidfile=$(getconfig pidfile /var/run/fcron.pid)
+fcrontabs=$(getconfig fcrontabs /var/spool/fcron)
+
+extra_started_commands="reload"
+
+start_pre() {
+ if [ ! -e $(configfile) ]; then
+ eerror "You will need to create $(configfile) first"
+ eerror "There is a sample in /etc/fcron"
+ return 1
+ fi
+
+ if [ ! -d ${fcrontabs} ]; then
+ ebegin "Creating missing spooldir ${fcrontabs}"
+ ${command} --newspooldir ${fcrontabs}
+ eend $?
+ fi
+}
+
+reload() {
+ kill -HUP `cat ${pidfile}`
+}
diff --git a/sys-process/fcron/files/fcrontab.2 b/sys-process/fcron/files/fcrontab.2
new file mode 100644
index 000000000000..0649397cf944
--- /dev/null
+++ b/sys-process/fcron/files/fcrontab.2
@@ -0,0 +1,5 @@
+# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/files/fcrontab.2,v 1.1 2012/08/29 17:38:40 flameeyes Exp $
+# Script for checking system crontabs and creating the fcron systab.
+# Runs every 10 minutes, does not mail output, doesn't log job runs
+# except for errors.
+@mail(false),nolog(true) 10 /usr/libexec/check_system_crontabs -s 0
diff --git a/sys-process/fcron/metadata.xml b/sys-process/fcron/metadata.xml
index 349c0bc3d6f6..54be2f8daf41 100644
--- a/sys-process/fcron/metadata.xml
+++ b/sys-process/fcron/metadata.xml
@@ -11,13 +11,7 @@
<email>flameeyes@gentoo.org</email>
</maintainer>
<use>
- <flag name="debug" restrict="&lt;sys-process/fcron-3.0.5">
- Enable debug code, output and allocation checks. Warning: in
- ebuilds before 3.0.5, enabling this flag will prevent fcron from
- running as a proper service.
- </flag>
-
- <flag name="debug" restrict="&gt;=sys-process/fcron-3.0.5">
+ <flag name="debug">
Enable debug code and output. Since version 3.0.5 this will no
longer force foreground execution, and fcron will be able to run
as a service properly.
@@ -29,5 +23,12 @@
fcrontab will use the "fcrontab" stack to authenticate the user
before editing its crontab file.
</flag>
+
+ <flag name="system-crontab">
+ Set up fcron to respect /etc/crontab and /etc/cron.d. If this
+ flag is disabled, /etc/cron.d and /etc/crontab will be ignored,
+ but /etc/cron.{hourly,daily,weekly,monthly} will still be
+ respected.
+ </flag>
</use>
</pkgmetadata>