summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-11-19 18:35:28 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-11-19 18:35:28 +0000
commit75f40ed9c952e52b312ac83edcc1216af49e11b1 (patch)
tree926941663b3dfdfc7f09069a98256fa5e9ebc9a7 /virtual/perl-DB_File
parentVersion bump. (diff)
downloadgentoo-2-75f40ed9c952e52b312ac83edcc1216af49e11b1.tar.gz
gentoo-2-75f40ed9c952e52b312ac83edcc1216af49e11b1.tar.bz2
gentoo-2-75f40ed9c952e52b312ac83edcc1216af49e11b1.zip
Updating virtual to catch perls built without berkdb
(Portage version: 2.1.2_rc1-r7)
Diffstat (limited to 'virtual/perl-DB_File')
-rw-r--r--virtual/perl-DB_File/ChangeLog6
-rw-r--r--virtual/perl-DB_File/perl-DB_File-1.814.ebuild12
2 files changed, 15 insertions, 3 deletions
diff --git a/virtual/perl-DB_File/ChangeLog b/virtual/perl-DB_File/ChangeLog
index e41e2a9a061d..aceacdc50824 100644
--- a/virtual/perl-DB_File/ChangeLog
+++ b/virtual/perl-DB_File/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for virtual/perl-DB_File
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/perl-DB_File/ChangeLog,v 1.7 2006/10/25 01:56:04 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/perl-DB_File/ChangeLog,v 1.8 2006/11/19 18:35:28 mcummings Exp $
+
+ 19 Nov 2006; Michael Cummings <mcummings@gentoo.org>
+ perl-DB_File-1.814.ebuild:
+ Updating virtual to catch perls built without berkdb
25 Oct 2006; Michael Cummings <mcummings@gentoo.org>
-perl-DB_File-1.811.ebuild, perl-DB_File-1.813.ebuild:
diff --git a/virtual/perl-DB_File/perl-DB_File-1.814.ebuild b/virtual/perl-DB_File/perl-DB_File-1.814.ebuild
index 036209e2d7f7..e177f82286c5 100644
--- a/virtual/perl-DB_File/perl-DB_File-1.814.ebuild
+++ b/virtual/perl-DB_File/perl-DB_File-1.814.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/perl-DB_File/perl-DB_File-1.814.ebuild,v 1.5 2006/02/26 06:26:24 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/perl-DB_File/perl-DB_File-1.814.ebuild,v 1.6 2006/11/19 18:35:28 mcummings Exp $
+
+inherit eutils
DESCRIPTION="Virtual for DB_File"
HOMEPAGE="http://www.gentoo.org/proj/en/perl/"
@@ -10,7 +12,13 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE=""
+IUSE="berkdb"
DEPEND=""
RDEPEND="|| ( ~dev-lang/perl-5.8.8 ~perl-core/DB_File-${PV} )"
+src_unpack() {
+ if ! has_version '~perl-core/DB_File-${PV}' && ! built_with_use dev-lang/perl berkdb ; then
+ die "You must build perl with USE=\"berkdb\" or install perl-core/DB_File-${PV}"
+ fi
+}
+