summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-12-26 09:29:00 +0000
committerHans de Graaff <graaff@gentoo.org>2013-12-26 09:29:00 +0000
commit9c8730fcd1e077eaac01600ace0c78c034465d84 (patch)
tree9a0aebbb06f42f1fd1d8fdb50d2527d441196849 /virtual/ruby-ssl
parentAdd ruby21. (diff)
downloadgentoo-2-9c8730fcd1e077eaac01600ace0c78c034465d84.tar.gz
gentoo-2-9c8730fcd1e077eaac01600ace0c78c034465d84.tar.bz2
gentoo-2-9c8730fcd1e077eaac01600ace0c78c034465d84.zip
Add ruby21.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'virtual/ruby-ssl')
-rw-r--r--virtual/ruby-ssl/ChangeLog7
-rw-r--r--virtual/ruby-ssl/ruby-ssl-4.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/virtual/ruby-ssl/ChangeLog b/virtual/ruby-ssl/ChangeLog
index 3e1361e529ec..c02652b838d3 100644
--- a/virtual/ruby-ssl/ChangeLog
+++ b/virtual/ruby-ssl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for virtual/ruby-ssl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-ssl/ChangeLog,v 1.24 2013/12/24 16:56:44 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-ssl/ChangeLog,v 1.25 2013/12/26 09:29:00 graaff Exp $
+
+*ruby-ssl-4 (26 Dec 2013)
+
+ 26 Dec 2013; Hans de Graaff <graaff@gentoo.org> +ruby-ssl-4.ebuild:
+ Add ruby21.
24 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-ssl-3.ebuild:
Stable for ppc64, wrt bug #487004
diff --git a/virtual/ruby-ssl/ruby-ssl-4.ebuild b/virtual/ruby-ssl/ruby-ssl-4.ebuild
new file mode 100644
index 000000000000..fa46ea6d96c1
--- /dev/null
+++ b/virtual/ruby-ssl/ruby-ssl-4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-ssl/ruby-ssl-4.ebuild,v 1.1 2013/12/26 09:29:00 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby21"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for the Ruby OpenSSL bindings"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-lang/ruby:2.1[ssl]"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.