summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2006-12-01 16:03:11 +0000
committerTony Vroon <chainsaw@gentoo.org>2006-12-01 16:03:11 +0000
commit4b0dfb302eaf81315dd3d9aa807ff6621e063a89 (patch)
treedb9b68b6427a74137b18ddd1ecb39c0b041288ee /virtual
parentversion bump (diff)
downloadgentoo-2-4b0dfb302eaf81315dd3d9aa807ff6621e063a89.tar.gz
gentoo-2-4b0dfb302eaf81315dd3d9aa807ff6621e063a89.tar.bz2
gentoo-2-4b0dfb302eaf81315dd3d9aa807ff6621e063a89.zip
Use double quotes in the test, it fails otherwise. As suggested by Jakub Muc <jacub@gentoo.org>.
(Portage version: 2.1.2_rc2-r3)
Diffstat (limited to 'virtual')
-rw-r--r--virtual/perl-DB_File/ChangeLog6
-rw-r--r--virtual/perl-DB_File/perl-DB_File-1.814.ebuild4
2 files changed, 7 insertions, 3 deletions
diff --git a/virtual/perl-DB_File/ChangeLog b/virtual/perl-DB_File/ChangeLog
index 22bef790c32e..694135658a66 100644
--- a/virtual/perl-DB_File/ChangeLog
+++ b/virtual/perl-DB_File/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for virtual/perl-DB_File
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/perl-DB_File/ChangeLog,v 1.9 2006/11/20 03:25:36 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/perl-DB_File/ChangeLog,v 1.10 2006/12/01 16:03:11 chainsaw Exp $
+
+ 01 Dec 2006; Tony Vroon <chainsaw@gentoo.org> perl-DB_File-1.814.ebuild:
+ Use double quotes in the test, it fails otherwise. As suggested by Jakub Muc
+ <jakub@gentoo.org>.
20 Nov 2006; Sven Wegener <swegener@gentoo.org> perl-DB_File-1.814.ebuild:
Drop berkdb from IUSE, this package doesn't use it. Move checking from
diff --git a/virtual/perl-DB_File/perl-DB_File-1.814.ebuild b/virtual/perl-DB_File/perl-DB_File-1.814.ebuild
index cf20b53b9c56..edc336782c11 100644
--- a/virtual/perl-DB_File/perl-DB_File-1.814.ebuild
+++ b/virtual/perl-DB_File/perl-DB_File-1.814.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/perl-DB_File/perl-DB_File-1.814.ebuild,v 1.7 2006/11/20 03:25:36 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/perl-DB_File/perl-DB_File-1.814.ebuild,v 1.8 2006/12/01 16:03:11 chainsaw Exp $
inherit eutils
@@ -17,7 +17,7 @@ DEPEND=""
RDEPEND="|| ( ~dev-lang/perl-5.8.8 ~perl-core/DB_File-${PV} )"
pkg_setup() {
- if ! has_version '~perl-core/DB_File-${PV}' && ! built_with_use dev-lang/perl berkdb ; then
+ if ! has_version "~perl-core/DB_File-${PV}" && ! built_with_use dev-lang/perl berkdb ; then
die "You must build perl with USE=\"berkdb\" or install perl-core/DB_File-${PV}"
fi
}