summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-07 08:12:49 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-07 08:12:49 +0000
commit9ae08d6cc8b75e21b31ad323ce0c3cc1e9b056ea (patch)
treee59ec7025f707551246ea47a7252e3e564953584 /virtual
parentAdd ruby20 support. (diff)
downloadgentoo-2-9ae08d6cc8b75e21b31ad323ce0c3cc1e9b056ea.tar.gz
gentoo-2-9ae08d6cc8b75e21b31ad323ce0c3cc1e9b056ea.tar.bz2
gentoo-2-9ae08d6cc8b75e21b31ad323ce0c3cc1e9b056ea.zip
Add ruby20 support.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'virtual')
-rw-r--r--virtual/ruby-rdoc/ChangeLog8
-rw-r--r--virtual/ruby-rdoc/ruby-rdoc-3.ebuild45
2 files changed, 51 insertions, 2 deletions
diff --git a/virtual/ruby-rdoc/ChangeLog b/virtual/ruby-rdoc/ChangeLog
index 3f1fe08524bd..161f9d26a4b1 100644
--- a/virtual/ruby-rdoc/ChangeLog
+++ b/virtual/ruby-rdoc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for virtual/ruby-rdoc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-rdoc/ChangeLog,v 1.17 2013/01/28 15:15:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-rdoc/ChangeLog,v 1.18 2013/07/07 08:12:49 graaff Exp $
+
+*ruby-rdoc-3 (07 Jul 2013)
+
+ 07 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-rdoc-3.ebuild:
+ Add ruby20 support.
28 Jan 2013; Alexis Ballier <aballier@gentoo.org> ruby-rdoc-0.ebuild,
ruby-rdoc-1.ebuild:
@@ -62,4 +67,3 @@
+ruby-rdoc-1.ebuild, +ruby-rdoc-2.ebuild, +ruby-rdoc-3.ebuild,
+metadata.xml:
Import the rdoc virtual for Ruby.
-
diff --git a/virtual/ruby-rdoc/ruby-rdoc-3.ebuild b/virtual/ruby-rdoc/ruby-rdoc-3.ebuild
new file mode 100644
index 000000000000..d184a1220d25
--- /dev/null
+++ b/virtual/ruby-rdoc/ruby-rdoc-3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-rdoc/ruby-rdoc-3.ebuild,v 1.4 2013/07/07 08:12:49 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby20"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for bundled and unbundled RDoc"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="|| ( dev-ruby/rdoc[ruby_targets_ruby20] )"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.