summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-08-15 17:22:51 +0000
committerStuart Herbert <stuart@gentoo.org>2004-08-15 17:22:51 +0000
commit38e24230bd280fd0f893e2ea55fe19b185bcc872 (patch)
treed88e0d29c16cbc2627718017ef2592e45d598f2d /www-apache/mod_tcl/mod_tcl-1.0.ebuild
parentFixed deps (Manifest recommit) (diff)
downloadgentoo-2-38e24230bd280fd0f893e2ea55fe19b185bcc872.tar.gz
gentoo-2-38e24230bd280fd0f893e2ea55fe19b185bcc872.tar.bz2
gentoo-2-38e24230bd280fd0f893e2ea55fe19b185bcc872.zip
Moved from net-www/mod_tcl to www-apache/mod_tcl.
Diffstat (limited to 'www-apache/mod_tcl/mod_tcl-1.0.ebuild')
-rw-r--r--www-apache/mod_tcl/mod_tcl-1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/www-apache/mod_tcl/mod_tcl-1.0.ebuild b/www-apache/mod_tcl/mod_tcl-1.0.ebuild
new file mode 100644
index 000000000000..6525a2d9c325
--- /dev/null
+++ b/www-apache/mod_tcl/mod_tcl-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_tcl/mod_tcl-1.0.ebuild,v 1.1 2004/08/15 17:22:51 stuart Exp $
+
+inherit eutils
+
+DESCRIPTION="An Apache2 DSO providing an embedded Tcl interpreter"
+HOMEPAGE="http://tcl.apache.org/mod_tcl/"
+
+S=${WORKDIR}/${P}
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+DEPEND="dev-lang/tcl =net-www/apache-2*"
+LICENSE="Apache-1.1"
+KEYWORDS="x86"
+IUSE=""
+SLOT="0"
+
+src_compile() {
+ mv tcl_core.c ${PN}.c
+ apxs2 -c -Wl,-ltcl -DHAVE_TCL_H ${PN}.c tcl_cmds.c tcl_misc.c || die
+}
+
+src_install() {
+ exeinto /usr/lib/apache2-extramodules
+ doexe .libs/${PN}.so
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/27_mod_tcl.conf
+ dodoc ${FILESDIR}/27_mod_tcl.conf
+ dodoc AUTHORS INSTALL NEWS README test_script.tm
+}