summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-17 16:24:28 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-17 16:24:28 +0000
commit18e83ac371e7f639dcb48f9348f09be0217ee7ca (patch)
tree5b37b9cb9cc78454aed4007d77b2ab7987b00819 /www-apache
parentalpha/ia64/sparc stable wrt #397617 (diff)
downloadgentoo-2-18e83ac371e7f639dcb48f9348f09be0217ee7ca.tar.gz
gentoo-2-18e83ac371e7f639dcb48f9348f09be0217ee7ca.tar.bz2
gentoo-2-18e83ac371e7f639dcb48f9348f09be0217ee7ca.zip
Bump EAPI and use USE deps instead of confutils eclass.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_whatkilledus/ChangeLog10
-rw-r--r--www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1-r1.ebuild (renamed from www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild)14
2 files changed, 16 insertions, 8 deletions
diff --git a/www-apache/mod_whatkilledus/ChangeLog b/www-apache/mod_whatkilledus/ChangeLog
index e897b5551e0a..a9abcd75b5b3 100644
--- a/www-apache/mod_whatkilledus/ChangeLog
+++ b/www-apache/mod_whatkilledus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_whatkilledus
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_whatkilledus/ChangeLog,v 1.4 2008/03/23 11:59:37 hollow Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_whatkilledus/ChangeLog,v 1.5 2012/06/17 16:24:28 flameeyes Exp $
+
+*mod_whatkilledus-0.0.1-r1 (17 Jun 2012)
+
+ 17 Jun 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +mod_whatkilledus-0.0.1-r1.ebuild, -mod_whatkilledus-0.0.1.ebuild:
+ Bump EAPI and use USE deps instead of confutils eclass.
23 Mar 2008; Benedikt Böhm <hollow@gentoo.org>
mod_whatkilledus-0.0.1.ebuild:
diff --git a/www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild b/www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1-r1.ebuild
index d8e9347f9354..d4f53c6cbac8 100644
--- a/www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild
+++ b/www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild,v 1.3 2008/03/23 11:59:37 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1-r1.ebuild,v 1.1 2012/06/17 16:24:28 flameeyes Exp $
-inherit apache-module eutils toolchain-funcs confutils
+EAPI=4
+
+inherit apache-module eutils toolchain-funcs
KEYWORDS="~amd64 ~x86"
@@ -21,9 +23,8 @@ APACHE2_MOD_DEFINE="WHATKILLEDUS"
need_apache2_2
-pkg_setup() {
- confutils_require_built_with_all www-servers/apache debug
-}
+RDEPEND+="
+ www-servers/apache:2[debug]"
src_unpack() {
mkdir -p "${S}" || die "mkdir S failed"
@@ -34,6 +35,7 @@ src_compile() {
$(tc-getCC) \
$(/usr/bin/apr-1-config --includes) \
$(/usr/bin/apr-1-config --cppflags) \
+ ${CFLAGS} ${LDFLAGS} \
-o "${S}"/gen_test_char \
"${FILESDIR}"/gen_test_char.c
"${S}"/gen_test_char > "${S}"/test_char.h