summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-06-01 09:29:04 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-06-01 09:29:04 +0000
commit295846014a451ef1c07cbf71f76efe5cd56654f2 (patch)
treeced7bef2ed592c750d8c8d517ca19697d361af07 /www-apache
parentadd missing IUSE as per bug #224375 (diff)
downloadgentoo-2-295846014a451ef1c07cbf71f76efe5cd56654f2.tar.gz
gentoo-2-295846014a451ef1c07cbf71f76efe5cd56654f2.tar.bz2
gentoo-2-295846014a451ef1c07cbf71f76efe5cd56654f2.zip
fix #214377
(Portage version: 2.1.5.2)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/anyterm/ChangeLog6
-rw-r--r--www-apache/anyterm/anyterm-1.1.22.ebuild16
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.22-respect-flags.patch64
3 files changed, 81 insertions, 5 deletions
diff --git a/www-apache/anyterm/ChangeLog b/www-apache/anyterm/ChangeLog
index 557fb211f848..dd65a20e72b3 100644
--- a/www-apache/anyterm/ChangeLog
+++ b/www-apache/anyterm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apache/anyterm
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/ChangeLog,v 1.13 2008/03/23 12:08:17 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/ChangeLog,v 1.14 2008/06/01 09:29:03 hollow Exp $
+
+ 01 Jun 2008; Benedikt Böhm <hollow@gentoo.org>
+ +files/anyterm-1.1.22-respect-flags.patch, anyterm-1.1.22.ebuild:
+ fix #214377
23 Mar 2008; Benedikt Böhm <hollow@gentoo.org> anyterm-1.1.16.ebuild:
fix depend.apache usage wrt #208033
diff --git a/www-apache/anyterm/anyterm-1.1.22.ebuild b/www-apache/anyterm/anyterm-1.1.22.ebuild
index 8224a819e04c..381445ceb0d0 100644
--- a/www-apache/anyterm/anyterm-1.1.22.ebuild
+++ b/www-apache/anyterm/anyterm-1.1.22.ebuild
@@ -1,23 +1,23 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/anyterm-1.1.22.ebuild,v 1.1 2008/03/22 16:35:16 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/anyterm-1.1.22.ebuild,v 1.2 2008/06/01 09:29:03 hollow Exp $
inherit apache-module eutils toolchain-funcs webapp
-KEYWORDS="~x86"
-
DESCRIPTION="A terminal anywhere."
HOMEPAGE="http://anyterm.org/"
SRC_URI="http://anyterm.org/download/${P}.tbz2"
+
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="~x86"
IUSE="opera pam ssl"
DEPEND="dev-libs/boost
>=dev-libs/rote-0.2.8
>=sys-devel/gcc-3
virtual/ssh
- pam? ( www-apache/mod_auth_pam )"
+ pam? ( || ( www-apache/mod_authn_pam www-apache/mod_auth_pam ) )"
RDEPEND="${DEPEND}"
APACHE2_MOD_CONF="50_${PN}"
@@ -48,10 +48,18 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${PN}-1.1.15-browser-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-1.1.22-respect-flags.patch
sed -i -e "s:apr-config:apr-1-config:g" apachemod/Makefile
}
src_compile() {
+ local my_LDFLAGS
+ for flag in ${LDFLAGS} ; do
+ my_LDFLAGS="${my_LDFLAGS} -Wl,${flag}"
+ done
+ unset flag
+ export LDFLAGS="${my_LDFLAGS# }"
+
cd apachemod
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die "Apachemod make failed"
cd ..
diff --git a/www-apache/anyterm/files/anyterm-1.1.22-respect-flags.patch b/www-apache/anyterm/files/anyterm-1.1.22-respect-flags.patch
new file mode 100644
index 000000000000..6dae0a41d41a
--- /dev/null
+++ b/www-apache/anyterm/files/anyterm-1.1.22-respect-flags.patch
@@ -0,0 +1,64 @@
+--- apachemod/Makefile
++++ apachemod/Makefile
+@@ -85,7 +85,7 @@
+ -DUSE_SHMEM \
+ -I../boost_shmem
+
+-COMPILE_FLAGS=$(CPP_FLAGS) $(shell $(APR_CONFIG) --cflags) -Wall -O0 -g
++COMPILE_FLAGS=$(CPP_FLAGS) $(shell $(APR_CONFIG) --cflags) -Wall
+
+ C_COMPILE_FLAGS=$(COMPILE_FLAGS) -std=gnu99
+
+@@ -108,23 +108,23 @@
+ OBJS=$(addsuffix .lo,$(basename $(C_SRCS) $(CC_SRCS)))
+
+ %.lo: %.cc
+- $(LIBTOOL) --mode=compile --tag=CXX $(CXX) $(CC_COMPILE_FLAGS) -o $@ -c $<
++ $(LIBTOOL) --mode=compile --tag=CXX $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(CC_COMPILE_FLAGS) -o $@ -c $<
+
+ %.lo: %.c
+- $(LIBTOOL) --mode=compile $(CC) $(C_COMPILE_FLAGS) -o $@ -c $<
++ $(LIBTOOL) --mode=compile $(CC) $(CPPFLAGS) $(CFLAGS) $(C_COMPILE_FLAGS) -o $@ -c $<
+
+
+ compile: $(OBJS) $(LIBPBE_LIB)
+- $(APXS) -c -o anyterm.la $(OBJS) $(LINK_FLAGS)
++ $(APXS) $(LDFLAGS) -c -o anyterm.la $(OBJS) $(LINK_FLAGS)
+
+ install: FORCE
+ $(APXS) -n anyterm -i anyterm.la
+
+ %.d: %.cc
+- $(CXX) -MM -MG -MT $@ -MT $(<:%.cc=%.lo) $(CPP_FLAGS) -o $@ $<
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -MM -MG -MT $@ -MT $(<:%.cc=%.lo) $(CPP_FLAGS) -o $@ $<
+
+ %.d: %.c
+- $(CC) -MM -MG -MT $@ -MT $(<:%.c=%.lo) $(CPP_FLAGS) -o $@ $<
++ $(CC) $(CPPFLAGS) $(CFLAGS) -MM -MG -MT $@ -MT $(<:%.c=%.lo) $(CPP_FLAGS) -o $@ $<
+
+ DEPENDS=$(addsuffix .d,$(basename $(OBJS)))
+
+--- libpbe/build/Makefile
++++ libpbe/build/Makefile
+@@ -53,7 +53,7 @@
+
+ WARN_FLAGS=-W -Wall
+
+-OPTIMISE_FLAGS=-O
++OPTIMISE_FLAGS=
+
+ DEBUG_FLAGS=
+
+@@ -71,10 +71,10 @@
+ $(AR) ruv $(LIBRARY) $(OBJS)
+
+ %.o: %.cc
+- $(CXX) $(COMPILE_FLAGS) -c $<
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(COMPILE_FLAGS) -c $<
+
+ %.d: %.cc
+- $(CXX) -pthread -MM -MT $@ -MT $(notdir $(<:%.cc=%.o)) $(INC_FLAGS) -o $@ $<
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -pthread -MM -MT $@ -MT $(notdir $(<:%.cc=%.o)) $(INC_FLAGS) -o $@ $<
+
+ all: $(EXECUTABLE)
+