summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2013-07-10 02:45:55 +0000
committerJesus Rivero <neurogeek@gentoo.org>2013-07-10 02:45:55 +0000
commit468ddfcebd70512f96f976a0caa3cd97225057e0 (patch)
tree488a64859c98a71c1f1e4815adc0dc868327f70b /www-apache
parentRemove unneeded useflag descriptions from metadata.xml (diff)
downloadgentoo-2-468ddfcebd70512f96f976a0caa3cd97225057e0.tar.gz
gentoo-2-468ddfcebd70512f96f976a0caa3cd97225057e0.tar.bz2
gentoo-2-468ddfcebd70512f96f976a0caa3cd97225057e0.zip
Bumped EAPI=5, added patch to compile against apache-2.4. Closes bug #411299
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 748B2C601F6F0683)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_fastcgi/ChangeLog11
-rw-r--r--www-apache/mod_fastcgi/files/2.4.6-graceful.patch50
-rw-r--r--www-apache/mod_fastcgi/files/mod_fastcgi-compile-against-apache2.4.patch137
-rw-r--r--www-apache/mod_fastcgi/mod_fastcgi-2.4.7_pre0910052141-r1.ebuild30
4 files changed, 176 insertions, 52 deletions
diff --git a/www-apache/mod_fastcgi/ChangeLog b/www-apache/mod_fastcgi/ChangeLog
index 8b2a156ea550..d796c2a9713d 100644
--- a/www-apache/mod_fastcgi/ChangeLog
+++ b/www-apache/mod_fastcgi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apache/mod_fastcgi
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_fastcgi/ChangeLog,v 1.16 2012/11/27 20:23:56 neurogeek Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_fastcgi/ChangeLog,v 1.17 2013/07/10 02:45:54 neurogeek Exp $
+
+*mod_fastcgi-2.4.7_pre0910052141-r1 (10 Jul 2013)
+
+ 10 Jul 2013; <neurogeek@gentoo.org>
+ +files/mod_fastcgi-compile-against-apache2.4.patch,
+ -files/2.4.6-graceful.patch, +mod_fastcgi-2.4.7_pre0910052141-r1.ebuild:
+ Bumped EAPI=5, added patch to compile against apache-2.4. Closes bug #411299
27 Nov 2012; Jesus Rivero <neurogeek@gentoo.org> metadata.xml:
Added myself as maintainer
diff --git a/www-apache/mod_fastcgi/files/2.4.6-graceful.patch b/www-apache/mod_fastcgi/files/2.4.6-graceful.patch
deleted file mode 100644
index b3d5dce179b6..000000000000
--- a/www-apache/mod_fastcgi/files/2.4.6-graceful.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- fcgi_pm.c.orig 2008-04-04 09:34:20.000000000 +0200
-+++ fcgi_pm.c 2008-04-04 09:37:58.000000000 +0200
-@@ -128,8 +128,26 @@
- int numChildren = (s->directive == APP_CLASS_DYNAMIC)
- ? dynamicMaxClassProcs
- : s->numProcesses;
-+
-+ /* Send TERM to all processes */
-+ for (i = 0; i < numChildren; i++, proc++)
-+ {
-+ if (proc->state == FCGI_RUNNING_STATE)
-+ {
-+ fcgi_kill(proc, SIGTERM);
-+ }
-+ }
-
-+ s = s->next;
-+ }
-+
- #ifndef WIN32
-+ /* sleep two seconds to let the children terminate themselves */
-+ sleep(2);
-+ s = fcgi_servers;
-+
-+ while (s)
-+ {
- if (s->socket_path != NULL && s->directive != APP_CLASS_EXTERNAL)
- {
- /* Remove the socket file */
-@@ -140,19 +158,9 @@
- (s->directive == APP_CLASS_DYNAMIC) ? " (dynamic)" : "", s->fs_path);
- }
- }
--#endif
--
-- /* Send TERM to all processes */
-- for (i = 0; i < numChildren; i++, proc++)
-- {
-- if (proc->state == FCGI_RUNNING_STATE)
-- {
-- fcgi_kill(proc, SIGTERM);
-- }
-- }
--
- s = s->next;
- }
-+#endif
-
- #if defined(WIN32) && (WIN32_SHUTDOWN_GRACEFUL_WAIT > 0)
-
diff --git a/www-apache/mod_fastcgi/files/mod_fastcgi-compile-against-apache2.4.patch b/www-apache/mod_fastcgi/files/mod_fastcgi-compile-against-apache2.4.patch
new file mode 100644
index 000000000000..417c03ef83b1
--- /dev/null
+++ b/www-apache/mod_fastcgi/files/mod_fastcgi-compile-against-apache2.4.patch
@@ -0,0 +1,137 @@
+Index: libapache-mod-fastcgi/fcgi.h
+===================================================================
+--- libapache-mod-fastcgi.orig/fcgi.h 2012-03-07 14:29:04.005720240 +0100
++++ libapache-mod-fastcgi/fcgi.h 2012-03-07 14:29:07.830566657 +0100
+@@ -34,6 +34,10 @@
+ #define APACHE2
+ #endif
+
++#ifdef AP_DECLARE_MODULE
++#define APACHE24
++#endif
++
+ #ifdef APACHE2
+
+ #include <sys/stat.h>
+@@ -57,10 +61,16 @@
+ #define XtOffsetOf APR_OFFSETOF
+ #define ap_select select
+
++#ifdef APACHE24
++#define unixd_config ap_unixd_config
++#endif
++
++#ifdef APACHE2
+ #define ap_user_id unixd_config.user_id
+ #define ap_group_id unixd_config.group_id
+ #define ap_user_name unixd_config.user_name
+ #define ap_suexec_enabled unixd_config.suexec_enabled
++#endif
+
+ #ifndef S_ISDIR
+ #define S_ISDIR(m) (((m)&(S_IFMT)) == (S_IFDIR))
+@@ -365,42 +375,42 @@
+ #ifdef APACHE2
+
+ #ifdef WIN32
+-#define FCGI_LOG_EMERG __FILE__,__LINE__,APLOG_EMERG,APR_FROM_OS_ERROR(GetLastError())
+-#define FCGI_LOG_ALERT __FILE__,__LINE__,APLOG_ALERT,APR_FROM_OS_ERROR(GetLastError())
+-#define FCGI_LOG_CRIT __FILE__,__LINE__,APLOG_CRIT,APR_FROM_OS_ERROR(GetLastError())
+-#define FCGI_LOG_ERR __FILE__,__LINE__,APLOG_ERR,APR_FROM_OS_ERROR(GetLastError())
+-#define FCGI_LOG_WARN __FILE__,__LINE__,APLOG_WARNING,APR_FROM_OS_ERROR(GetLastError())
+-#define FCGI_LOG_NOTICE __FILE__,__LINE__,APLOG_NOTICE,APR_FROM_OS_ERROR(GetLastError())
+-#define FCGI_LOG_INFO __FILE__,__LINE__,APLOG_INFO,APR_FROM_OS_ERROR(GetLastError())
+-#define FCGI_LOG_DEBUG __FILE__,__LINE__,APLOG_DEBUG,APR_FROM_OS_ERROR(GetLastError())
++#define FCGI_LOG_EMERG APLOG_MARK,APLOG_EMERG,APR_FROM_OS_ERROR(GetLastError())
++#define FCGI_LOG_ALERT APLOG_MARK,APLOG_ALERT,APR_FROM_OS_ERROR(GetLastError())
++#define FCGI_LOG_CRIT APLOG_MARK,APLOG_CRIT,APR_FROM_OS_ERROR(GetLastError())
++#define FCGI_LOG_ERR APLOG_MARK,APLOG_ERR,APR_FROM_OS_ERROR(GetLastError())
++#define FCGI_LOG_WARN APLOG_MARK,APLOG_WARNING,APR_FROM_OS_ERROR(GetLastError())
++#define FCGI_LOG_NOTICE APLOG_MARK,APLOG_NOTICE,APR_FROM_OS_ERROR(GetLastError())
++#define FCGI_LOG_INFO APLOG_MARK,APLOG_INFO,APR_FROM_OS_ERROR(GetLastError())
++#define FCGI_LOG_DEBUG APLOG_MARK,APLOG_DEBUG,APR_FROM_OS_ERROR(GetLastError())
+ #else /* !WIN32 */
+-#define FCGI_LOG_EMERG __FILE__,__LINE__,APLOG_EMERG,APR_FROM_OS_ERROR(errno)
+-#define FCGI_LOG_ALERT __FILE__,__LINE__,APLOG_ALERT,APR_FROM_OS_ERROR(errno)
+-#define FCGI_LOG_CRIT __FILE__,__LINE__,APLOG_CRIT,APR_FROM_OS_ERROR(errno)
+-#define FCGI_LOG_ERR __FILE__,__LINE__,APLOG_ERR,APR_FROM_OS_ERROR(errno)
+-#define FCGI_LOG_WARN __FILE__,__LINE__,APLOG_WARNING,APR_FROM_OS_ERROR(errno)
+-#define FCGI_LOG_NOTICE __FILE__,__LINE__,APLOG_NOTICE,APR_FROM_OS_ERROR(errno)
+-#define FCGI_LOG_INFO __FILE__,__LINE__,APLOG_INFO,APR_FROM_OS_ERROR(errno)
+-#define FCGI_LOG_DEBUG __FILE__,__LINE__,APLOG_DEBUG,APR_FROM_OS_ERROR(errno)
+-#endif
+-
+-#define FCGI_LOG_EMERG_ERRNO __FILE__,__LINE__,APLOG_EMERG,APR_FROM_OS_ERROR(errno)
+-#define FCGI_LOG_ALERT_ERRNO __FILE__,__LINE__,APLOG_ALERT,APR_FROM_OS_ERROR(errno)
+-#define FCGI_LOG_CRIT_ERRNO __FILE__,__LINE__,APLOG_CRIT,APR_FROM_OS_ERROR(errno)
+-#define FCGI_LOG_ERR_ERRNO __FILE__,__LINE__,APLOG_ERR,APR_FROM_OS_ERROR(errno)
+-#define FCGI_LOG_WARN_ERRNO __FILE__,__LINE__,APLOG_WARNING,APR_FROM_OS_ERROR(errno)
+-#define FCGI_LOG_NOTICE_ERRNO __FILE__,__LINE__,APLOG_NOTICE,APR_FROM_OS_ERROR(errno)
+-#define FCGI_LOG_INFO_ERRNO __FILE__,__LINE__,APLOG_INFO,APR_FROM_OS_ERROR(errno)
+-#define FCGI_LOG_DEBUG_ERRNO __FILE__,__LINE__,APLOG_DEBUG,APR_FROM_OS_ERROR(errno)
+-
+-#define FCGI_LOG_EMERG_NOERRNO __FILE__,__LINE__,APLOG_EMERG,0
+-#define FCGI_LOG_ALERT_NOERRNO __FILE__,__LINE__,APLOG_ALERT,0
+-#define FCGI_LOG_CRIT_NOERRNO __FILE__,__LINE__,APLOG_CRIT,0
+-#define FCGI_LOG_ERR_NOERRNO __FILE__,__LINE__,APLOG_ERR,0
+-#define FCGI_LOG_WARN_NOERRNO __FILE__,__LINE__,APLOG_WARNING,0
+-#define FCGI_LOG_NOTICE_NOERRNO __FILE__,__LINE__,APLOG_NOTICE,0
+-#define FCGI_LOG_INFO_NOERRNO __FILE__,__LINE__,APLOG_INFO,0
+-#define FCGI_LOG_DEBUG_NOERRNO __FILE__,__LINE__,APLOG_DEBUG,0
++#define FCGI_LOG_EMERG APLOG_MARK,APLOG_EMERG,APR_FROM_OS_ERROR(errno)
++#define FCGI_LOG_ALERT APLOG_MARK,APLOG_ALERT,APR_FROM_OS_ERROR(errno)
++#define FCGI_LOG_CRIT APLOG_MARK,APLOG_CRIT,APR_FROM_OS_ERROR(errno)
++#define FCGI_LOG_ERR APLOG_MARK,APLOG_ERR,APR_FROM_OS_ERROR(errno)
++#define FCGI_LOG_WARN APLOG_MARK,APLOG_WARNING,APR_FROM_OS_ERROR(errno)
++#define FCGI_LOG_NOTICE APLOG_MARK,APLOG_NOTICE,APR_FROM_OS_ERROR(errno)
++#define FCGI_LOG_INFO APLOG_MARK,APLOG_INFO,APR_FROM_OS_ERROR(errno)
++#define FCGI_LOG_DEBUG APLOG_MARK,APLOG_DEBUG,APR_FROM_OS_ERROR(errno)
++#endif
++
++#define FCGI_LOG_EMERG_ERRNO APLOG_MARK,APLOG_EMERG,APR_FROM_OS_ERROR(errno)
++#define FCGI_LOG_ALERT_ERRNO APLOG_MARK,APLOG_ALERT,APR_FROM_OS_ERROR(errno)
++#define FCGI_LOG_CRIT_ERRNO APLOG_MARK,APLOG_CRIT,APR_FROM_OS_ERROR(errno)
++#define FCGI_LOG_ERR_ERRNO APLOG_MARK,APLOG_ERR,APR_FROM_OS_ERROR(errno)
++#define FCGI_LOG_WARN_ERRNO APLOG_MARK,APLOG_WARNING,APR_FROM_OS_ERROR(errno)
++#define FCGI_LOG_NOTICE_ERRNO APLOG_MARK,APLOG_NOTICE,APR_FROM_OS_ERROR(errno)
++#define FCGI_LOG_INFO_ERRNO APLOG_MARK,APLOG_INFO,APR_FROM_OS_ERROR(errno)
++#define FCGI_LOG_DEBUG_ERRNO APLOG_MARK,APLOG_DEBUG,APR_FROM_OS_ERROR(errno)
++
++#define FCGI_LOG_EMERG_NOERRNO APLOG_MARK,APLOG_EMERG,0
++#define FCGI_LOG_ALERT_NOERRNO APLOG_MARK,APLOG_ALERT,0
++#define FCGI_LOG_CRIT_NOERRNO APLOG_MARK,APLOG_CRIT,0
++#define FCGI_LOG_ERR_NOERRNO APLOG_MARK,APLOG_ERR,0
++#define FCGI_LOG_WARN_NOERRNO APLOG_MARK,APLOG_WARNING,0
++#define FCGI_LOG_NOTICE_NOERRNO APLOG_MARK,APLOG_NOTICE,0
++#define FCGI_LOG_INFO_NOERRNO APLOG_MARK,APLOG_INFO,0
++#define FCGI_LOG_DEBUG_NOERRNO APLOG_MARK,APLOG_DEBUG,0
+
+ #else /* !APACHE2 */
+
+Index: libapache-mod-fastcgi/mod_fastcgi.c
+===================================================================
+--- libapache-mod-fastcgi.orig/mod_fastcgi.c 2012-03-07 14:29:04.017047773 +0100
++++ libapache-mod-fastcgi/mod_fastcgi.c 2012-03-07 14:29:07.841272721 +0100
+@@ -97,6 +97,10 @@
+ } while (0)
+ #endif
+
++#ifdef APACHE24
++module AP_MODULE_DECLARE_DATA fastcgi_module;
++#endif
++
+ /*
+ * Global variables
+ */
+@@ -3014,7 +3018,11 @@
+ ap_hook_fixups(fixups, NULL, NULL, APR_HOOK_MIDDLE);
+ }
+
++#ifdef APACHE24
++AP_DECLARE_MODULE(fastcgi) =
++#else
+ module AP_MODULE_DECLARE_DATA fastcgi_module =
++#endif
+ {
+ STANDARD20_MODULE_STUFF,
+ fcgi_config_create_dir_config, /* per-directory config creator */
diff --git a/www-apache/mod_fastcgi/mod_fastcgi-2.4.7_pre0910052141-r1.ebuild b/www-apache/mod_fastcgi/mod_fastcgi-2.4.7_pre0910052141-r1.ebuild
new file mode 100644
index 000000000000..feafd1ced217
--- /dev/null
+++ b/www-apache/mod_fastcgi/mod_fastcgi-2.4.7_pre0910052141-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_fastcgi/mod_fastcgi-2.4.7_pre0910052141-r1.ebuild,v 1.1 2013/07/10 02:45:54 neurogeek Exp $
+
+EAPI="5"
+inherit apache-module eutils
+
+MY_P="${PN}-SNAP-${PV/2.4.7_pre/}"
+DESCRIPTION="FastCGI is a open extension to CGI without the limitations of server specific APIs."
+HOMEPAGE="http://fastcgi.com/"
+SRC_URI="http://www.fastcgi.com/dist/${MY_P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="mod_fastcgi"
+IUSE=""
+
+APXS2_ARGS="-c mod_fastcgi.c fcgi*.c"
+APACHE2_MOD_CONF="20_${PN}"
+APACHE2_MOD_DEFINE="FASTCGI"
+
+DOCFILES="CHANGES README docs/LICENSE.TERMS docs/mod_fastcgi.html"
+
+S="${WORKDIR}/${MY_P}"
+
+need_apache2
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-compile-against-apache2.4.patch"
+}