summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2012-05-13 08:36:27 +0000
committerLance Albertson <ramereth@gentoo.org>2012-05-13 08:36:27 +0000
commita132aff9b1ceff1d6520f961bed6772f6871722a (patch)
treedbebccd35ef49af434244ccd3b5b6b7de9a84de7 /www-apache
parentVersion bump. (diff)
downloadgentoo-2-a132aff9b1ceff1d6520f961bed6772f6871722a.tar.gz
gentoo-2-a132aff9b1ceff1d6520f961bed6772f6871722a.tar.bz2
gentoo-2-a132aff9b1ceff1d6520f961bed6772f6871722a.zip
Version bump, also fixes #410927
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_fcgid/ChangeLog11
-rw-r--r--www-apache/mod_fcgid/mod_fcgid-2.3.7.ebuild27
2 files changed, 36 insertions, 2 deletions
diff --git a/www-apache/mod_fcgid/ChangeLog b/www-apache/mod_fcgid/ChangeLog
index c01029b58eca..44df996529ec 100644
--- a/www-apache/mod_fcgid/ChangeLog
+++ b/www-apache/mod_fcgid/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apache/mod_fcgid
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_fcgid/ChangeLog,v 1.49 2011/01/11 17:52:02 xarthisius Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_fcgid/ChangeLog,v 1.50 2012/05/13 08:36:26 ramereth Exp $
+
+*mod_fcgid-2.3.7 (13 May 2012)
+
+ 13 May 2012; Lance Albertson <ramereth@gentoo.org> +mod_fcgid-2.3.7.ebuild:
+ Version bump, also fixes #410927
+
+ Changed to need_apache2 since it supports both 2.2 and 2.4 via upstream.
11 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org>
mod_fcgid-2.3.6.ebuild:
diff --git a/www-apache/mod_fcgid/mod_fcgid-2.3.7.ebuild b/www-apache/mod_fcgid/mod_fcgid-2.3.7.ebuild
new file mode 100644
index 000000000000..1b3aed523e60
--- /dev/null
+++ b/www-apache/mod_fcgid/mod_fcgid-2.3.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_fcgid/mod_fcgid-2.3.7.ebuild,v 1.1 2012/05/13 08:36:27 ramereth Exp $
+
+inherit apache-module eutils multilib
+
+DESCRIPTION="mod_fcgid is a binary-compatible alternative to mod_fastcgi with better process management."
+HOMEPAGE="http://httpd.apache.org/mod_fcgid/"
+SRC_URI="mirror://apache/httpd/mod_fcgid/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+APACHE2_MOD_CONF="2.2/20_${PN}"
+APACHE2_MOD_DEFINE="FCGID"
+
+DOCFILES="CHANGES-FCGID README-FCGID STATUS-FCGID"
+
+need_apache2
+
+src_compile () {
+ ./configure.apxs || die "apxs configure failed!"
+ make || die "make failed"
+ ln -sf modules/fcgid/.libs .libs || die "symlink creation failed"
+}