summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2014-02-07 20:08:42 +0000
committerChris Reffett <creffett@gentoo.org>2014-02-07 20:08:42 +0000
commitf907a8205a018e59c92fa33347e770f2641e9a64 (patch)
treecba646ce9abf642a9819d05b9ca474c932a7b874 /www-apache
parentDo not install libnvidia-fbc.so (bug #500634). (diff)
downloadgentoo-2-f907a8205a018e59c92fa33347e770f2641e9a64.tar.gz
gentoo-2-f907a8205a018e59c92fa33347e770f2641e9a64.tar.bz2
gentoo-2-f907a8205a018e59c92fa33347e770f2641e9a64.zip
Revision bump: bump EAPI, use emake instead of make, fix DESCRIPTION, split configure step into src_configure
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_fcgid/ChangeLog8
-rw-r--r--www-apache/mod_fcgid/mod_fcgid-2.3.9-r1.ebuild31
2 files changed, 38 insertions, 1 deletions
diff --git a/www-apache/mod_fcgid/ChangeLog b/www-apache/mod_fcgid/ChangeLog
index f4c46dab408b..a27bc1760da0 100644
--- a/www-apache/mod_fcgid/ChangeLog
+++ b/www-apache/mod_fcgid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_fcgid
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_fcgid/ChangeLog,v 1.61 2014/02/07 20:00:11 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_fcgid/ChangeLog,v 1.62 2014/02/07 20:08:42 creffett Exp $
+
+*mod_fcgid-2.3.9-r1 (07 Feb 2014)
+
+ 07 Feb 2014; Chris Reffett <creffett@gentoo.org> +mod_fcgid-2.3.9-r1.ebuild:
+ Revision bump: bump EAPI, use emake instead of make, fix DESCRIPTION, split
+ configure step into src_configure
07 Feb 2014; Chris Reffett <creffett@gentoo.org> -mod_fcgid-2.3.7.ebuild:
Drop vulnerable versions wrt bug 487314
diff --git a/www-apache/mod_fcgid/mod_fcgid-2.3.9-r1.ebuild b/www-apache/mod_fcgid/mod_fcgid-2.3.9-r1.ebuild
new file mode 100644
index 000000000000..f78e045243d5
--- /dev/null
+++ b/www-apache/mod_fcgid/mod_fcgid-2.3.9-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_fcgid/mod_fcgid-2.3.9-r1.ebuild,v 1.1 2014/02/07 20:08:42 creffett Exp $
+
+EAPI=5
+inherit apache-module eutils multilib
+
+DESCRIPTION="A binary-compatible alternative to mod_fastcgi with better process management."
+HOMEPAGE="http://httpd.apache.org/mod_fcgid/"
+SRC_URI="mirror://apache/httpd/mod_fcgid/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+APACHE2_MOD_CONF="2.2/20_${PN}"
+APACHE2_MOD_DEFINE="FCGID"
+
+DOCFILES="CHANGES-FCGID README-FCGID STATUS-FCGID"
+
+need_apache2
+
+src_configure() {
+ ./configure.apxs || die "apxs configure failed"
+}
+
+src_compile () {
+ emake
+ ln -sf modules/fcgid/.libs .libs || die "symlink creation failed"
+}