summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2014-06-06 18:37:10 +0000
committerFabian Groffen <grobian@gentoo.org>2014-06-06 18:37:10 +0000
commitfce4bfcb2b40f591e9749d054a709c87eadfba43 (patch)
treef832c8919deec1e11bf139fdf65130113f5abaf3 /www-apps/baikal
parentAdd USE flags to control the install of the net/pci/usb databases. Unify the ... (diff)
downloadgentoo-2-fce4bfcb2b40f591e9749d054a709c87eadfba43.tar.gz
gentoo-2-fce4bfcb2b40f591e9749d054a709c87eadfba43.tar.bz2
gentoo-2-fce4bfcb2b40f591e9749d054a709c87eadfba43.zip
Version bump (bug #511956) and fix possibly invalid chown, bug #468508
(Portage version: HEAD/cvs/SunOS i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'www-apps/baikal')
-rw-r--r--www-apps/baikal/ChangeLog10
-rw-r--r--www-apps/baikal/baikal-0.2.7.ebuild59
-rw-r--r--www-apps/baikal/files/postinstall-en.txt1
3 files changed, 68 insertions, 2 deletions
diff --git a/www-apps/baikal/ChangeLog b/www-apps/baikal/ChangeLog
index 85b4b6e00c18..ae984752df9a 100644
--- a/www-apps/baikal/ChangeLog
+++ b/www-apps/baikal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/baikal
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/baikal/ChangeLog,v 1.2 2013/04/20 15:23:34 grobian Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/baikal/ChangeLog,v 1.3 2014/06/06 18:37:10 grobian Exp $
+
+*baikal-0.2.7 (06 Jun 2014)
+
+ 06 Jun 2014; Fabian Groffen <grobian@gentoo.org> +baikal-0.2.7.ebuild,
+ files/postinstall-en.txt:
+ Version bump (bug #511956) and fix possibly invalid chown, bug #468508
20 Apr 2013; Fabian Groffen <grobian@gentoo.org> +files/postinstall-en.txt,
baikal-0.2.4.ebuild:
diff --git a/www-apps/baikal/baikal-0.2.7.ebuild b/www-apps/baikal/baikal-0.2.7.ebuild
new file mode 100644
index 000000000000..ccfd6708f00a
--- /dev/null
+++ b/www-apps/baikal/baikal-0.2.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/baikal/baikal-0.2.7.ebuild,v 1.1 2014/06/06 18:37:10 grobian Exp $
+
+EAPI="5"
+
+inherit depend.php webapp
+
+DESCRIPTION="Lightweight CalDAV+CardDAV server"
+HOMEPAGE="http://baikal-server.com/"
+SRC_URI="http://baikal-server.com/get/${PN}-regular-${PV}.tgz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64"
+IUSE="+mysql sqlite"
+REQUIRED_USE="|| ( mysql sqlite )"
+
+RDEPEND=">=dev-lang/php-5.3[pdo,xml,mysql?,sqlite?]
+ mysql? ( virtual/mysql )
+ sqlite? ( dev-db/sqlite )
+ virtual/httpd-php"
+
+need_php5
+need_httpd
+
+S=${WORKDIR}/${PN}-regular
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc-php *.md || die "dodoc failed"
+
+ einfo "Installing web files"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r html/* html/.htaccess Core vendor || die "doins failed"
+
+ einfo "Setting up container for configuration"
+ insinto /etc/${PN}
+ doins Specific/.htaccess || die "doins failed"
+
+ einfo "Fixing symlinks"
+ local link target
+ find "${D}${MY_HTDOCSDIR}" -type l | while read link ; do
+ target=$(readlink "${link}")
+ target=${target/..\/Core/Core}
+ rm "${link}" && ln -s "${target}" "${link}"
+ done
+ dosym /etc/${PN} "${MY_HTDOCSDIR}"/Specific
+ dosym . "${MY_HTDOCSDIR}"/html
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+ webapp_src_install
+
+ if has_version www-servers/apache ; then
+ fowners -R apache:apache /etc/${PN}
+ else
+ einfo "/etc/${PN} must be owned by the webserver user for baikal"
+ fi
+}
diff --git a/www-apps/baikal/files/postinstall-en.txt b/www-apps/baikal/files/postinstall-en.txt
index 5115d56cba49..aafca857472d 100644
--- a/www-apps/baikal/files/postinstall-en.txt
+++ b/www-apps/baikal/files/postinstall-en.txt
@@ -1,3 +1,4 @@
In order to setup baïkal:
- create /etc/${PN}/ENABLE_INSTALL owner apache:apache
- point your browser at the instal's URL and follow the setup
+To upgrade baïkal, you have to follow the setup instructions