summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2014-06-12 03:07:40 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2014-06-12 03:07:40 +0000
commit8d34b149600e2d3008decc1ba73edb74298efc5b (patch)
tree1993a87956b9245b62b0e0c0850111f30e2e7b72 /www-apps/blohg-tumblelog/blohg-tumblelog-0.2.ebuild
parentinitial commit (diff)
downloadgentoo-2-8d34b149600e2d3008decc1ba73edb74298efc5b.tar.gz
gentoo-2-8d34b149600e2d3008decc1ba73edb74298efc5b.tar.bz2
gentoo-2-8d34b149600e2d3008decc1ba73edb74298efc5b.zip
initial commit
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'www-apps/blohg-tumblelog/blohg-tumblelog-0.2.ebuild')
-rw-r--r--www-apps/blohg-tumblelog/blohg-tumblelog-0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/www-apps/blohg-tumblelog/blohg-tumblelog-0.2.ebuild b/www-apps/blohg-tumblelog/blohg-tumblelog-0.2.ebuild
new file mode 100644
index 000000000000..8554061654fd
--- /dev/null
+++ b/www-apps/blohg-tumblelog/blohg-tumblelog-0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/blohg-tumblelog/blohg-tumblelog-0.2.ebuild,v 1.1 2014/06/12 03:07:40 rafaelmartins Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A blohg extension with reStructuredText directives to run a tumblelog"
+HOMEPAGE="https://github.com/rafaelmartins/blohg-tumblelog"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=
+ KEYWORDS=
+ EGIT_REPO_URI="git://github.com/rafaelmartins/blohg-tumblelog.git
+ https://github.com/rafaelmartins/blohg-tumblelog.git"
+ inherit git-r3
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=www-apps/blohg-0.12
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pyoembed[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"