summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-19 12:37:37 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-19 12:37:37 +0000
commit78bd440c8503fcaa1ef5ddfef1922823b5523e09 (patch)
treee183bda0928ce7401364ba5aa63cf12c05deba5e /www-apps/dokuwiki
parentVersion bump (diff)
downloadgentoo-2-78bd440c8503fcaa1ef5ddfef1922823b5523e09.tar.gz
gentoo-2-78bd440c8503fcaa1ef5ddfef1922823b5523e09.tar.bz2
gentoo-2-78bd440c8503fcaa1ef5ddfef1922823b5523e09.zip
ebuild cleanup wrt #208584
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-apps/dokuwiki')
-rw-r--r--www-apps/dokuwiki/ChangeLog10
-rw-r--r--www-apps/dokuwiki/dokuwiki-20070626b.ebuild76
2 files changed, 35 insertions, 51 deletions
diff --git a/www-apps/dokuwiki/ChangeLog b/www-apps/dokuwiki/ChangeLog
index f070a79dd071..9b9f52f29bb8 100644
--- a/www-apps/dokuwiki/ChangeLog
+++ b/www-apps/dokuwiki/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/dokuwiki
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/ChangeLog,v 1.28 2007/10/22 20:47:35 armin76 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/ChangeLog,v 1.29 2008/02/19 12:37:37 hollow Exp $
+
+ 19 Feb 2008; Benedikt Böhm <hollow@gentoo.org> dokuwiki-20070626b.ebuild:
+ ebuild cleanup wrt #208584
+
+ 05 Feb 2008; Jakub Moc <jakub@gentoo.org> dokuwiki-20070626b.ebuild:
+ Check for all PHP features at once. Quoting, cleanup.
22 Oct 2007; Raúl Porcel <armin76@gentoo.org> dokuwiki-20070626b.ebuild:
Add ~sparc wrt #195404
diff --git a/www-apps/dokuwiki/dokuwiki-20070626b.ebuild b/www-apps/dokuwiki/dokuwiki-20070626b.ebuild
index f0df541295e3..bce406eb95ec 100644
--- a/www-apps/dokuwiki/dokuwiki-20070626b.ebuild
+++ b/www-apps/dokuwiki/dokuwiki-20070626b.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/dokuwiki-20070626b.ebuild,v 1.3 2007/10/22 20:47:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/dokuwiki-20070626b.ebuild,v 1.4 2008/02/19 12:37:37 hollow Exp $
inherit webapp depend.php
-# Upstream uses dashes in the datestamp
+# upstream uses dashes in the datestamp
MY_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}${PV:8:1}"
-DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small companies
-documentation needs."
+DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small companies documentation needs."
HOMEPAGE="http://wiki.splitbrain.org/wiki:dokuwiki"
SRC_URI="http://www.splitbrain.org/_media/projects/${PN}/${PN}-${MY_PV}.tgz"
@@ -16,75 +15,54 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~sparc x86"
IUSE=""
-DEPEND="virtual/php"
-RDEPEND="${DEPEND}"
+DEPEND=""
+RDEPEND=""
-pkg_setup() {
- # let the eclass pick right php version...
- require_php_cli
+need_php_httpd
- # ...and we check if correct USE flag for XML support is enabled
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
if [[ ${PHP_VERSION} == "4" ]] ; then
- require_php_with_use expat
+ require_php_with_use cli expat
else
- require_php_with_use xml
+ require_php_with_use cli xml
fi
-
- webapp_pkg_setup
}
src_unpack() {
- cd ${WORKDIR}
- unpack ${PN}-${MY_PV}.tgz
+ unpack ${A}
mv ${PN}-${MY_PV} ${P}
-}
+ cd "${S}"
-src_compile() {
- # Default compile hangs
- echo "Nothing to compile"
+ # create initial changes file
+ touch data/changes.log
}
src_install() {
- local docs="README"
webapp_src_preinst
- # NOTE: doc files should go into /usr/share/doc, and NOT installed in the vhost
- einfo "Installing docs"
- dodoc ${docs}
- for doc in ${docs} COPYING; do
- rm -f ${doc}
- done
+ dodoc README
+ rm -f README COPYING VERSION
- # Move bin directory to safe location (outside of docroot)
- # To resolve security bug #146800
docinto scripts
dodoc bin/*
rm -rf bin
- einfo "Copying main files"
- cp -r . ${D}/${MY_HTDOCSDIR}
-
- # Install the htaccess file for pretty urls
- cp .htaccess ${D}/${MY_HTDOCSDIR}
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
- # Create initial changes file
- touch ${D}/${MY_HTDOCSDIR}/data/changes.log data/changes.log
-
- # The data dir needs to be owned by the server
- for x in `find . -print | grep "data/*" | grep -v .htaccess` ; do
- webapp_serverowned ${MY_HTDOCSDIR}/$x
+ for x in $(find data/ -not -name '.htaccess'); do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${x}
done
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
- webapp_configfile ${MY_HTDOCSDIR}/.htaccess
-
- webapp_configfile ${MY_HTDOCSDIR}/conf
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf
- # Mark all conf/* files as config files, except msg, which should be
- # updated unconditionally.
- for x in $( ls -1 ${D}/${MY_HTDOCSDIR}/conf | grep -v ^msg$ ) ; do
- webapp_configfile ${MY_HTDOCSDIR}/conf/$x
+ for x in $(find conf/ -not -name 'msg'); do
+ webapp_configfile "${MY_HTDOCSDIR}"/${x}
done
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
webapp_src_install
}