summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJochen Maes <sejo@gentoo.org>2005-06-26 06:33:35 +0000
committerJochen Maes <sejo@gentoo.org>2005-06-26 06:33:35 +0000
commit89b7133155f457ab344d9228a098e26f26dc0b75 (patch)
tree25f364f1326343143b164f2cae8c96d27e75693b /www-apps/dragonflycms/dragonflycms-9.0.4.0.ebuild
parentstable on ppc64 (diff)
downloadgentoo-2-89b7133155f457ab344d9228a098e26f26dc0b75.tar.gz
gentoo-2-89b7133155f457ab344d9228a098e26f26dc0b75.tar.bz2
gentoo-2-89b7133155f457ab344d9228a098e26f26dc0b75.zip
new version
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'www-apps/dragonflycms/dragonflycms-9.0.4.0.ebuild')
-rw-r--r--www-apps/dragonflycms/dragonflycms-9.0.4.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/www-apps/dragonflycms/dragonflycms-9.0.4.0.ebuild b/www-apps/dragonflycms/dragonflycms-9.0.4.0.ebuild
new file mode 100644
index 000000000000..61cddd06d50c
--- /dev/null
+++ b/www-apps/dragonflycms/dragonflycms-9.0.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dragonflycms/dragonflycms-9.0.4.0.ebuild,v 1.1 2005/06/26 06:33:35 sejo Exp $
+
+inherit webapp
+
+MY_P=Dragonfly${PV}
+DESCRIPTION="CPG Dragonfly CMS is a feature-rich open source content management
+system based off of PHP-Nuke 6.5"
+HOMEPAGE="http://dragonflycms.org"
+SRC_URI="mirror://gentoo/$MY_P.tar.bz2
+http://dev.gentoo.org/~sejo/files/Dragonfly9.0.3.0.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-db/mysql-3.23.32 <dev-db/mysql-5.1
+ virtual/httpd-php"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_install() {
+
+ webapp_src_preinst
+
+ #Do the documentation
+ insinto /usr/share/doc/${PF}
+ doins -r ${WORKDIR}/documentation/*
+
+ #installing files where they need to be.
+ einfo "installing php main files"
+ cp -r ${WORKDIR}/public_html/* ${D}${MY_HTDOCSDIR}
+ einfo "Done"
+
+ #identiy the configuration file the app uses
+
+ webapp_configfile ${MY_HTDOCSDIR}/config.php
+
+ # add the postinstall instructions
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ # done, now strut the stuff
+
+ webapp_src_install
+
+}