summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJochen Maes <sejo@gentoo.org>2005-10-04 11:28:07 +0000
committerJochen Maes <sejo@gentoo.org>2005-10-04 11:28:07 +0000
commit86dd9a6a0601796151da1799caed0c394c2ed6ed (patch)
tree27a570263c69315841cf0e4505f66c66f9a7de1c /www-apps/dragonflycms
parentAdded ~sh (diff)
downloadgentoo-2-86dd9a6a0601796151da1799caed0c394c2ed6ed.tar.gz
gentoo-2-86dd9a6a0601796151da1799caed0c394c2ed6ed.tar.bz2
gentoo-2-86dd9a6a0601796151da1799caed0c394c2ed6ed.zip
new version also fixes the security bug 104422
(Portage version: 2.0.52-r1)
Diffstat (limited to 'www-apps/dragonflycms')
-rw-r--r--www-apps/dragonflycms/Manifest22
-rw-r--r--www-apps/dragonflycms/dragonflycms-9.0.6.1.ebuild60
-rw-r--r--www-apps/dragonflycms/files/digest-dragonflycms-9.0.6.11
3 files changed, 68 insertions, 15 deletions
diff --git a/www-apps/dragonflycms/Manifest b/www-apps/dragonflycms/Manifest
index 865a984fcaaf..fd91006521a4 100644
--- a/www-apps/dragonflycms/Manifest
+++ b/www-apps/dragonflycms/Manifest
@@ -1,19 +1,11 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 5ca169fcfd41c2e46f99f51f5967b236 metadata.xml 574
-MD5 61bf86b88c5802f1960720e2610c42f0 dragonflycms-9.0.5.0.ebuild 1539
-MD5 1bbf11c642643230e581cb138f93cb98 dragonflycms-9.0.3.0.ebuild 1524
MD5 ede77ca0f059c716b755868e73a180f6 ChangeLog 1272
+MD5 1bbf11c642643230e581cb138f93cb98 dragonflycms-9.0.3.0.ebuild 1524
MD5 5489d8ebd937cd75db0cb4937d0082b3 dragonflycms-9.0.4.0.ebuild 1477
-MD5 1d15a225bbe4934b0abc439d9131ee41 files/postinstall-en.txt 826
-MD5 30e21c32d1b9515d3805387218d50fa2 files/digest-dragonflycms-9.0.4.0 70
+MD5 61bf86b88c5802f1960720e2610c42f0 dragonflycms-9.0.5.0.ebuild 1539
+MD5 5ca169fcfd41c2e46f99f51f5967b236 metadata.xml 574
+MD5 61bf86b88c5802f1960720e2610c42f0 dragonflycms-9.0.6.1.ebuild 1539
MD5 0de8c25d7b281327a6e87009d44c9f20 files/digest-dragonflycms-9.0.3.0 70
+MD5 30e21c32d1b9515d3805387218d50fa2 files/digest-dragonflycms-9.0.4.0 70
MD5 d51ee9843ef583fd547b75e420105250 files/digest-dragonflycms-9.0.5.0 70
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDAXZqgIKl8Uu19MoRAvTVAJ991UNbRoiA07gF2nQyOXpc7p9ToQCeJIAt
-kqBwkLe4byY62R6sZMET8tU=
-=6ofl
------END PGP SIGNATURE-----
+MD5 1d15a225bbe4934b0abc439d9131ee41 files/postinstall-en.txt 826
+MD5 772df86b0bb435027373f5e22676ee11 files/digest-dragonflycms-9.0.6.1 70
diff --git a/www-apps/dragonflycms/dragonflycms-9.0.6.1.ebuild b/www-apps/dragonflycms/dragonflycms-9.0.6.1.ebuild
new file mode 100644
index 000000000000..7d95fcee6da4
--- /dev/null
+++ b/www-apps/dragonflycms/dragonflycms-9.0.6.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dragonflycms/dragonflycms-9.0.6.1.ebuild,v 1.1 2005/10/04 11:28:07 sejo Exp $
+
+inherit webapp
+
+MY_P=Dragonfly${PV}
+DESCRIPTION="CPG Dragonfly CMS is a feature-rich open source content management
+system based off of PHP-Nuke 6.5"
+HOMEPAGE="http://dragonflycms.org"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2
+http://dev.gentoo.org/~sejo/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~arm ~ppc ~s390 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-db/mysql-3.23.32 <dev-db/mysql-5.1
+ virtual/httpd-php"
+DEPEND=""
+
+src_install() {
+
+ webapp_src_preinst
+
+ #Do the documentation
+ insinto /usr/share/doc/${PF}
+ doins -r ${WORKDIR}/documentation/*
+
+ #installing files where they need to be.
+ einfo "installing php main files"
+ cp -r ${WORKDIR}/public_html/* ${D}${MY_HTDOCSDIR}
+ einfo "Done"
+
+ #identiy the configuration file the app uses
+
+ webapp_configfile ${MY_HTDOCSDIR}/config.php
+
+ # add the postinstall instructions
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ # done, now strut the stuff
+
+ webapp_src_install
+
+ # manually changing the permissions on the directories
+ # if no-suexec then perms should be 777 else 755
+
+ if useq no-suexec; then
+ PERMS=777
+ else
+ PERMS=755
+ fi
+ fperms 600 ${D}/cpg_error.log
+ fperms ${PERMS} ${D}/cache
+ fperms ${PERMS} ${D}/modules/coppermine/albums
+ fperms ${PERMS} ${D}/modules/coppermine/albums/userpics
+ fperms ${PERMS} ${D}/uploads/{avatars,forums}
+}
diff --git a/www-apps/dragonflycms/files/digest-dragonflycms-9.0.6.1 b/www-apps/dragonflycms/files/digest-dragonflycms-9.0.6.1
new file mode 100644
index 000000000000..d2693ab9a574
--- /dev/null
+++ b/www-apps/dragonflycms/files/digest-dragonflycms-9.0.6.1
@@ -0,0 +1 @@
+MD5 c4aa9862b2474b090e1158bd6a603708 Dragonfly9.0.6.1.tar.bz2 1376475